Another Filament Changing Issue

I am printing the calibration cubes individually, roughly in the middle of the printer bed. I’m using a p1p, no sides. Part cooling is set to its default settings in the bambu slicer. When the pause command happens, the extruder moves over to the waste chute. I am not sure how to answer your question about fan settings during the pause - not sure since the print head moves away from the part anyway. I am nearby to the printer, so I essentially immediately unload the filament and load new filament. The filament changeover takes … roughly 60 - 90 seconds before I resume print.

Yes, the print does begin to warp before the color change on the two color parts.

Ok, so according to the slicer, it should be cooling at 100% the whole print - this is the fan speed setting for the slice with a manually added pause:

Just out of curiosity, why are you manually adding G-Code to Pause?

Bambu Studio and OrcaSlicer both have ‘Pause’ built in. Right click the Layer Slider on the right:
BL Studio - Pause Print Add G-Code

Also - are you using Studio or OrcaSlicer? You’re running XYZ cubes which is usually done when someone is tuning. OrcaSlicer offers many more built in tools to Calibrate. Check here:

Hmmm, that kinda disproves my theory.

Especially since you’re not enclosed (so probably no heat creep or anything like that) and you’re not letting it sit for very long. Weird that it starts to deform even before the color change but doesn’t do that for single color.

Can you check the travel speed? Does it slow down before the pause? What other variables could be different?

I am using bambu studio. I am manually adding the g-code to pause because of an apparent layer shifting issue with the manual pause button on the printer and the “add pause” option in Bambu Studio. Upon resume when using either the pause button or the “add pause” option in the slicer, I get about -.5 to -1mm of X axis layer shift after changing filament. If I just pause and resume there is no layer shift. I think the running theory has something to do with the load\unload commands and the cutter.

When I use the manual g-code option, I do not get the layershift, but I do get the strange problem described in this post.

I am planning to try a different slicer today to see if I get the same result. I can also set the pause command in studio let one of the layer shifted prints finish to see if it experiences the same warping.

I am not sure if any variables are changing as a result of manually adding the pause. I am going to test some additional things today and post results. I’m running bambu’s default travel speed settings for generic pla. Mono-color parts are printing amazingly well - the capabilities of this machine are incredible. I am still printing some functional and decorative parts between all the testing. These corner panels for the P1P printed overnight beautifully. No warping, everything solid and straight. I swear I am slicing these things the exact same way as the calibration cube with the single and only exception of the manual g-code stop and filament change.

Btw, I used the Orca Slicer for my test, not the Bambu Studio. I am not sure it makes a difference, but worth a try.

I’ve never used Orca, but I am going to d/l and give a try today. Oh, and @Thrawn, thanks a bunch for taking a deeper dive into this /w me. I appreciate your responses and advice.

Hmmm (he says, thoughtfully stroking his beard…) that’s … odd.

Perhaps do a manual pause on one layer then later the built in Pause?

I didn’t deep read all the posts, but did you do a full set of filament profile calibrations in OrcaSlicer?

Also - on that subject, I have found different color of filament from the same brand can have dramatically different profiles, never mind across brands, that’s bigger.

Here’s a long post I did as a PSA on OrcaSlicer vs Bambu Studio if you are interested:

For sure, I don’t doubt that. I’m more wondering if the slicer is changing something that you didn’t change when you do the filament change.

There has to be some variation that’s occurring to cause that, no?

Can you try one going half speed and see what happens?

I’m using bambu studio, and no, I’m using the generic PLA profile. I am yet unsure how to perform filament profile calibrations - I’m am still pretty new to all of this.

What I can say is that I can slice a calibration cube and print it in green fine. I can then unload green and load grey and print another grey cube just fine. Then add the pause command at layer 51, click slice plate, and send the print with the grey still loaded. At layer 51 it pauses and the extruder moves over the chute. I unload the grey and load the green, extrude until I see green, then hit resume on the printer. The printer homes and then begins printing again in green, but with this problem occurring. Independently running as a mono-color, both colors complete the cube fine without issue using the same slicer settings. I’m not adusting anything else in the slicer except for the manual pause which requires a reslice before printing.

Yes, that’s a good call, I’ll run one on silent today and see what happens. I will also try adding a manual pause but without changing filament to see if adding the command or pausing alone is doing something. I’m currently printing a couple corner panels so it may be a couple hours. :slight_smile:

Oh jeez, this is awesome. I commented to Thrawn that I’d try Orca today, and if I wasn’t already convinced to give it a try, your post did the trick. I’m going to take a look at it as soon as my current print finishes.

1 Like

Can you also try printing two on the same plate but pausing one and not changing filament and completing the other in a single color?

Your welcome, that’s why I wrote it. This 3D printing can be complex. :grin:

If you read the link to OrcaSlicer Calibrations page I posted you’ll see he gives great Step-by-Step directions of how to calibrate for each filament.

Generally you have to do that only once as long as you’re using quality filament because most have good consistency from batch to batch now.

BTW - something I didn’t get at first is on this forum you can reply to multiple people with one post. You just highlight the sentence or thought and click the little “Quote” button. It inserts their comment. Wash rinse and repeat. Easier than posting 3 times to three people. :wink: :grin:

1 Like

@Thrawn @Matt @ThanksForAsking

So, I think I figured it out:

C is the control
1 is representative of my initial attempt
2 is the same as the initial attempt with quality filament
3 is my first attempt with Orca Slicer instead of Studio
4 when I realized what was happening…

So, the first color isn’t warping during the print, it isn’t until the second color is added and printing begins that the new color deforms the original. Part cooling turns off with the pause command and the extruder moves back to the trash chute. Once the new filament is added, I click resume and printing resumes. However, part cooling does not instantly turn back on. It prints several (varying amount of??) layers before cooling turns back on. Sometimes it turns back on quickly, sometimes it does not. You can see the layer line in 1, 2, & 3 when the cooling kicks back on and the print “autocorrects” its size. In print 4, I reloaded the filament and immediately restarted the fans upon printing using the Handy app.

As an aside, I did attempt this

M400 U1
G28 X Y
M106 P2 S100

to try to immediately start the fans after homing, but this didn’t work. I just jacked the M106 command from somewhere in the initialization gcode that was commented “turn on the big fan” so I have no idea if that is even right.

Here is a closer look at 3 and 4:

There is a tiny bit of a lip on the new color in block 4, but I am happy enough with this result. There is a little droop in the over hang on the X, but it isn’t very noticeable on the print when holding it. Not sure if I still maybe have a slight cooling issue going on… regardless, I think the cause of the deformation is figured out.

Anyone know what might be going on with the fan situation, or any suggestions on better code to add to start the fans after a pause like that?

Also, thanks so much for all of the support, I feel kinda bad for not noticing the fan behavior earlier.


Great detective work!

Not at all, we all learn from each other here. Sometimes you’re asking the Q and sometimes you’ll explain to some other poor chap who’s stumped.

Don’t feel bad, the fix is always obvious in retrospect, eh? Besides, you did a stellar job in tracking this down, glad you got a handle on it! And learned a bunch in the process.

You might put this in as a Bug Report, it seems an easy enough fix to get in the Firmware.

1 Like

P2 is for the big auxillary fan on the left side of the printer.
P3 would be the chamber fan for X1C
M106 S255 (without the Px value)
that should be the part cooling fan on the toolhead.
The speed ranges from 0 to 255 for 0% to 100%


I’ll give it a test, thanks!

1 Like

Hey, thanks for this. I printed a test piece today and had, for the first time, what I would consider a successful multi color print. I introduced the fan startup code after the xy home, and all was well!

M400 U1
G28 X Y
M106 S255

Thanks again!