"Failed to pull out the filament..." error only when using AMS spot A3

I cleaned filament buffer and the problem almost went away. I also moved printer to make sure tubes don’t touch the wall and I swapped 3rd slot First Stage Feeder with the one from another slot

hi, I also had problems sometimes loading or unloading the filament because my AMS systems are next to my printer. I have now positioned the HUB a little differently. I laid the PTFE tubes in a neat arch and haven’t had any problems since then.



I apologize if this was already mentioned or asked but how are you guys fixing the error?

I fix the error by disconnecting the quick connect of the filament tube that comes out of the printer itself. I then slide the tubes apart so I can see/touch the filament. I then click retry and it just works.

here is where I disconnect the filament run, then slide the connector the direction of the arrow

odd that just clicking retry works. If I do nothing and click retry, I get the same error.

I should try to create a longer run there and see if there is any difference.

With that it leads me to believe that a repositioning or lengthening of tubes etc. could be the problem?

1 Like

After checking, there is no filament still in the extruder.

Also, I can use the same exact filament in a different AMS slot right after I get the error and have no issues at the end of a print. Its slot A3 every single time I get the error and only slot A3.

1 Like

I have the exact same problem, also on the exact same slot. (A3).

I don’t think people realize exactly how stuck it gets. It is really hard to pull it out. I can completely understand that the puny motors and gears cant move it.

Mine seems to be stuck at the AMS where it comes in from the printer. I have followed the guides and checked for debris etc, but cant find any reason for this.

If anyone has some real suggestions, please let me know.

while I’m reading here I hat that problem again. When I release the PTFE tupe on top of my P1S I can pull out that filament without any problem. Releasing the PTFE tube at the filament puffer is not possible without releaseing the PTFE tupe on top. After releaseing the PTFE tube at the filament puffer the spring jumps back and I’m able to click on the Retry Button in the devison section the filament goes back.

Hello Bambu Lab team. It looks for me like a faulty Filament puffer. I just got that P1S with AMS 3 weeks now

Same issue, same slot, filament is fine and from bambu, nothing is realy clocked. Mainly as described here.

Same issue for me and haven’t be able to resolve it. There is a lot of resistance when trying to pull it out manually after getting the error.

I had this issue when I first received mine. I assumed it was the almost empty spools I had in the AMS and the coils where too tight. I moved the AMS to the right hand side of the printer and made the PTFE tube follow a gentle curve out the AMS and into the hub. I also bevelled all the tubes with a centre drill which has a sharper angle. You can see in @Dulphy 's picture the U-turns the filament has to make.
I’ve never had feeding issues since then (Mar 23) fingers crossed.

Was yours happening on the 3rd AMS slot as well? This is the only slot that it’s happening for me similar to what the OP posted. I haven’t had any issues with any of the other slots

I really can’t remember anymore, I thought you could just try it to see. I didn’t cut the tubes shorter so no harm done.

I also added the minimum bend radius to the printhead which also may have helped, but I assumed everyone has one by now. I have the smaller one now which doesn’t touch the glass lid.

I got the printer a few days ago and 3rd spool would fail to unload on a multi print… like you, i pulled the tube from the hub and the filament retracted fine… i did some looking around and found a print that mounts to the cable on the hub and supports the ptfe tube aligning it better and the problem went away.
search makerworld for “Ams Bowden Guide Clip” hopefully it works for you too.

I printed that up the other day, too, after having a filament hang up there.

Same issue here, i have the X1c for about a week now, so its a totally new machine.

Last night printed for the first time from AMS station 3 and then i saw the error this morning, print was done, filament was cutted, but pulling out was failted. No issues till now with the stations 1 / 2 / 4.

Now i see this is happening to many people that’s not nice to read at all.

Hope Bambu lab get a solution to this.

I have been back and forth for over a month with support on this. Nothing has fixed it and I am tired of there guessing game. They have you do the same thing over and over again just stalling and running you in circles. From day 1 we knew it was getting stuck at the extruded end. It pulls out fine from the hot end then gets stuck. Why? If I knew exactly why I could fix everyone’s issues with it.
Here is my thought on when a real fix will come out: The new X1E is for Professional and Engineering users. Once they stick an AMS on it they will have the same issues we are having and then a real fix will come out. Why, because the machine is $1,000 more and Bambu is trying to break into a different group of users. These user wont stand for or put up with this or go in circles with support.

1 Like

I also tried the Ams Bowden Guide Clip and unfortunately that didn’t fix the issue. Ams Bowden Guide Clip by iretreiver - MakerWorld

After seeing a solution with a drill and zip ties on a Facebook group, someone created this solution.
I tried it yesterday and so far its worked for me. I can even print the CF filaments in slot A3 without the issue. Its the angle of the tubing going into slot A3 that causes it according to the people on one Bambu facebook group. This little piece fixes the angle. You just have to make sure to install it in the correct direction.
AMS INSIDE PTFE GUIDE by papsjundi - MakerWorld

Man I was skeptical as I was doing it, as it didn’t look like the PTFE tube was being obstructed by that ferrite core, but it works like a charm.

Same issue here, with slot 3. The AMS will successfully pullback after disconnecting at the back of the printer where the PTFE tube enters and then pulling slightly. Very frustrating for a unit that is under a month old.

1 Like