P1S first layer mesh

Anyone have any experience with bad bed mesh on a P1S? It’s brand new and I keep having this issue, I’ve calibrated filament, I’ve done the full auto calibration, factory reset, changed the SD card, everything I can think of and I still have every other print a bad bed mesh where a section of the bed is like the nozzle is too high. Always the same spot when it happens but doesn’t happen all the time. So whatever is causing it isn’t consistent. Not sure if I could have a bad piezo sensor for the bed or something? Any thoughts? Submitted a ticket but I know that will take a while so just looking for ideas while I wait. Thanks! I’ve attached photos of the bad.

First thing that comes to mind is to make absolutely sure that your buildplate is clean as poor local adhesion can cause this kind of pattern. Especially contamination from silicon lubricants can be very persistent and are difficult to get rid of so scrub it really well with a good dish washing detergent.

Yeah it’s the same on multiple build plates and washed with dawn and a scrub brush. It’s like the nozzle is too high in spots. Kinda weird. Like the bed mesh isn’t working wondering if I have a bad sensor for the bed. Hoping support will help soon.

highly doubt that it is the bed sensor if it is always on the same spot, did you check if there is any warping//, deformation or bubbles in the vicinity of that spot?

Yeah bed look really flat honestly. Definitely should be good enough. Only reason I thought maybe a sensor because there is three of them and wondered if maybe that front left one isn’t always spot on cause that’s kinda the area where it’s worst. But did just notice that to tram my bed one knob was way looser than the rest. So I loosened my belt so I could get it closer to the others and trammed again. Wondering if maybe that one loose knob could’ve been messing with it since that spring would’ve been really loose compared to the others. Idk I’m just trying things while waiting for tech support. lol more testing tomorrow.

Have you tried changing the infill pattern to concentric? This will provide a better visual if it’s a plate vs filament flow issue. It will also confirm whether on not you have contamination on your plate.

Also have you tried chaning the pattern angle?

The sole reason for suggesting this is to rule out mechanical issues. The default infill is 45 Degrees. At 45 degrees you’re only moving one motor and belt.

Try this test to witness for yourself because it’s counterintuitive. Power off your machine, then move the head back and forth at a 45-degree angle. First from the 8 to 2 o’clock position, and then from 4 to 10 o’clock. You’ll notice that only one belt moves at a time when moving at 45 degrees. So, at 135 degrees, you’re isolating the other belt and motor, while at 45 degrees, the second motor is isolated.

If it is mechanical, then follow the maintenance steps on the wiki page for pulley lubrication and belt tensioning. Be very careful not to place lube anywhere near the belt.

By changing the pattern angle, you can control and isolate which motor/belt is moving. If it’s a mechanical issue with the belt or the motor, it should not be visible using the opposite direction of infill.

However, if after isolating the belt/motor, the problem stays in the same place on the plate, then no matter how clean you think your plate might be, it’s likely contaminated.

A less likely explanation but not impossible, is that your bed leveling is not happening correctly. Also, have you tried another plate just to rule out a defective plate?

One last question, can you hold up the test sample to a uniform light source so that we can see the transmissivity? I’m bothered by this perfect corner artifact where the lines seem to be making a perfect square(in green). That almost makes me want to tale a closer look at the slicer settings and/or the model itself. It would also help if you can show both a zoomed in and zoomed out screengrab of the sliced model to let us see the pattern being sliced.

1 Like

I haven’t tried changing the pattern angle, I will say the problem seems hit and miss. I can rerun that test and the whole bed level will redo itself and be perfect. And if I uncheck bed level it will be perfect each time. But if bed level runs again it will check its few points and decide it needs to redo the entire mesh. At which point it may be perfect or may be messed up in that same general area. I tried to upload a full pic holding it up to light but it makes me crop it and resize it smaller. But this picture is a perfect first layer. I changed a few things mechanically on the machine last night. Testing now to see if it’s better. It’s definitely weird. I’ll try changing the pattern angle but I’m confident it’s not plate contamination cause I can get a good layer. It’s just seems like sometimes the bed mesh is wrong. Still waiting on support to reply. And this is the model I used from maker world for the first layer. But only used this because on other models I was seeing the same issue in these spots.

Thanks for sharing that additional data.

So one of the things I’m not liking about this sample are the banding lines.

That can only be explained away by uneven filament flow. What is disturbing is that the banding appears to be consistent in that it stretches border to border rather than appearing in mid stroke.

So three things come to mind to maybe check.

  1. The first is of course, can you reproduce these errors with a completely different filament in color and maker? Stick with the same class though, if your using PLA stick with PLA don’t mix in PETG or anything else as that will skew the results.

  2. The second is: how are you feeding from the spool? Is it via an AMS or direct spool? Is the spool cardboard of plastic? I ask because one thing I’d want to rule out is uneven feed of the filament.

There is a fringe technique that I’ve not tried yet that uses a clip-on filament duster with a dab of olive oil that is featured in these two YouTube videos. 1) Filament Friday and 2) CNC Kitchen channel. Olive oil has a much higher temperature than straight vegetable oil and eventual rubs off as opposed to industrial lubricants. So some have suggested it is suitable for 3D printing. Stefan at CNC kitchen tested different kinds of oils with mixed results and actually raises more questions than he answers but towards the end of the video he shows two example Benchies with noticeable smoothness differences that he attributes to lubing the filament. So this might be a applicable experiment to run in your use-case.

  1. For the third option, try this simple experiment to rule out a feed problem. After slicing, note the predicted length. Then pull off that amount from the spool and allow it to flow loosely from the PTFE tube onto the floor. Monitor the feed while printing to ensure that you have the most frictionless/tug-free feed. You may even want to try feeding by hand.

For the third experiment, you won’t even need to run the entire first layer print just enough to display where the banding patterns were previously. If the banding disappears, then I would look at something like replacing or aligning your PTFE differently. One problem I stumbled over was when I added a chain guide to my P1P. I had the PTFE tube at too sharp an angle. This produced banding issues. I redid the tube so that there was a more gradual slope in the tube where it meets up with the extruder, thus providing - or so I theorize - less friction in the last 50mm of travel into the nozzle. It fixed some of the banding I was seeing but not all.

And last, have you checked your extruder for wear? Or for that matter, did you blow it out with an air duster? If you’ve got accumulated dust, it could be causing slippage. A long shot but worth looking at.

Didn’t really think about that, has happened with multiple colors and materials, I am feeding from the spool holder, only have ams on my A1. I will say one thing I printed was a PTFE guide because mine kept going over the top instead of staying near the chain. I did this and fixed my bed level, that front left corner was way off, I trammed it but that knob had to be loosened a ton to get it trammed. So I loosened my belt and spun that one Z rod so that it was more in line with the other two. My thought was maybe that spring being under a lot less tension was causing the reading to be different than the others. Since doing the PTFE tube fix and the bed deal I haven’t seen the issue again. But it was inconsistent before so I’m still watching it for sure. If it appears again I will def look at the filament feeding. I will say this machine is brand new so the extruder should be good. At least I would think. And it always seemed to be only the first layer. After 2-3 layers it was perfect which is why I was leaning toward bed mesh. But you definitely raise some good points to look at. I’m watching it closely every print to see what the first layers do. So far today each one has been perfect so fingers crossed I have sorted it between the PTFE tube and the bed leveling knob having to be super loose to tram it.