Printer Stops in the middle of the print

Ok, I just tried printing and I have a message stating “A microSD card needs to be inserted before printing.”. I’ve never seen this message before, so I think the SD card issues stated before may have merit.


I had the same problem. The printer stops printing three times already and goes offline. At first I thought that the reason was in the SD card, but after formatting it the problem remained. There is a problem when printing one small part, when there are 40 of them on the table at once, the gcode file size is 45 MB, maybe this is the problem? When I print 15 parts on the table, everything is fine, the printer does not stop.

Maybe someone already had this problem?

1 Like

I had a similar bug on the ongoing print that stopped extruding filament in the mid-way.

I have a repeated problem with the PLA marble prints, the job stops extruding after several hours, and the extruder still moves after several layers in the air!

I had to stop and try to extrude manually but there was no movement to bring the head closer to the front door and I got this message.

it does go to home and stay at the poop shoot area. I can’t move the xy axis because the filament is still in the nozzle sensor detection. (green dot on the LCD screen)
after removing the Hall effect sensor I noticed that the arm magnet got stuck in
the corner of the plastic slot casing!

As you can see the arm can sit on the corner without a filament in place!

The Picture below is when a Filament is detected present in the extruder.

This is a problem and maybe explains why I can’t move my XY extruder.
somehow the firmware interlock takes over to lock any movements.
I ended up grinding the corner so the arm could slide back down without restrictions.

Please make up a newer design with a 45-degree chamfered edge on the plastic casing or the magnet arm.

Besides I am very happy with my X1C!

Best regards

Is this what I’m dealing with and getting no error codes or help from CS? This ■■■■ has been driving me crazy for months, and I have wasted so much filament I just stopped using my P1P. Since I can’t use my A1 either I’m back to trying to fix this same issue with the P1P. CS is so slow and not helpful in the least with this.

I found the TH cable was pinched in the housing and there looked to be a little black on the TC cable board. When I take the TH apart to swap cables, I’ll look into this too.

I also think I saw a Youtube about this and the guy used some hack to fix it. Is this another poorly sourced part used by Bambu?

Did your modification work? I’ve had this occur twice in the last week.
Maybe it is Hardware because the P1 series owners in this thread have the same problem. For some reason, I guess the X1 series has an entirely different FW than the P1. X1 series is running in a Linux variant. I don’t know what the P1s are using.

I’m curious if that HW mod worked. I find it puzzling the function of it running out of filament would not move.

I suspect one of the boards has an issue, or there is corruption on the FW/OS somewhere. I’d reinstall the FW if I could. Bambu took away the functionality to downgrade or reinstall the firmware. It is only possible to upgrade if one is available.

I opened a ticket, but based on the automated response, it said they were out of the office for the Chinese New Year. Based on the no response many people are encountering through out this Forum, I don’t have much confidence in their Warranty.

I love the printer, but they have some technical problems and terrible Customer Support. Maybe the price of the printer should be lower since Customer Service and a warranty appear nonexistent.

Well, see what happens with my ticket. Oh ya, I bought mine at Microcenter and keep reading during ticket creation that I should contact them for support. If they want to “be like Apple,” they need to support their product no matter where it is purchased directly.

I read here somewhere that Microcenter is taking back A1s for cash or exchange.

yes, I get less false filament sensor report, but I still can’t move the XY while in jam mode. it’s a software restriction I guess.
When a broken filament is stuck in there, I power off then heat the extruder at 250c and push manually a new filament through the extruder to force it out.