2.4ghz dropping issue - anyone else?

Hello all! Newbie here, so please excuse my ignorance but (and yes, I did research my question here before posting, but couldn’t find a definitive answer and figured best to ask before opening a support ticket);

I purchased my P1S about 2 months ago and everything worked flawlessly. I printed everything under the sun! AMS was a breeze to install and begin using and it too has worked exceptionally.

Now, within the last 3 days, it has all gone down hill with the 2.4ghz side of the router being the culprit. I have tried rebooting the router, renaming the 2.4 channel, changing the password, deleting the print profile from the Bambu Handy, deleting and reinstalling the Handy, and tons of other ideas, so much so I have forgotten them all. It seems it drops the 2.4ghz direct connection for some reason now. However, if I turn my phone into a mobile hot spot, it will take it just fine, WHILE using the SAME 2.4ghz channel it refuses to stay attached to. But if I switch back to the direct 2.4 input, it drops and fails. I also have a WiFi extender that has been in use since the printer got here. I can attach to that as well, as it uses 2.4 also, but since it is to far away it can’t make a clean connection to the printer, but will still attach.

I can literally watch the Handy attach and drop from the printer’s screen, then look back at the Handy to see the “Invalid Password” error code. I know the password is correct, as it is the same one used on all other devices.

Sooooooo, short story long, has anyone else had a similar issue out of the clear blue, and if so, what did you do to resolve it?

Thanks in advance!!

Attached is a pic of one of little creations that was part of the Bambu Maker World Halloween contest for attention, LOL!

1 Like

Yes, I had this exact issue 3 days ago and thought it must have been my internet provider at first. I added the printers Mac address to the 5k blacklist and that eventually allowed me to connect to the 2.4k wifi. But then the next day it cut out again and no amount of rebooting or resetting of either would get it to connect. I factory reset the P1P twice and eventually just enabled Lan only mode and printed from the SD card (this had a weird print failure too that I can’t explain but that’s a different story). I even tried setting up an isolated 2.4 guest account but even when forcing my PC and mobile and printer to that account, I kept getting a ‘printer not on the same network’ failure from the app. Then just when I was about to give up, I put it back to the original connection and it just connected :person_shrugging:

2 Likes

Thanks for the reply RMB!

Okay, what makes that even more weird is that your issues started in the same 3 day window as mine. Just bizarre. Of course, mine still has not self resolved, and I’m still doing the Mobile Hot Spot jig, but at least it’s still running for now. Just can’t for the life of me figure out why all of the sudden it quit on me (or you for that matter). Just doesn’t make sense, but does make me wonder if it’s a back-end issue on the Bambu side of code.

~MyDeSoto~

We have the same issue with our upgraded P1P and P1S.
Both don’t work anymore logged in with the cloud account, and only one works half in LAN only mode. All this started a couple of days ago, without any changes to the network or infrastructure. When I try to ping the printers, they are all over the place between 500-4000ms latency or just dropping. Do you have any new findings?

1 Like

I have something for you to try. It is a completely different situation, but it could be caused by the same problem.

I had a connection issue between my router and an extender. I tried several things that didn’t work, until I made a security level change. I had the login security set to the highest setting on the extender. I changed the login security level to auto, and it worked, then I changed it back to the highest security again and it still worked. It is strange, but changing the security level fixed the issue, even though I changed it back to the same level it was a at originally.

I actually asked ChatGPT if it had any ideas of how it fixed it, and it said:

It’s possible that changing the security level on the extender triggered a reauthentication or a reset in the connection between the routers, resolving any potential issues. Sometimes, making adjustments to security settings can prompt devices to establish a new, more stable connection. While the exact reason might be hard to pinpoint without more specific details, it’s not uncommon for such adjustments to have a positive impact on network performance. If the issue doesn’t recur, you might have successfully addressed a temporary glitch in the network.

1 Like

Today I resolved the issue. Due to a firmware update of our APs, the channels of our 2.4GHz were incorrect. It seems like the printers need channel 6 to operate.

1 Like

Thank you ALL for the replies!

I too have had some success, but wanted to give it a day or two before reporting back my findings to ensure it was truly fixed. We have an Epson laser printer (all in one job, not sure if that matters, but none the less) that, I completely forgot, also utilizes 2.4ghz. Recently it ran out of paper and my bride turned it off until one of us went get more (since we had none left here). Oddly enough, with that printer offline and removed from 2.4, the P1S magically started working again!

It has now been 48 hours with BOTH printers on, and running smoothly with zero latency or connectivity issues. Was it the actual issue? Who knows, but what I DO know is, that once that Epson went offline and was removed from the 2.4ghz chain, the P1S began working again flawlessly. I’m assuming it’s a hierarchy issue, and Bambu Lab just doesn’t force their products first in the chain? Who knows.

At any rate, I am currently up and running again. My next challenge is firmware updates on both the P1S and the AMS. Is there a way to go back to a previous firmware version should these be a bad decision?

Thanks again everyone for the replies and advice! It was ALL super helpful!!!

3 Likes

Glad you got it resolved, troubleshooting wireless is a chore , especially when dealing with Wifi. :slight_smile:

1 Like

Wow, just stumbled on to this. I’ve been having a tough time with my P1S staying connected with Bambu Studio. After seeing your post I realized that the issues started right after I bought a new Epson printer, never even thought that could be the problem. I turned off the Epson and the connection between the P1S and Bambu Studio is working flawlessly.
After I finish a few prints I’ll turn the Epson back on and see what happens.

1 Like

Many printers broadcast their own built-in wi-fi network, either just for initial setup, or to let guests use your printer but not your home network. I suspect that the Epson caused interference by using a 2.4Ghz frequency near your LAN 2.4Ghz channel.
You should be able to disable the Epson network - look for something like Wi-Fi Direct in the settings and turn it off.

In my router settings, I assigned a static IP adress to my Bambu printer. Since then, I didnt have any hiccups. Just FYI.

Thank you. I found WiFi Direct but it says “Not Set”. I’ll keep poking around. As soon as I turned the Epson back on the Bambu connection dropped.

If you can change the static IP for things connected to your router in router settings, then you could set one for the Bambu.

If you can’t change it in the router, I don’t think you can set a static IP in the Bambu settings, but you should be able to set one up in the Epson printer settings. Check what IP is assigned to it and then set a static IP, but change the numbers after the last dot.

It is possible that the Epson is taking the IP address the Bambu is using.

I’m really not very knowledgeable about this stuff. The IP addresses for both devices are different. Was trying to feel around in the Epson settings and I kept getting error messages. So I backed out and left it be.

One thing I tried a few days ago that seems to be helping is making sure my router is set to one of the optimal channels for 2.4GHz, which are 1, 6, and 11. If you don’t know, those are the only 3 channels on the band that don’t overlap. (I’m in the US. Other countries have a couple more channels, but I believe those three are still considered standard.) My TP-Link router will always choose a different channel if set to auto.