All four AMS LEDs flashing red. Communication error with AMS

My dear Bambu friends, hi everyone!
I greet you from The Netherlands!

I hope someone can help me with the following AMS problem (I already made a support ticket to).

  1. I send a print from Bambu Studio to the X1C.
  2. The bed is heated and the nozzle gets heated.
  3. The bed levelling gets executed and the filament gets loaded from the AMS.
  4. The LED lights in the AMS with occupied slots are white and the white LED from the loaded filament is breathing white.
  5. After the bed levelling the line calibration is executed.
  6. The LED lights in the AMS with occupied slots are still white and the white LED from the loaded filament is still breathing white.
  7. Then the purge line gets executed. When that is finished, normally the printhead goes to the middle of the bed and starts the actual print.

But in my case after the purge line is printed, the print head goes to the filament cutter and after that’s gets parked above the poop shute. All four AMS LED’s start blinking red, indicating there’s a problem with communicating with the X1C. At that point I also get the error message: AMS1 communication is abnormal. Please check the communication cable (0700 5000 0002 0001 1845 10)

This is what I tried to resolve the issue:

  1. I cleaned the hot end nozzle with a cold pull.
  2. I cleaned the extruder and filament cutter.
  3. I’m only using Bambu lab filament and spools in the four slots.
  4. I’m not using an external spool.
  5. I removed the spools and filament out of the AMS and placed them back again.
  6. I swapped the filament spools randomly in the AMS.
  7. Powering off the X1C and powering on again.
  8. I unplugged all AMS cables on the AMS and at the back of the X1C and plugged them in again.
  9. I tried different filaments but it gives the error with all filaments.

The AMS LEDs are restored to normal again and are white.
Then I start the print again and all goes well, up until the actual prints has to start after the purge line. At that point all four AMS lights start blinking red again, the printing stops, the print head gets parked again and the error message appears.
I am not educated in measuring the electrical connections as in the article: AMS is not detected by the printer | Bambu Lab Wiki

Can someone help me?

With very warm regards, Ludo Timp.

can you manually load and unload filament from the touch screen while not in a print job?

Yes I can. But I first have to turn off and on the X1C to reset everything again.

That’s strange indeed, can you try to print from the sd card a factory model, and see if it will print?

( All four AMS LED’s start blinking red, indicating there’s a problem with communicating )

There are two internal AMS wires check they are fully plugged in on both ends

This is the back two connector location.

AMS Cables

Hi 3DTech, thanks for your help. I opened up the AMS, removed the bottom part, checked all the connections, placed everything back and connected the AMS again. The problem persists. Now when I turn on the AMS, eight out of 10 times, all the four LED lights turn to red in about 4 seconds.





im going through the sam problem. I even have 2 ams where the issue is in my first unit while theres no issue with the 2nd one. my first unit has been nothing but junk since i added 2 ams boxes. i do not recommend wasting your money on 4 cause 2 alone has been a nightmare. did you ever find a fix for this?

I finally fixed the problem by unplugging and re-plugging all of the cables from the AMS to the printer.

Did you happen to try any of the suggestions in the posts above to see if your problem could be fixed?

1 Like

I completely de-assembled the AMS, disconnected all the wires and connected them again. I also removed the backplate of my X1C, took the opportunity to clean the internals, disconnected all the wires indide the X1C and connected them again. After that I had no more error warnings and flashing red AMS LED lights. Let’s hope it stays that way.

1 Like