Allow me to move the build plate down

Short time after a print has finished I can press the “10 down” button on the X1C control panel and the plate moves down. So it is easier to remove the build.
But if I do not await the finish (doing something else in the meanwhile e.g. eating) and come back to the printer half an hour later this function is not allowed. Instead the firmware tells me to press first the “home” button to avoid damages.
But this is very bad! Because I have not yet removed the printed object. Pressing the home button in this situation will not avoid damage, but instead causes it.
Ok, there is the power-off switch :slight_smile:


I believe the reason is it goes into standby mode after 15 minutes or so. This means the steppers are not powered so the tool head can be moved around by hand. As a result, when coming out of sleep mode, positions can’t be trusted.

I think the best solution would be to warn once, but then let you move freely without homing. Also as far as I can see the plate is unlikely to have moved, so the printer could even opt to trust it and only warn about X and Y moves.

Have you perhaps modified your end gcode at all? I ask as I have never encountered a problem of the build plate being too high to be able to remove after a print. Normally the printer drops the plate after the print finishes.


I might have the opposite reason, because I can’t remember anything lol. So after I print something taller and I’ve removed the print the printer bed is usually near the bottom.

So what I like to do before I remotely print something is to check to make sure I peeled the purge line off or that there wasn’t a purge tower from a multicolored print still on the bed. (I’m guilty of it)

But if it’s been a few minutes I’ll get the same error, but then I too am afraid to let the homing cycle happen just in case those pieces are still on the plate I don’t want to risk the nozzle jamming itself into the stuff on the plate.

It shouldn’t really be a problem, if you’ve ever wiped a piece of filament off the while it’s homing you’ll know. It instantly moves back down a bit, so it would just home on the piece still there since it uses the bed to detect the collision and not the nozzle. I haven’t tried to home on a part though

Moving from remote might be dangerous. But if I use the panel of the printer it could trust that the operator knows what he is doing.
I did not change the end code or so. I am also able to remove the plate in the position it stops. I had done it several times. But I feel more comfortable doing it if I have more space available, because the magnet is very strong and I dont need to be careful.
I want neighter risk to damage the print head, the nozzle nor the finished print.

You could also remove the model height check in the Machine end G-code so it always drops the bed to the bottom.

In the stock gcode it checks to see if the total model height + 100mm is less than the total Z height of 250mm. If it is then it lowers the bed to the model height + 100mm. If the model height + 100mm is greater than 250mm it lowers the bed all the way to the bottom (Z250).

{if (max_layer_z + 100.0) < 250}
G1 Z{max_layer_z + 100.0} F600
G1 Z{max_layer_z +98.0}
G1 Z250 F600
G1 Z248

To remove the check you would need to comment out or remove the model height check.

;{if (max_layer_z + 100.0) < 250}
; G1 Z{max_layer_z + 100.0} F600
; G1 Z{max_layer_z +98.0}
G1 Z250 F600
G1 Z248

You could also just increase the values added to the the max_layer_z respectively so it drops the model a lot lower once the print finishes.


Thank you for your hint. But this are workarounds and much effort if I have do do it for every print. I think it would be simplest if the firmware would not disallow movement.
Nevertheless interesting to learn the possibilities.

It’s a one time change as you change it in the slicer settings. The slicer will add the end gcode to every sliced file moving forward.


Oh, thank you. Than this could realy be a solution. I thought I would have to change it after slicing.

1 Like

It can be a little difficult to find where the end gcode is located. Follow the arrows top to bottom.


Thank you heapss for this , I also wanted a bit more of a “buffer” to clear the tool head when pulling out a print with the flexi plate, it might come out easy but i prefer more room than 100mm to reinsert, say 150 or 175

so does this mean a modification of the model height + 100, to +150 would achieve that? I notice a z+98 line as well. so increased that in ratio, z+148.

{if (max_layer_z + 150.0) < 250}
G1 Z{max_layer_z + 150.0} F600
G1 Z{max_layer_z +148.0}
G1 Z250 F600
G1 Z248

Yup, you’ve got it figured out.