AMS Assist motor constant overload

Brand new AMS, just got it 2 days ago. Hooked it up yesterday and
Slot 1 is showing constant motor overload every two minutes if you’re lucky to get that long out of it.
My other AMS units all work fine. All set up the same way, sitting beside the printer on right hand side.
Submitted a support ticket.
But they suck at answering ppl.
Any tips or tricks?

Check te spring of the AMS-HUB. Sometimes it gets stuck, resulting in said error.

The rest of the slots work fine, so I figured it’s fine and moves freely.
I could swap it out with one off my other printers to test.

Is the spool rolling freely?

If Hits any resistance you get the Same Error, cause the Hub Registers said Problem

Yes, moves the same as other slots. Just slot one giving error…lucky to get 2 minutes of printing. Then stops…some times you get the error, sometimes you don’t. Either way still stops. Hit resume, prints for 2 minutes…stops.
Tried a fresh new roll, different colour and did the same thing.Part roll dam near empty…same. Slot 2 all the rolls worked fine…
I’m going to swap the hubs around and try it. Then move the ams unit to another printer and vice versa…if it does it on other printer then I’d be safe to presume it’s the AMS motor. I’m
going to video every test as well.N submit it…because they’re gonna ask for it. On top of the vid and pics all ready submitted.
Obviously they don’t test the equipment as this is the first use of this AMS.

Getting late on this thread? Has it been resolved? On my side it’s a bambulab petg spool causing the problem, it’s rolled in a way that keeps it stuck