AMS not recognized by X1 Carbon

Hi everyone,

I have a first issue to report and it’s one with my AMS. The unit gets recognized by the printer and after that, the red lights start flashing on all 4 slots and the X1 Carbon doesn’t see the unit anymore. It’s a bit strange because after unplugging the AMS and re-plug it will do the same again. Last week I only had this issue once and now it starts to get way more frequent. Rebooting the printer also does not help and I also replaced the cable. Still had one from the first AMS unit I received during the promo/testing period.

Did you check if the AMS and/or printer firmware was up-to-date? Sorry if that’s too obvious; I’m curious what other error messages you may be receiving. I had some issues with printer calibration out of the box that were unexplainable, only to find that the firmware hadn’t yet been updated; after that, everything worked great.

1 Like

I’m having the same issue. It worked last night. Now no lights. I measured the voltage at the printer connection to the first connection of the AMS and it was only 8v ( should be 24v ) at the Printer and got to zero by the time I checked at the cable to the AMS. I’m going to check the connections on the controller as this suggests a connection that isn’t fully seated.

I am having the same problem. It has happened about 15 days ago. Worked on day and nothing the next. I don’t have the ability to check voltages. I have sent 3 support tickets with no response. No way to talk to a real person. Have you been given any guidance?

I have been having the same issue. I think there is a very poor connection on all the plugs, and the vibrations can cause it to lose connection randomly. I can unplug/replug my cables to get it to reconnect, but it will randomly disconnect in the middle of a print or during filament change.

They basically made a poor engineering choice of the communication cables design and orientation.

Same. It appears to be the first cable out of the printer.

Same issue, AMS loses connection (all lights blinking red) and when I unplug and re-plug any of the AMS communication cables it fixes it only for a minute before the AMS loses connection again.

My AMS and X1C has accured 880 hours so far and this just started happening to my setup. Cycling the power sometimes works immediately and sometimes I need to unplug the AMS power/connection cable on the back.

I attribute this to wear and tear caused by removing broken PLA from the AMS. Disassembly and reassembly stressing the connection and wires in the AMS. I love the AMS when it works but an improved design would solve a lot of the AMS issues.

I just submitted a ticket as this problem is occuring a lot now. I’ve read the Wiki and unplugged and replugged the cables, checked the two plugs in the AMS and still no solution. Sometimes I can get a couple of prints out and othertimes it won’t see the AMS when I turn the machine on.

Hello everyone, does Bambu have a solution to this problem?

My X1C with AMS has now had over 1000 printing hours and exactly the same error described occurs. Unfortunately, replacing the two cables (printer hub and hub-AMS), completely dismantling and cleaning the AMS did not bring any improvement.


Same issue here. Happens throughout each print. Disconnecting and reconnecting. If it happens at the end of a print, the printer thinks there is filament in the external spool and the ams will not cut and unload. Turning off/on the printer seems to reconnect and then the ams can cut and unload. Of course this would prevent a muli-material print which defeats the purpose of the ams. I’ve submitted a ticket. We’ll see what happens.

I have read that replacing the small AMS interface board on the back of the printer fixes this issue in some cases. This can be purchased on the Bambu website for around $10. The installation processes looks like a hassle but I might give that a try.