AMS Retraction problem

I am using SunLu filament but it doesn’t matter what spool I use, but in slot #2 it keeps hanging up like this on retraction for a color change:

Any ideas on how to fix? Anyone else with the problem?


It looks like the spool is not all the way to left side. About 3/8" to the left.

1 Like

I reseated quite a few times. Slot 1, 3, and 4 are fine… Slot 2 is having the the problem with ANY spool.

Apologies! I looked at the video again. It is in the right position.

1 Like

Try cleaning the rubber of the reels, use the original spool. You can print them

At least that is what I would do.
I hope it will solve the problem.

Someone also put the electric wire around the edge of the spool. He cut it in half and inserted it. This increases the grip.

Good ideas…

I tried the electric tape around the spool but it made it worse. I tried Bambu Spool, SunLu, and Inland cardboard and all three have a problem just in that slot. The other slots work fine.
The rubber on the wheels look intact. They do not look dirty as this is less than a week old. I have tried cleaning but no luck.

1 Like

I believe all the AMS drivetrain parts are available and the wiki covers their replacement. I would reach out to customer service and they will probably send you a new part. (As they did for the main board fan on my first X1) I would imagine your AMS is still under warranty.

Bambu answered back with their tech support. They gave some good suggestions. It looks like the First feeder needs to be replaced like you said. I requested they send me a new one since it was new and never working out of the box. (The other slots did just fine) Thanks for your reply!!!

Great to hear that should be a relatively easy fix for you. Bambu isn’t perfect (who is?) but from my experience they try their best to make things right! Let us know how the repair goes.(I had an issue early on as well but it turned out to be an odd combo of filament and spool.)

After contacting support and working them through emails, I have fixed my problem.
The problem was that the front roller was just a bit unseated. I oiled and reseated it and seems to have fixed my problem. I took a picture showing the roller unseated.

Thanks all for your help on this!