Bambu Lab just released a new firmware update

Bambu Lab just released a new firmware update for the Bambu Lab X1 line to 1.03.00.

This update contains several new features and functionality as well as numerous bug fixes.

We hope you enjoy it as much as our beta testers did.


  • Added support for sending multi-plate files to the printer and basic file management for the pre-loaded models
  • Added support for browsing plates in the 3MF files and printing the selected plate
  • Added filament drying functionality
  • Added support for build plate type identification, reminder and protection
  • Added support for first-layer inspection with gcode files generated by Bambu Studio.
  • Combined spaghetti detection and excess chute pileup detection into the AI monitoring function
  • Added HMS guides to the printer screen
  • Supported time-lapse photography and video in default 1080P resolution
  • Added network self-test
  • Added statistics for the printer’s printing hours.
  • Added fan control
  • Supported turning off the motor when printing is completed or the printer is idle for over 20 minutes
  • Supported automatic recovery after losing printing steps (Experimental function, turned off by default)
  • Added support for adapting the maximum temperature of the hot bed in different regions under 110/220V
  • Improvements and bugs fixed
  • Remaining Issues

For all the details check out our release notes: X1/X1-Carbon and AMS Firmware Release History | Bambu Lab Wiki


I just updated to this new firmware and it has caused a couple of issues.

I am now getting warning:

The sensititvity of heatbed force sensor 1/2/3 is low

Doesn’t seem to have impacted anything, but I was not getting this warning before, then immediately after updating the firmware its now there. It seems too much if a coincidence to actually be a hardware issue, I didn’t touch the inside of the printer or any cables etc, just did a firmware update on the touch screen.

Secondly, and more annoyingly, the printer now pauses with an error every time I start a print telling me the build plate marker is missing/does not match. I am using the official bambu textured pei build plate, it has the aruco marker on it, it is correctly positioned and the textured pei plate is chosen in bambu slicer.

Any help appreciated, as currently I’m very much not enjoying this firmware update, feels like beta testing was not very thorough…


I just tried running a calibration and it gave a “Mesh bed levelling failed” error :frowning:


You can turn off the marker check in the settings

Is the firmware based on a rollout? I am unable to update my ams or x1c to the latest firmware, Does anyone else not see updates available?

FYI. First time I have seen this. happened just after the upgrade I cleared and working ok. Just FYI



You should be able to disable this check in the firmware, if you want to disable the check.
The feature was introduced in the latest firmware update.



Thanks Ciprian, just letting you know thats all.

1 Like

Ciprian, thanks for letting us know we can disable this. I get it for every build. Will there be an eventual fix or do we just need to permanently disable this feature/process? And if we need to permanently just disable it why was it added?

More of a curiosity of trying to understand why. Thank you!

Please can anyone lead me to where I can disable the check?


1 Like

You mean related to the print plate check? According to the release note:

1 Like

I had the same type of error come up. It kept saying Force sensor 3 lower weak signal. I looked up where the force sensor 3 was, all I did was turn the knob a little bit back and forth and tap on the sensor and everything was fine. Before I print anything I just tap underneath on that sensor and I never get any more errors. I did put in a support ticket, they answered me within 12 hours and within 48 hours they sent me a new cable to replace which I haven’t done and they also gave me $50 store credit. I just don’t want to take stuff apart on the bed and have more serious issue. I just give it a little tap when I turn the printer on and it’s fine. It might have even worked itself out I don’t even know if I have to tap on it anymore. I guess they had some bad cable connections. If you were part of Kickstarter though, you shouldn’t have any problems with your motherboard fan dying though.

It turned out that in my case the heatbed signal cable to which you refer was actually damaged. Pin 3 had no continuity end to end on the cable. It goes through a tight 90 degree channel at the back of the bed, which is probably not great for a flat ribbon cable. The fact that support very quickly identified this cable as the likely cause in both our cases indicates they have probably had many cases of this problem.
They sent a replacement which has been slightly redesigned to be more resilient and have a different routing to the mainboard. It was very fiddly to replace, but not something that should be too challenging so long as you have the patience and can follow instructions.
Definitely glad to have been offered the $50 credit though as it did take a couple of hours and induced the kind of frustration that only fiddly jobs like this can!
All in all, annoying it broke, but can’t fault BL on their support. Issue was quickly identified and rectified.
The build plate error was confirmed to be a firmware bug and apparently will be fixed in the next update.

1 Like

$50 credit - Wow - Must be nice. They sent me a replacement warped bed and a four plus hour instruction on how to replace it. The new bed is more warped than the original. No mention of any compensation LOL - Ive spent close to $5K with them printers, parts and filament.

Yeah I’m not ready to replace the cable especially if it’s going to take a couple hours. I’ll replace it when it stops working all together. I haven’t had an error come up in a couple months. Then I made a large order of 12 to 14 rolls of filament with them which got sent out of two different warehouses in California so they sent me two of the same type of filaments when one of them should have been a matte color. I put in a ticket about it and they gave me a $20 voucher and let me keep the spool so I had $70 and store credit so I purchased the textured p e i sheet and the complete whole hot end assembly with the .2mm nozzle with free shipping. And since I backed them on Kickstarter I also got that Kickstarter bonus where I also received the hardened steel extruder gear set and a complete hot end assembly that has the two sensors in it the fan and a .4mm nozzle and sock and then also got the .6 and .8mm nozzles. I haven’t tried those yet. I also got a roll of carbon fiber filament free and white and yellow PLA and the support w filament. They also sent me a bunch of spare parts and two extra OEM build plate stickers. I’m not sure what comes with the X1 carbon if you didn’t buy it on Kickstarter but with all this extra stuff it definitely paid off. The only thing I don’t like about the AMS system is that number one I’m not used to doing multicolor prints and two it does kind of seem like it wastes an awful lot of filament and takes much much longer to print something with a different colors because it has to purge every time and then it has the purge block if you have that enabled. I don’t see the justification of having to switch filaments 800 to 1800 different times for one print just to have a multicolor print. I rather would just paint from now on.

1 Like

Maybe people could stop resurrecting this 2 month old thread and keep the announcement category for announcements.