Bambu Lab P1S Homing randomly

Just recently, my Bambu Lab P1S started homing randomly during it’s setup, like when it purges, it’ll wipe it’s start wiping it’s nozzle but then it homes and goes back to finish wiping. I’ve tried changing slicers from Orca to Bambu, problem still occurred, then i tried to change profiles, still had the problem, and it only occurs sometimes. I’ve found it might be a weird slicer issue, printing from the sd card is fine sometimes.

I would check out the operation of the filament sensor switch. It could be losing the ability to sense the filament. There could be also a piece of filament broke off in the filament sensor chamber. It’s the clear part of the extruder.


I wouldn’t think it would be losing the ability to detect filament because I just got the printer about 1-2 months ago. I’m also not getting any filament runout errors. The homing only happens during setup and it does not home when printing. But i will check on it as soon as i can

Do you perhaps have the “Auto-recovery from step loss” enabled?


I understand, I’m just looking for easy stuff to check. Hopefully not a faulty connector on the TH pcb.


I do have it on ill try it soon.

I just checked it and there was nothing wrong with it as far as i could tell

The auto-recovery from step loss rehomes the machine when it thinks that there has been a step loss from higher than normal current draw from the steppers, ie cleaning the nozzle.

Turn it off and I think your “problem” will go away.


Just started a print and it’s still homing. I also figured out it is not randomly homing, it is consistently doing it at the same spots. I guess the good thing is that it still prints fine.

So, I figured out the issue, sort of. I started a print, closed Bambu Studio, and no homing during the setup (after initial home). That means its a slicer issue that seems like only I have cause I cant find anything about this. I will keep testing this and report this as an issue on their GitHub as well.

I’ve recently got a network update on Bambu Studio and it seems to have fix my problem, I’ll test it for a few days and get back about it.

Welp, it started again. Same exact spots and I don’t even know what i did.