Bambu Slicer/Orca Slicer crashing when slicing complicated models

I have tried reinstalling both programs and drivers

Hmm, interesting… I honestly don’t see anything being wrong with your computer. When you uninstalled, did you have any other versions still downloaded? I’ve used OrcaSlicer since the beginning and have never had an issue with crashing during a slice.

I do notice the program itself utilizes RAM the most but in your case that also doesn’t seem to be an issue… Have you tried a .STEP file? or any other complex file? (.3MF, .STL, .STEP) Do you see the same issue?

I made sure to uninstall every version from each and complete wipe all data. Even restarted the computer after uninstalling and reinstalling. I have tried all versions of files and if it is to complicated (to many triangles) the program crashes.

I have the same issue as the OP.
Also on 1.8.4.51 (but came from 1.7.7.something - same result/crash).
My computer specs are close to the OP’s:
Processor 13th Gen Intel core i9-13900k
Ram 64 gb
GPU Geforce RTX 3080 TI

Windows Eventviewer:
Faulting application name: bambu-studio.exe, version: 1.0.0.0, time stamp: 0x65a7952e
Faulting module name: BambuStudio.dll, version: 0.0.0.0, time stamp: 0x65a7952b
Exception code: 0xc0000005
Fault offset: 0x00000000003eb99d
Faulting process id: 0x0x60E8
Faulting application start time: 0x0x1DA6CDC4B5765A0
Faulting application path: C:\Program Files\Bambu Studio\bambu-studio.exe
Faulting module path: C:\Program Files\Bambu Studio\BambuStudio.dll
Report Id: 5b6212d1-3422-4a91-aca1-4dce44554cda
Faulting package full name:
Faulting package-relative application ID:

File: [Traffic Cone by Erikjuh | Download free STL model | Printables_com]
<>

It already printed a few weeks ago, like a dream. Even multicolor (3 colors).
I put 9 or 12 of these cones on the plate and made a serie at 75% small.

OrcaSlicer also crashes at exactly the same percentage, when slicing: 15%
So I’m not sure it is the slicer, altho they are both derived from Prusa slicer.

Ok, a little news: I installed the same (=newest) Bambu Studio on my wifes pc.
Specs:
Processor 4th Gen Intel core i7-4770k
Ram 32 gb
GPU Geforce RTX 1660 TI
OS Windows 10 (latest patches & updates)

I have Windows 11 (latest patches & updates). So I am thinking it is either processor related or OS related. I think the latter. I am curious what jasonxt4c is running…

Exactly the same 3MF -file. Sliced like a dream. Printer is now printing it.

I also downloaded some random items from Printables. Some will slice, on my pc, others will not and Bambu Studio will crash and close.

Studio crashes and memory leaks have only been reported on 64 GB systems.

These bugs need to be reported as issues on the Github site where the developers will see them. A log needs to be submitted with the report, so it should be done by a user with such a system.

The developers rarely see or respond to problems here on the forum. If you want bugs fixed, report them on Github.

1 Like

I have similar specs to the above with the i9 and a 4070 ti with 32gigs ram and complex prints crash slicer. Prints i printed 2 weeks ago before updating software it crashes. Loaded on wife’s i7 with 32gigs ram and it works fine as of right now.

Motherboard/CPU stability issue as per other threads, changed current limit to 307 and power limits to 253w on both short and long durations. No further crashes.

Motherboard manufacturer pushing the CPU defaults significantly higher then intel spec…

I have this issue as well. Running on Windows 10 with an Intel i9 14900k.

2 Likes

I also have the problem with i9 13900k, 64gb ram and RTX 4090. Lowering the CPU frequency seems solve the problem.

2 Likes

So I think I have a work around for my issue. I am running windows 11 and if I put OrcaSlicer/Bambu Studio in Efficiency mode, I am actually able to slice everything. I will admit sometimes it can take forever, but it slices.

I have plenty of memory and a good enough GPU…
My slicers don’t crash, not even on the 128gb gaming rig I had for a while.
But I did have plenty of slicing crashes until the actual problems were fixed - even on a 8GB system.

I found some main issues and if it fits try the fixes…
One major issues with my slicers was the GPU support paired with badly configured drivers.
For example the Nvidia Studio drivers quite often caused crashes because of their optimization for totally different things.
On the other hand the Game Ready drivers often had issues with new releases and taking over the CORRECT settings.
No need for the latest driver unless the one running is known to be buggy…

Another problem was memory usage…
Having Firefox open with a dozen of so tabs can eat a lot of memory and unless Windows is told otherwise it loves to creates a mess between actual RAM, Virtual Memory and swapfile use.
For me it was never memory leaks, it was the constant shuffling of data between ram and other locations causing timing issues.
Most slicers are not kind enough to allow for extra time if the start of the slicing was fine.
Then the memory runs low with all those complex calculations and Windoofy start to ‘free memory’…
If this then takes longer than what the slicer expects or tolerates it either looses code or gives up with memory issues.

Last but not least: The model itself…
When people talk about big, highly detailed or complex models than quite often the model is far from it.
In reality it is the mesh that way too dense or detailed :wink:
Some creators only really care about the ease of use of their apps and the look of the final model - with no need or consideration for 3D printing.
There is a lot of models where you can reduce the triangle count by over 50% without being able to see any visual difference, let alone one in the print…
Especially when it comes to STL files it is quite possible to end up with defects - defects most slicers correct on the fly during slicing.
You only get warnings and the option to correct them if they WILL cause a slicing issue.
Quite often you see a slice fail around the same time every time.
Reduce the size by 25% or so and if it then slices just fine and WITHOUT slowing down big time once or twice you know it is NOT the model to blame.
Just give the mesh reduction a try if the model is not of technical nature or so…

What about the fixes not mentioned above?
If you can try a different computer or laptop as the first option.
working there means the other computer is to blame.
If more than one slicer fail with THIS model - have you tried a different one of similar file size and complexity ?
Just one model failing while even more complex ones slice fine usually means the model itself has some issues the slicer can’t deal with properly.
Don’t change the task priority for the slicer in Windows…
A higher priority does not help you if the system is otherwise busy, in fact it can make things far worse.
Check the memory usage in the task manager.
Right next to it you can see the CPU usage.
If the slicing requires more physical memory than what you have left empty Windoofy WILL give you a hard time…
Your slicer stuck with well over 95% CPU usage and if enabled also doing the same to your GPU is NOT a good thing :wink:
You need a really well working system in order to get away with such extremes if you deal with ‘bad’ (for slicing) models.
But adjusting the slicer so it won’t use all CPU sores and all power as the default you will have far less headaches.
And realistically those few seconds of extra waiting for the slicing to complete always beats the swearing when you have to try it again, again and then some times :wink:
In case I wasn’t clear above with complex and such:
IF you mean this in terms of file size based on things like triangle count and such ask yourself if you REALLY need this high level of details.
It is usually NOT those models coming from CAD programs that cause headaches, it the models from programs like Blender and such which rely on those many triangle and won’t care what this means for printing needs.
Even something as simple a herringbone planetary gearbox can be yours for as little as a few kb or as much as well over 15mb - go figure, all depends on how it was created and what software was used.

For future reference it might be helpful to provide a link for the model in question so that people can do further checks.

I have an I9 14900k with a 4090, and 96 gb of ram, i dont understand why it keeps dying

Reducing the mesh CAN help depending on the model. But otherwise, this is an issue that’s been going on for a long time, between several versions of drivers and slicers, even between Windows 10 and 11.
Slicing on a different computer will fix the problem, but that doesn’t mean the problem is the computer. The problem is the fact that the slicer is incompatable with something in the other computer. It’s not like this is happening to one guy trying to run his entire life on a Raspberri Pi. This is an issue tons of people are experiencing on very powerful current or last gen hardware.
It’s undoubtedly a development problem.

I just noticed a typo in my prior reply. I am running a 13900k, not a 14900k.
The 13900 is still in the Raptor Lake series. Is anyone running a Raptor Lake proccessor, especially the 13900k or 14900k, and NOT experiencing this issue?
Also, is anyone experiencing this issue who is NOT running a Raptor Lake proccessor?

  • If you can try a different computer or laptop as the first option.
    working there means the other computer is to blame.

Works fine on other computers

  • If more than one slicer fail with THIS model - have you tried a different one of similar file size and complexity ?

More than one file crashes the program, anything that has a lot of details or a large amount of small designs (filled the bed with copies)

  • Don’t change the task priority for the slicer in Windows…
    A higher priority does not help you if the system is otherwise busy, in fact it can make things far worse.

Only changed the Efficiency of the problem, which i think is preventing the program from spiraling out of control on the CPU/Memory and GPU usage which i think is relating to the crashes.

  • Check the memory usage in the task manager. CPU usage.

My memory usage doesnt change when slicing, however my CPU usage jumps by about 35% (up to 40%) and the program crashes

  • If the slicing requires more physical memory than what you have left empty Windoofy WILL give you a hard time…

I personally have 64 GB of ram available and only use about 9 gb

With THAT much memory, why not try a different approach ?
Install a VM with Windows and what you need for 3D printing.
Give it just 16GB of Ram and see if it works.
I have 64GB machine left running but it is basically only used as a VM environment and for testing things, never had any slicing problems inside the VM.
Configuring it for proper network use can be a bit of pain though.

Exception code 5 means that the program tries to access a memory which does not exists or which is not assigned to this program. Usually an unassgned pointer or a memeory location is used after it has been freed.
The error is not necessarily in the slicer, could also be in a system library.
Because you have computers where it does not crash I would load the program on both machines and then use the process explorer from sysinternals to check which dlls are loaded. And compare size and version of corresponding dlls. Also the directory from which it is loaded.
Might be you get an idea what is too new or too old. Could also help, if you change the path variable in environment.
Good luck!

same Problem here with 4090 and i9 14900k + 32GB Ram…

For me, bambu studio also crashes on my Mac Studio when it is sliced and I try to print it. Bambu studio asks to restart and when I do this and go to device it is busy printing that sliced print.
Bambu Lab please create a stable bambu studio…