Bambu Studio almost unusable, memory leak?

Welcome to the forum! :wave:

I truly believe you are correct. If it was something in Studio, everybody would have the problem. I was just pointing out even a feeble PC like mine can run it. I can run FreeCad, Inkscape, Canvas Workspace and Bambu Studio. Throw in Microsoft Word and I can still flip between apps. It sounds like there is a problem but it’s not Studio.

Yet the problem only occurs with it and goes away when its closed. Yeah definitely not it that has/is the problem. I can recreate it easily on 2 different pc’s just open bambu studio and leave it open, eventually the pc will come to a crawl when switching apps (takes hours to occur). If i close bambu studio on either they become fully responsive again.Definitely not the problem though.

1 Like

The problem seems to be isolated to systems with 64GB of memory.

I tried to reproduce this massive “leak” yesterday, but I think I failed.

Win 11 Pro 23H2, i7-8700K, 32GB, GTX1070 8G, current releases of Studio and OrcaSlicer.

OrcaSlicer 318MB at launch, Studio 230MB.

Left those two windows open for 14 hours, opened new projects every half hour or so, made changes, sliced and re-sliced, imported additions, saved and exported, printed a few items, monitored the printer via video. At times, I had two other instances of each slicer open. I also worked on my music library in MediaMonkey, did some simple video editing in Resolve, created a model in Fusion, did my taxes in TurboTax, did the usual Chrome web browsing, YouTube, Thunderbird email stuff, and ran backups on my drives.

Highest memory usage of any slicer instance was 1820MB for a complex multi-plate model. I left that open and made changes to the model from time to time for about four hours. Memory usage only varied by only a fraction of a MB when idle or when I made changes and then to dropped 740MB when I selected New Project.

At the end of the day, OrcaSlicer was holding on to 710MB and Studio had 539Mb. At no time did I have any slowdowns in the slicers or any other programs.

There was a slight “leak” in that memory usage never dropped all the way to the initial launch usage after starting a New Project, but neither slicer ever exceeded 750 MB before loading a new model.

The only recent mention that I can find of a leak on Github was for an older beta release with 32GB systems. If you want this issue fixed, a detailed bug report with log should be submitted on Github. The developers seldom see or respond to problems here on the forum.

3 Likes

It would be interesting to see where everyone that has a problem has set their virtual memory. Also, whether they are using SSDs or the old spinners. And perhaps, the age or Health Status of the SSD. SSDs don’t last forever especially when written, deleted the written again.

I have 32Gb of memory but only 4096Mb for virtual memory. I’ve heard that too much VM can cause more problems than too little. MS recommends 1.5x memory but that seem way too high.

On both my laptop and desktop I can leave BS open seemingly indefinitely with no resource change. It sits at around 1.2Gb usage indefinitely unless I open a really massive project. But it never grows during idle…

I’m running the flatpak version on Arch and a self compiled version on my desktop

One thing to note is that macOS uses the idea that “memory not being used is memory wasted.” So the OS will do a lot of caching behind your back to improve performance.

Open Activity Monitor and look at the Memory tab. Mine is open right now and the only application open in the foreground is Safari. My machine is an M2 Max Mac Studio with 64 GB RAM, and it says “memory used: 23.6 GB.”

Wow! Seems excessive!

But when I look at the “Memory Pressure,” it’s very low and green. That means that all is well, there’s no issue with memory needs.

So always look at Memory Pressure on a Mac.

Whenever i closed Bambustudio everything was back to being smooth. The longer I had bambustudio open the more laggish my mac would be become.

There is a memory leak

It’s already up there: Application keeps crashing or cancels when slicing is at 50% · Issue #3548 · bambulab/BambuStudio (github.com)
Seems not the highest priority. Unfortunately since I cannot print most of my items (unless I use my wife’s pc).