Bambu Studio cant find X1E in Lan Only

Hello,

I just got a X1E for work and i am trying to connect it to Bambu Studio. Since it’s a printer for work LAN Only Mode is required. Yet Bambu Studio doesn’t show the printer and i can’t connect.

What i did so far:
Updated the firmware with my Bambu account.
set the printer to LAN Only
connected it via a router to my pc. No other connections on the router, just so the printer gets a IP assigned via DHCP.
I can ping the Printer from my PC.

I’m no networking expert, so i need some help. Is there a way to diagnose, why can i ping, but cant see the printer in Bambu Studio?
Can I actively trigger a search for a printer in Bambu Studio?
Can i specify which network adapter Bambu Studio uses to connect to a printer?

Currently the PC is connected to my normal network via one network adapter and to the printer via another adapter.

I hope i didn’t miss any important information.

Thank you in advance!

1 Like

We are having the exact same issue with out X1E at my work… has anyone else successfully set an X1E up on LAN or WLAN mode? I run a personal P1S at home in WLAN mode with no issues so this is surprising.

Are the printer and desktop on the same logical network? Bambu studio discovers the the printers via broadcast messages, which require them both to be on the same logical network. Many wireless routers will put wireless devices on a different network and DHCP scope than the physically connected devices. Since the wireless router tends to be the default gateway for both the physical and wireless connected devices, the router will route the ping traffic between the two networks and the pings will succeed. That’s just a common example of why it may not be working for you. So the first thing I would look at is that both the computer and printer are on the same network/subnet.

I don’t think that subnets have anything to do with it :wink:

They (BL) are probably using mDNS for printer discovery. I have my X1C on a different VLAN and discovery is not an issue as long as mDNS across vlans is allowed.

That’s making an assumption on your part that they are allowing mDNS traffic across VLANs. We don’t know what their network configuration looks like and if they took the additional step to allow that broadcast traffic to traverse networks or VLANs. I realize that it’s possible to allow, but it’s not typically allowed by default. So we should at least start with networking basics, which is that Bambu Studio relies upon broadcast traffic to identify printers on the network and that typical networks would require that they both be on the same network to communicate.

Sorry if I wasn’t clear enough, with “They” I was referring to Bambu Lab.

1 Like

Ahh okay, that clarifies that for me.

I’m looking back at his setup and now I’m thinking the issue is that Bambu Studio is probably only using the primary interface for broadcast traffic and completely ignoring his secondary interface where he’s connected to a dedicated router with the printer.

Why I hate how how Bambu forces the use of broadcast traffic in order to connect. There really need a way to statically set the IP, which should have been a default for the X1E.

1 Like

Agreed. Relying on mDNS for a so called enterprise product is, well, let’s say questionable :slight_smile:

1 Like

That might very well be the case. Should be easy enough to test by either using arp from a terminal and specifying the interface or simply disabling the primary interface.

Hello weak, hello RandomKhaos,

Thank you for your discussion. I guess i could extract some information and at least some general knowledge.

For clarification, i used a standard TP Link Router only connected to the X1E via ethernet and to my PC. The Router doesn’t have any restriction other than the default settings. The Router is just a test setup.
IP Addresses are in the same subnet as specified by the router.
I also tried without a router, but the printer didnt get an IP and i was unable to set it via the display. Apparently many have this problem and there seems to be a workaround.

After some rechecking with my IT department and reassuring they got my problem right, they assumed blocked ports by company settings on the PC.
They are now looking into it, to check how they can integrate the printer in our network.
Maybe i can squeeze out some information about their solution and share them here.

As weak mentioned the arp from the Terminal. I just rechecked and using arp -a doesnt show the IP i see on my printer. But after pinging, i got the entry in the arp -a list.

Yet for now i need to use the micro SD card on the printer.

Thank you guys anyway!

I had to make my printer and computer running Bambu studio be on the same subnetwork example printer 192.168.10.1 and 192.168.10.2 when i had the computer on a different subnet such as 192.168.11.2 it could not see it.

I am in similar situation, in a secure environment with extremely limited Internet access only via USB hotspot. Going to try 3d_printer-X!E suggestions next week.

Just using a Win10 p2p but Bambu X1E wants a DNS value and we aren’t using DNS, created and assigned ideas