Binding x1c to Bambu studio

Anyone having trouble binding x1c to Bambu Studio? Mine worked fine for two weeks, now refuses to connect. I have put in a ticket with Bambu labs but no response for 3 days now.

Yesterday Bambu Labs started helping me diagnose my non-binding issue. I still cant bind it in the usual way, but can by using a hotspot on my phone. Its a little slower, but way better than pulling out the sd card every print. Idk if they will keep assisting me or not, but they did suggest that its my network problem not the printer. So I may be on my own at this. We’ll see.

Try rebooting your router by switching it off, then wait 20 seconds, then switch on again.

thanks ninyule, awesome, it worked!

My networks been screwy the last few days, maybe the weather. For the life of me I couldn’t get the Handy app or Studio to connect to the printer. Wiki only frustrated me, I went through my network and tried a few things without joy. I can see the printer on my router page, it is connected, I logged out and in (fully). Out of ideas, I picked up my X1C and carried it to where my router is located and powered up. Wouldn’t you know it, thing worked (5min after I’d sent a support ticket :laughing:). So, powered down and put everything back in place and its currently working like it never happened. GRRRR… Still not sure what changed, I swear it was a tad concerned the next step was out the door.

Glad to be of help. As a (now retired) computer engineer, it was amazing how often the turn-off-turn-on trick worked!