Chamber light stuck on since this firmware update


Since this last firmware update, my chamber LED is now permanently stuck “on” (seems dimmer?) and does not respond to the touch screen on/off. I unplugged the printer and the power cable overnight to see if it was something capacitator based, but this morning it’s still stuck.

How to report a bug?

I’m not seeing that problem, using the same printer and firmware.

Strange behaviors after a firmware update can often be corrected by restoring factory settings (Hex icon, General tab).

If that does not help, I’d verify the lamp connections. You can find them with this installation wiki.

1 Like

Agree with Ikraus. Try factory reset if this solves the problem.

I tried those both as well. Unplugging and replugging the light does nothing (turns off when unplugged of course, comes back on when hooked, even with the light “turned off” it comes on), also factory reset did nothing.

Something gone wrong with my board perhaps?

If they reenabled the ability to restore to previous firmware you might want to try and give that a shot. I’m going to wait to update as I’ve had issues since the last firmware update, so I will wait to see if more issues come out during this release.

Doesn’t seem to be an option to downgrade the firmware.

Was hoping they would allow you to downgrade darn. Unfortunately, it seems you’ve done all the troubleshooting you can already. You can put in a support ticket but don’t except a reply back for awhile.

Just out of curiosity, have you tried to turn it on, or off from the handy app, or Bambu Studio?

Yes, I have, nothing. Same behavior as using the screen.

It seems I can no longer turn off the LED, only dim it. When I turn it “on” it just gets slightly brighter, but sometimes flickers too while in this state.

Darn if it only happened after the firmware update, I guess you can wait for a new release.

Firmware downgrade is possible again after the last firmware update.

I have not updated it yet, but this is good.

Hi, did you ever get this resolved? My X1C started doing this today. It was fine for about a month with the new Firmware, but then randomly the chamber light is extra dim and I can’t turn it off as shown in your video.

not a software problem, hardware most likely, check your wires and grounding cables. your printer looks a little aged, so the vibrations may have loosened something.

Thanks. The original post/video is not mine, but I’m having a similar issue. I’ve only had the printer for about 6 months with about 500 hours. Took the covers off and checked all my cables and they seem fine.

Their quality problems with a new product would not bother me as much if Customer Service jumped on and resolved customer problems quickly, not weeks before any responses.