Choosing different filament to print on an AMS unit

On my Bambu Slicer I configure my AMS unit for position # 3 to be black and loaded four filaments. On a print I chose the object and painted in with filament # 3 (black) inside the slicer. When it printed it defaulted to Filament # 1. Is there a way to select filament position # 2, 3 or 4 to print versus having position #1 being the default.

Did you ‘paint’ the whole object in the slicer and should it be single color?
If it is only single color and you send and start the file to the printer via Bambu Studio you can select the AMS slot during the setting (where you choose also if you want to have the calibration lines etc).

And if you want to have your four slots always as an option in the slicer, you can switch to the object tab, right-click the object and in the drop-down menu you can switch filament to slot #3.

1 Like

I did the whole object. I also tried right click on the object and selected selected change filament and then roll 3. no luck. I will play around with it more

I tried it today by myself - sliced an object with AMS slot #3 and when sending to the printer it was preselecting slot3:
image

And as I mentioned, you don’t necessarily select a slot of the AMS if you slice a single color object - you can select the filament on the screen with this button (only the selected filament type in the profile and in the AMS have to match).
The same option is available on the machine when selecting an object to start printing.

Latest version of FW & BS installed

Thank you for this. I think there is still an issue. I may be missing a step, but I am having the same problem as https://forum.bambulab.com/u/Fastcars2 above.

Here is my situation:

  1. I’ve got the AMS slots loaded as follows: Slot1-PLA, Slot2-ABS, Slot3-PLA, Slot4-PLA
  2. I entered the info into the X1 terminal for the ABS in slot 2, as I just inserted it.
  3. I clicked on the “Syncronize the filament list from AMS” button on the Orca slicer.
  4. I can see that slot #2 now shows Generic ABS and is the correct color.
  5. When I slice it, I get and error about not using the Engineering Plate for the type of filament I’ve selected, and I can see it has “selected” Slot 1 (which is green PLA).

I saw your message about clicking on “Objects”, then right-clicking each object (I have three on the plate) and selecting “Change Filament”, then clicking on slot #2, and that seems to work. But I can’t find a way to make the “default” filament anything but slot 1. How do I do that?

1 Like

I don’t know how to change the default to anything other than slot 1, but today I learned I simply have to select an object (or all objects using Ctrl-A) and press the number key on the keyboard corresponding to the slot!

That makes it a lot easier than right-clicking when you are using a trackball.

15 Likes

This helped allot! Thank you.

You can right click on an object, then in the menu “change filament”

Thank you. This works good for me too. The overall UI usability for this app needs some work. Filament management feels like a bolted on afterthought. As and ex UI designer is drives me nuts. :slight_smile: