Does the AMS filament runout sensor only work with BL filament spools?

Just ran out of material mid-print while printing in my office and saw the printer continuing to print in the air with no filament. I thought that the printer would stop and warn me to load another filament but no dice. I paused the print and tried to load from another slot (even though the layer would have been too high) but the AMS wouldn’t let me load there either. I’m using PolyTerra filament which is not on a BL spool with QR code.

Should that matter? Shouldn’t the printer/AMS stop and warn me?



Yes the printer should have stopped and waited for a refil…
Doesnt matter what spool you use as the sensor is down stream.
If the sensor didnt pick up that the filiment ran out, and the AMS wont let you re-load, sounds like you may have a broken piece of filliment in there.
Not too familiar with Polyterra…is it a brittle filliment…?
Looks like you will have to investigate

1 Like

Thanks for the reply. I will check it out. Sounds like I may have to remove the nozzle to check. I haven’t had this issue previously and it’s been working mostly flawlessly since July.

PolyTerra is one of the preloaded filament presets from the factory. Great stuff, not too brittle. Have had lots of success with it even before this BL X1

Same here … the thing works flawlessly.
If you have been using since July, I wonder if there might be a bit of dust build-up in the system that has made this happen. Will be interesting to hear what you find.
This might be part of the maintenance program to clean the system out every 6 months or so.
In fact I might have to suggest a maintenance timer, so after so many hours printing it prompts you to clean certain parts…??


I had the similar issue, I pulled out the old filament (it was still int the AMS feed) and then tried to reload…

There was lots of smoke from the extruder but it did work and the issue seemed cleared, sadly it was the last few layers of a 10h print so the part was effectively scrapped

Don’t know why the runout sensor didn’t work, it was still printing with no fillament and even tho the filament was in the AMS feed it wasn’t feeding it through??

Any thoughts?