"enable nozzle clog detect at 3rd layer"

In the 3rd layer, the print heads of my A1 and A1 Mini move to the left rear corner once. I think this corresponds to the gcode behind the comment “enable nozzle clog detect at 3rd layer” in the gcode file.
How is that supposed to work?

if is exactly the same on both printers, then there is an issue with the model/gcode

I’m experiencing the same thing which is causing imperfections when trying to print ColorFabb varioShore TPU. It’s a foaming TPU so any unnecessary movements affect print quality dramatically. I bought the A1 Mini specifically to print this material so hopefully the issue can be resolved. The gcode looks as follows:

; enable nozzle clog detect at 3rd layer
M400
G90
M83
M204 S5000
G0 Z2 F4000
G0 X-6 Y170 F20000 (toolhead moves off bed here)
G39 S1 X-6 Y170
G0 Z2 F4000
G0 X90 Y90 F30000\

Any insight to what could be causing this is greatly appreciated!

I’ve found a workaround that solves the problem but (I think) disables clog detection. I’ve never been worried about clog detection on my X1C so not having it on the A1 Mini doesn’t seem like a big deal. To fix the issue you’ll need to edit the Machine gcode in the Printer settings. Under the Time lapse G-code section you’ll find a block of commands that looks like this:

M622.1 S1
M1002 judge_flag g39_detection_flag
M622 J1
; enable nozzle clog detect at 3rd layer
{if layer num == 2}
M400
G90
M83
M204 S5000
G0 Z2 F4000
G0 X-6 Y170 F20000
G39 S1 X-6 Y170
G0 Z2 F4000
G0 X90 Y90 F30000
{endif}

By changing the “layer num” value to something higher than the model being printed, the scenario where the extruder runs off the bed (and in my case drools varioShore TPU all over the place) is avoided. I presume that clog detection in this case is turned off but there is a command in the Machine start G-code section turning it on at the beginning of the print so I am unsure if it’s actually off or not. I can least say that it solves my problem of causing surface defects for now.

I’ve got the varioShore TPU dialed in almost perfectly now on the A1 Mini and will be uploading the settings to Printables and MakerWorld as soon as I’m convinced they can’t be improved any further. I found the varioShore settings for the X1C on Printables to be rather disappointing as they clearly go against some of ColorFabb’s recommendations and produced rather shoddy prints in my opinion. The author based them around Bambu PLA Basic for some reason and then edited most the parameters while forgetting some critical ones like fan speed. The prints would finish but had a lot of zits and required quite post processing. I’m at the point of almost having PLA level quality and zero post processing so I know I’m getting close to perfect!

Hello, I tried to use this solution, but I’m unable to find this lines in my A1 mini gcode with date: 20231201. Can please share the complete gcode from your A1 mini please ?

How do you get to see the gcode and edit that out. When I try to view the gcode with notepad or with NC viewer it is a bunch of ? And where letters not the actual gcode. I have this same issue with the stupid 3rd layer thing and I’d like it to not be there