External spool + AMS

I would love to be able to print tpu and pla in the same prints. Could just have the machine pause, send out a prompt asking the user to pull back or insert manually for the tpu. It would then wait for the user to hit done and then feed from the ams. I want to print a carbon pla tool box with tpu inserts printed in place.

1 Like

Looking at this video yesterday made me think about this sort of thing too. I did raise a comment about possible automation workarounds and he says he is working on something.

Anyway, your suggestion did lead me to one other thought, which is - if you don’t mind babysitting and doing a few manual filament changes then one idea could be to to trick the printer into thinking it is getting PLA (with the right settings for TPU) from the AMS, when it is actually getting TPU from the side spool.

  1. Introduce a pause into the gcode layer before any changes to tpu are required (or just keep a careful eye on the printer.
  2. Use a spare for example PLA channel on the Ams to hold the TPU parts of the model - with the PLA settings change to be the ones required for TPU,
  3. Before the AMS starts feeding the dummy PLA channel disconnect the AMS ptfe and start manually feeding in TPU from the side spool almost to the print head
  4. Release the pause and then as soon as the AMS starts feeding the dummy PLA push the TPU down to the print head manually so that the filament is detected and the AMS thinks it has done its job.
  5. Once the dummy PLA/TPU is finished and the AMS starts pulling back and respooling the dummy PLA - pull out the TPU and reinsert the AMS ptfe and let it carry on until the next layer that needs TPU

PS/ steo 1 pause could be generated by just pulling out the dummy PLA filament end from the AMS inout feeder - so that it pauses and prompts you to reinsert it.

Link to video with automation comment

1 Like

I tried to test this, but the printer ends with an error after 5 trys of loading the “dummy PLA” if the PTFE of the AMS is not connected to the printer. Error is “somithing is wrong with the buffer sensor” and he do not accept my TPU I loaded manualy to the extruder. :frowning:

I tried it again myself a few weeks ago too and couldn’t get the timing right this time. So ended up printing the PLA supports for TPU separately and inserting them into the paused print,

I still think though that it is possible to get this ‘tricking the AMS’ method to work, perhaps with some custom add ons to help get the buffer and extruder sensors synchronised correctly . Will investigate further,

2 Likes