Failed to pull out filament from the extruder

Hi !

I get this message more and more often when printing multicolor, and indeed the filament seems broken in the extruder, but it is not difficult to remove.
I remove the PTFE tube at the entrance to the extruder and the filament comes with it.
I don’t understand why the filament is not retracted by the AMS
I thought the cutter might be worn, I replaced it but that doesn’t change anything.

I don’t think there is anything stuck in the extruder because other than this message it extrudes fine.

I should point out that I recently added an AMS, but there doesn’t seem to be any problem there.

ideas ?


These borderline cases occur more often. Also with my printer with AMS already. The extruder does not manage to pull back the filament. If you pull the filament yourself, however, it seems to work without any problems. In fact, the filament gets stuck a little. Or it is too soft for the extruder at that moment. The problem is that the heat from the hotend is not properly dissipated and the filament is deformed above in the extruder.
With my printer, everything works at first until it has printed for about 20min and the heat keeps building up in the print head. At some point during the next changes, the extruder no longer manages it, the filament is deformed and I must open the extruder and free it from the filament residue.

Translated with DeepL Translate: The world's most accurate translator (free version)

Diese Grenzfälle treten öfter auf. Auch bei meinem Drucker mit AMS schon. Der Extruder schafft es nicht, das Filament zurückzuziehen. Zieht man selbst am Filament, scheint es aber problemlos zu funktionieren. Tatsächlich steckt das Filament ein wenig fest. Oder es ist in dem Moment zu weich für den Extruder. Das Problem besteht darin, dass die Wärme vom Hotend nicht richtig abgeführt wird und das Filament oberhalb im Extruder verformt wird.
Bei meinem Drucker ist es so, dass zunächst alles funktioniert, bis er etwa 20min gedruckt hat und sich die Wärme im Druckkopf immer weiter aufstaut. Irgendwann bei den nächsten Wechseln schafft es der Extruder nicht mehr, das Filament ist verformt und ich darf den Extruder öffnen und vom Filamentrest befreien.

1 Like

I had this happen over the weekend for the first time. It has been quite humid here (S California) on and off. I was also traveling for most of Aug, so the printer didn’t get used much during that month. I had a few filament breaks in the AMS.

Prior to this, I’d never seen this in the months I’ve owned the printer. I’m believing it is a filament problem.

I’m going to try drying some of them this week. I’ll start with X1’s mode to do this.

thanks for your answers, so first i’ll dry filaments, then print a model with a lot of filaments changes with the top glass open and the door open

I cut this section out of the hotend cover and never had this happen again. We need someone to make a ducted cover. It was mostly happening to me while printing asa.
I need to clean it up a bit but it killed all heat creep

I had this issue a ton with a roll of Bambu PLA-CF. After doing some reading, I figured out that the problem was that the roll which was only .25kg was too light, and when the AMS needed to really pull hard, it would turn the drive roller without being able to move the too-light roll of filament. I solved the problem by simply laying a “D” size battery inside the spool hub. This extra weight took care of the problem 99% of the time.

yes i know this issue, but in my case it’s not the same issue. It seems to be a problem of tempature like KaffeeKafee has described it above

yes radical solution, but if it works… i think it resolves the temperature problem described by kaffeekaffee
For the moment, i try to print the same model failed before with 500 filaments changes, but i made two changes
first one : i print with door et upper glass opened
second one : i don’t use purge tower

until now it works (print in progress), no error message and it already print for 10 hours now

1 Like

open the chamber to work is a good thing and helps in the most of this problems. at other users too.

I had same problem last week: suddenly my filaments (PLA) stuck in extruder and jammed the whole system; the AMS wasn’t able to retract. It happened several times within a few days, so I thought something was broken. Like you, I changed the cutter, changed the bowden tubes, etc. but nothing helped.

I assume that you have “heat creeps”. Is it very warm in your area at the moment?
Due to warm enviroment AND all the heat from nozzle, housing, etc. the filament becomes already soft in the extruder. This results in clogging the extruder / jamming the AMS.

Since weather change (ten degrees less temperature :stuck_out_tongue: ) and opening the front door while printing all my problems are gone…

Hello, no it’s not very warm in my region at this time, but i confirm that print the same model with door et upper glass opened have solve my issue.
However during the new print i have had another issue : “failed to extrude filament…”. The extruder wasn’t clogged but while a filament change, the new filament didn’t enter in the toolhead, it seems it was blocked at the enter.
I have searched an answer to this new problem on the forum, and i found that the reason was that the PTFE tube wasn’t staright above the extruder. For this issue there is a STL of a bracket to print, i will try.
Sample of STL :

This sounds like all the problems I had… :stuck_out_tongue:

Of course you can try to the mentioned bracket, but if your system worked fine in the past I don’t think that this will solve your problem.
Fun fact: I tried this bracket / versions / remixes by myself because I like to test “goodies” for my bambu. But I refrained from these; sooner or later they all broke due to the continuous movement and rattled around.

First I would try the “easy” things:

  1. perform a self test (I think you already did)
  2. take off the magnetic front cover (tool head). Take a look to the connectors/wires. If i remember correct, there are 4 connectors: 3 for nozzle, 1 for extruder unit. Be sure that the connections have not come loose.
  3. Put your darkest (black) filament in AMS. Light up the chamber and hit the load-button. Take a look at the tool head / where the PTFE-tube goes into the tool head: can you see the dark filament within the tube going in the tool head? If the filament makes it to head, your AMS works fine. If not, something is blocking the way. In this case check all tubes from AMS to head if there is some broken filament in the way.
    If the filament reaches the head: heat up your nozzle to your filament’s melting point (e.g. PLA 220°). Hit the extrude-button on display: is filament pressed out? If not you have a clogged extruder and/or a clogged nozzle…

Try the “complicated” things:

  1. Are you really, REALLY (!) sure that your extruder is not clogged? You can’t see it from outside…
    Remove the extruder unit from tool head, disassemble the extruder unit and take a look inside. Be sure that no filament is stuck. In my case there was a bulbed piece of filament blocking the extruder… Clean the all componets inside with compressed air and/or Isopropanol.
    The process is described here: Extruder Clog | Bambu Lab Wiki

  2. Check your nozzle: remove your nozzle from tool head but keep wires connected. When your nozzle is free, take a look from above: can you see filament in there?
    Yes: do a “cold pull”. Take an 1,5mm Allen key, heat it up with a lighter, press the hot Allen key in the filament and wait for 30s. Then heat up your nozzle to 100° and pull the filament out slowly.
    No: Heat up your nozzle to your filament’s melting point (e.g. 220°), take a piece of filament and press it from above in the nozzle (CAUTION: VERY HOT, wear gloves!). Let it cool down. Then perform a cold pull described as above.

Repeat the cold pull procedure 2-3 times.

Allen-Key- / Cold-Pull-procedure is described here more detailed: Nozzle clogs | Bambu Lab Wiki

Reassemble all parts, do a self test and a test print.
Good luck!

thank you for your complete answer !

in fact my problem occurs after à long time of printing and only when there are filament changes… I d’ont have any problem for à short print.
I had the intention to dissassemble the extruder as you recommended it, so i did it.

the extruder is perfect, there isn’t any filament residue inside.

Regarding the hotend, I have seen a filament head at the top, but I think it’s correct because the cutter cut the filament at this level, so it’s that we have to see no ?
it always must have a visible piece of filament on top not ?

Another question please : i didn’t find the “silicon glue” tu put on the extruder connector when you replace it, do you know which glue is it ?

Regarding the hotend, I have seen a filament head at the top, but I think it’s correct because the cutter cut the filament at this level


Now take an allen key (1,5mm), heat the long end up with a lighter and press the hot allen key in the filament. Wait 30s until the melted filament becomes hard again / is connected to the allen key. Then heat up your nozzle to 100°: the filament in the nozzle will not be liquid, but soft. Now pull the allen key slowly out. Due to the gummy filament all impurities within the nozzle are also pulled out.
Repeat this process 2-3 times.

(please note the pictures are for demonstration only; I took a replacement nozzle which was removed from the printer)

If your problem still occurs, I have no further solution. It could be that the nozzle is defective and needs to be replaced. But this is very unlikely… I would open a ticket at Bambu Lab first.

Another question please : i didn’t find the “silicon glue” tu put on the extruder connector when you replace it, do you know which glue is it ?
I also didn’t have silicon glue. I connected the cable without the glue. The last two weeks I printed for almost 24/7 without any problem. In my opinion the missing glue is not critical. If you want to be sure, ask Bambu where to find… I don’t know :wink:

Hey, thanks a lot
ok i will try.

so, you’re right, my nozzle was clogged.
But is was a partial clogged i thnink, because i could begin a print, print for 2 hours, and then have the error message.

i didn’t do the procédure of cold pull right now, i had try to replace the nozzle first because i had a spair part.

I will try tomorrow to print a multi-color model with a lot of filaments changes, to confirm the issue is resolved

Thanks again

I started having this problem and after disassembling the extruder there was no filament. Have tried to print and keeps telling me that there’s filament, to the point that can’t start any print. If I manually feed the filament, it will print perfectly, but at the end will give me the same error. I think is a defective extruder, but can’t get any response from support. The printer is less than a month old.

Back to this matter.
I actually had a lot of different AMS problems and different AMS messages, but it was the same stupid cause!

I think all the issues were with the AMS hub cable. The shape of this black cable was such that it touched the spring behind the hole on the AMS hub side. He must have blocked the spring

I have the same experience as [dc3210]. I find if I just stop the print, head up the head manually to 250 (It usually jams with PLA Silk filament), and then hit the manual extrude button while pushing the filament in from the back, the head will clear out and once the filament is seen flowing, manually retract the filament.

Unfortunately, this usually happens in a multi-day print and the print has to be aborted. If anyone knows how to grab manual control of the extruder while the print is paused, it would make this issue more tolerable, not losing a day or more of print and filament!