How to fix black filament bleeding into white

I am trying to print a Lightbox with black and white filament. Every print have black filament stuck in the white.
I maxed out the flushing volume from black → white at 999 and set the sequence as white → black, and that seems to help a bit. But after staring at the prints for hours it looks like the remaining problem is z-hops during the black prints. Sometimes when the z-hops over white portions happen either a string of black could land on the white or perhaps the toolhead is dirty with black and drag across the white. The next layer of white then imbeds the leftover black into the print.

I am not familiar with configuring z-hops. So my question is if there is anything I can do to reduce the issue. Can I change the z-hops to improve the quality. Or should I slow the printer down. I am using the preconfigured standard speed settings which is (in my opinion) already slow for the first few layers.

I Hope you did flow dynamic and flow calibration for all filaments. If Not, filaments can oze Out of the nozzle.

Calibration of filaments can reduce that drasticly.

I’m having the same issue. @Lucyna_Kushinada I see Flow Dynamics Calibration option but I get a warning that it may fail on the textured plate. Should I try it anyway or use a different plate?

I dont have an X1C. My printer is an P1S. There it is done manualy… :smiley:

Have exactly the same issue with my A1 and AMS Lite. Really annoying and I am coming to the conclusion that I just can’t use it for what I want it for.

Is it possible to have the white layer print first so that the black layer can’t get garbage on the bed as its printing it’s first layer? I noticed that the object I’m printing starts with the black and then goes to white. Maybe if it does the white first and then the black, I won’t have the black “artifacts” in my white???

Go to the calibration tab and do both calibrations on a high temperature plate and save the results with an appropriate name. I have read that the calibration it does before a print doesn’t get saved.

If you were using non Bambu filament, the calibration will be saved but you will need to select it from the list again the next time you use the filament. Also, after you choose the filament you want in the prepare section, make sure you select the flow rate calibration you did instead of leaving it as the default selection.

I have gotten it much better by doing the following. It’s not perfect and I would need to play with settings more but I moved on for now;
Print white layer first. And if more than just black and white, go from lightest to darkest. So the sequence would be: 1 layer white, then 2 layers black, then 2 layers white and so on. My only issue remaining is the second time transitioning to white. See photo of “hair” of black laying on white. The next layer of white would embed it into the white.
Maximize black → white extrusion.
Further mitigation: on the filament settings for black, enable “z-hop while retracting”. This helped quite a bit. And I’m sure dialing in the remainder of settings in “settings Override” tab would fix the problem.

Since I’m using a textured plate, should I choose that instead of the high temp plate?

You do the calibration of the high temperature plate, selecting the high temperature plate in the plate drop down. Then when you print the model, choose the textured plate, don’t do a calibration, just select the saved calibration that was done on the high temperature plate.

I did the auto calibration but I didn’t see a way to save anything. Even in Manage Results it doesn’t show anything. I guess it should be done with the manual option?

I get an option to save it after I do the auto calibration.

On the last page of the calibration section, I think there is a drop down with a suggested name, you can change the name or select a previous name already saved.

I don’t remember if there was an actual save button or just a next button, but it definitely can be saved.

This is where the Flow Dynamics is saved:

Screenshot 2024-01-07 at 6.50.39 PM

I clicked the pencil icon on the Red PLA. Here is a list of Flow Dynamics I have saved

This is where Flow Rate is saved:

I noticed when looking at the list that I need to calibrate a filament. I will post the screenshots to show how to save it.

Go to the Calibration tab and tap Flow Dynamics

Click Auto-Calibration

Select the filaments you want to calibrate and select the High Temperature Plate for Plate Type and Click Calibrate. I think the cold plate calibration won’t work correctly for the textured plate. Somebody can correct me if I am wrong.

I selected both a Generic and a Bambu filament to calibrate.

Click Next when the calibration is finished

On this page, if you leave the Bambu PLA Basic as it is, it will apply the flow dynamics to all colors for Bambu PLA Basic. You can click the drop down and select a previously saved calibration to overwrite it, or just write a new name in the name box and it will save it under that name.

Here is an example of changing the names. When you click Finish, a message box will say that the setting has been saved to the printer, I forgot to save that screenshot.

Then go to the Flow Rate Calibration page and click Auto-Calibration

You can only calibrate one filament at a time for Flow Rate. Select the High Temperature plate and the filament and then click Calibrate.

Click Next when the calibration is finished.

You can change the name in the preset box and click Finish.

A box will appear saying it has been saved to the preset. For the Flow Dynamics, the box said saved to the printer, so that might mean that the Flow Rate is just saved to the computer and not the printer, I am not sure.

The Bambu filament works the same


Wow, this is an awesome post. I do have one question. After you do these calibration processes on the X1C, are you supposed to uncheck the “Flow Dynamics Calibration” check box on the print dialogue box? I am still confused on that one.

Thank you!

Mike

Yes you can uncheck flow dynamics calibration if you have already saved the calibration. Just make sure you select your saved calibration before you print.