How To Print NinjaFlex 85A TPU

Thank you so much!
I got the best results ever when printing Ninjaflex 85.
I have also have a Prusa mk2.5 and manage to print 98A and 95A filaments fine but never got the results I wanted with softer filaments.

Your help was much appreciated.

The only strange behavior I have is sometimes (this may differ if I print from the computer or from the printer memory) the Bambulab seem to do a bed calibration after the print so I might have something wrong in the Gcodes

Here are Bambu Slicer config files for both a filament profile as well as a printing profile for Ninjaflex 85A. The only thing you cannot configure now in bambu studio is the pressure advance. Other than that its perfect. Ive increased speeds slightly

File>Import and from there select the json files

Hi, seems the file is deleted. Would really appreciate if you could share it again :slight_smile:

Hi 3D Tech!

Thanks for the great tuned profiles working with Ninjaflex TP85A

After battling trying to get a good print with this filament, I was able to get some decent results with your settings. I am just having a peculiar issue in Bambu Studio (I know you mention to use Orca but I am just trying to stick to Bambu Studio for now).

After I slice, I notice that the Nozzle Purge (black on picture) line is different than the manual Ext Spool selected filament for the Model (TPU Loaded there). Note on the picture that the purge line is Black PLA (belonging to A1 Filament in AMS). Is there a way to make the purge line the same material as the model so that it doesn’t think its printing with 2 filaments in the Preview?


I obtain the following error when I try to slice on Orca 1.0 RC2 :

Failed to generate G-code for invalid custom G-code.
change_filament_gcode Parsing error at line 31: Referencing a vector variable with a negative
M620.1 E F[old_filament_e_feedrate] T{nozzle_temperature_range_high[previous_extruder]}
Please check the custom G-code or use the default custom G-code.

Using Orca Slicer 1.8.0 and getting the following error any chance you have an updated version that works with the latest Orca?


Failed to generate G-code for invalid custom G-code.
change_filament_gcode Parsing error at line 31: Referencing a vector variable with a negative index
M620.1 E F[old_filament_e_feedrate] T{nozzle_temperature_range_high[previous_extruder]}
Please check the custom G-code or use the default custom G-code.

Hello ondrovic,

When I have time I will look into it and see if the settings need to be changed in Ocra slicer or G-code updated for the newer BL firmware also what printer do you have and firmware version ?

Hello! Thanks for all the advices. Just got my printer and some TPU for a project and tried it. Worked like a charm but i did’nt have the spool holder on top and the shorter PTFE tube yet so the filament stopped flowing. I have to install that. Do you have some spool holder model to share that works fine for you?
Thanks again for all the informations and work you did.

Also, quick question: my tpu filament seems to stick to itself on the spool. I never noticed anything like that with filament but don’t usually go with that kind of TPU. Is it normal? Should I dry it somehow? [it’s ninjatek ninjaflex brand new, out of the box]

A few pictures… yeah it’s a rock. Just a rock but soft. :smiley:

Hello Tam501e,

When I use the 85A TPU I just use a low friction bearing spool roller. The one I used on the BambuLab X1 is a modified Eibos filament dryer; it was just above the printer feeding into the short 150 mm ptfe tube with the soft tpu you need to keep the fiction as low as possible so the extruder will be happy.

The Ninja flex sticking on the spool I have had one black roll like this and I just respooled it and it has been fine. Can you see if they will replace the roll under warranty being you just purchased it.

Cool TPU Rock :slight_smile:

1 Like

X1C Firmware Version (Latest)

Ok I just tested it out with the Bambulab X1 firmware and OrcaSlicer V1.8.1 Official Release and it worked.

I have the first layer inspection off and AMS unhooked.

Try again with the new OcraSlicer version and double check you have your start G-code correctly done.

Post all your settings if still not working for you.

You can update the bed plate g-code but it’s still working with the original bed plate g-code posted in the past I did update it for the new firmware

;===== for Textured PEI Plate , lower the nozzle as the nozzle was touching topmost of the texture when homing ==
{if curr_bed_type=="Textured PEI Plate"}
G29.1 Z{-0.04} ; for Textured PEI Plate
{elsif curr_bed_type=="Smooth PEI Plate / High Temp Plate"} 
G29.1 Z{+0.0} ; for WhamBam / Smooth PEI Plate / High Temp Plate

Keep me updated

Hello, I did a bit of tweeking according to your suggestions and it is working fine with my setup now. The default you could see was due to overheating. I lowered it a few degrees.

I finally installed my spool above, using those two projects :

It works fine for now but I will update it with 45deg angled piece to orient the spool in a better way (toward the extruder might be even better).

Today I could print a bigger smooth rock again (in 6hr), all on its own after a few supervised prints that went fine. I used 15% gyroid infill and will try to lower it to 12 or even 10%, because the fluffier the better.

I’ll keep you updated and share with you my printing profil if you want, as I’m willing to print 60 to 100 of those rocks for a project.

So essentially you had to remove everything that makes this printer special in order to print ninjaFlex. This is incredibly disappointing. I have a voxelab aquilla x2 that prints faster than this. 20mms is incredibly slow, are you sure it cant print faster than this? Why is the flow calibration being turned off. I printed with it yesterday using the generic tpu slowed it down a little increased flow and it worked fine for exception of the first layer. It under extrudes on that first layer no matter what I do to it. I used your settings for a print and it didnt work at all. came off the bed plate immediately. spaghetti.

Hi Conley,

I have other printers I use to print tpu filaments at higher speeds using a .6 nozzle the problem with the very soft tpu like 85A or less is the extruder in the bambu x1 it can grind up the very soft tpu filaments it also helps if you back off the extruder tension screw on the x1

The quick start x1 g-code was to help stop the filament from plugging the nozzle and the extruder grinding up the filament if you add nozzle wipes and calibration lines the longer you have softer tpu’s not printing the risk of the nozzle plugging and extruder grinding increase.

So if using a .4 nozzle with say 85a or lower tpu the safe thing to do is keep the speeds low and the line width smaller this gives less nozzle back pressure and this helps keep the filament from getting grinded up by the extruder.

What hardness tpu are you using 95a ?

What are your current slicer tpu settings and filament settings post some photos.

Bambu did add tpu settings for basic 95a tpu and 95a high speed tpu’s only.

95a tpu filaments can do way more in speed than the softer tpu’s.

Also the bed plate needs the correct tpu glue to stick real good also blue painter tape and tpu glue helps if needed.


Start slow with your first layer and first layer infill @ 15 mm/s or 20 mm/s for both settings.

  • You might have to set your first layer height higher

  • You might have to set your bottom surface flow ratio higher

  • You might need to set your first layer line width higher

When you have a good first layer now you can work on your first layer speeds @ 5 mm/s steps you have to find what speed will work for your tpu filament.

Also these settings was done a long time ago. Many things have changed in the Bambu lab x1 firmware and Orca slicer.

Hope this information helps you out :v:

im using 85A and the Edge 83A. I switched back to bambu’s cause I was having success with 95A without any issues but that not the case with 85A. Ill give the orca another go tomorrow and see how it goes. it was really bizarre on the first try. with your info it was printing really high above the plate. I may have entered something in wrong. Ill also try loosening the screw. I just got the printer yesterday and havent had time to mess with it till now. coming from Cura its a bit of a learning curve. My first layer has to be flawless with minimal grooves in it as its going in a Air care helicopter and cant build up bacteria.
but ill retry with your new info and post some feedback.

Thanks again.

What firmware is on your printer ?

Mine still has the old firmware version but some people with the new firmware have reported some z offset problems.

Also if you did not know the newer versions of Orca slicer you can adjust the Z offset now or you can change the g-code G29.1 Z to a new offset value as needed.


Hello everyone! It’s me again with my silly questions.
I keep printing with Ninjaflex (which is labelled 85A) and started with ArianePlast 85A TPU using the same settings with my P1S.

With the ArianePlast filament I had to do a few temperature adjustment (I reduced it by 5degrees on the nozzle and increased the plate by 10 degrees) and it works great.
The result is very different in term of resistance. Ninjaflex is waaay softer. What could explain such a difference considering they have the same shore rating? Two manufacturers can diverge that much?

They can, depending how they actually measured it, and given they usually only give the rating to the nearest 5 or 0 there can be quite a width - and the other issue is that the shore rating of the filament isn’t always the shore rating of the printed part - Taulman, Rigid, F3D all make soft filaments that are cold strained as the final step while drawing the filament, that hardens the surface so it feeds better but once it’s heated it softens again. I would imagine a few other manufacturers are doing similar.
How hot or cold you print it can have a small effect too, as does post annealing.

1 Like

Thanks for the answer that is very clear and helping :slight_smile:

Again, thank you everyone for your tips. I keep printing 24h longs rocks with this TPU and it works fantastic.

Here at 18hr, bit of stringing around the support but nothing really bad.

1 Like

Wow that is one big rock …:+1: I think you just set a 85A tpu world rock record … :smiley:

Just a few things if you have not tested it out already with the newer Orca slicer.

Test your pa setting it might be in the 0.135 range on this roll use the line test and set the PA line range 0.08 to 2

Test your retrations settings again they might have changed but the filament must be dry also or it will string some.

Make overhangs printable in the new Orca slicer if you can change the shape of the rock a little this will help on overhangs and not need support sometimes.

What are your current overhang speed settings @ and nozzle temp @

You might want to test out adaptive cubic infill on these big rocks. It can save time but you will have to adjust the density sometimes to a higher value due to the top bridge layer and the filament being used.

Happy 3D Printing :v:

1 Like