Is anyone else having weird issues after this last firmware update?

All of a sudden after this last firmware update I am getting what I believe is under extrusion, the layer lines aren’t actually touching each other anymore after the first layer. This starts from the second layer all the way up and has been causing this weird texture on my top surfaces. Just to throw it out there no that’s not my infill, I’m using gyroid infill, and it’s only set to 25%. If I try to run flow calibration in Orca or Bambu Studio they come out with the same weird texture and none of the different flow blocks seem to change much. I did do a factory reset after the firmware update and it didn’t change. The same stuff I was printing fine a couple of days before the firmware update now has these issues. I also tried to do a few cold pulls on the nozzle just to make sure it was clean and it came out clean. What’s weird is now if I just use the default Generic PLA profile and let it auto-calibrate it is coming out better than my tuned profile and it was the other way around before. But even the Generic PLA profile has the second layer and above issues and while the top layer improved a little it is still very noticeable.

I have no idea what this could be. For me, the update went without a hitch, and everything prints as before. I assume correctly that you have run the printer calibration and dried your filaments?

Yes, the filaments are dry, and re-ran calibration right after the firmware update and again after factory resetting the machine.

I´m having some issues where the filament won´t stick to the bed no matter what I do. Even with the PEI textured plate, recently dried PLA just wont stick. I´ve calibrated the printer 5 times already, changed nozzle, cleaned the previous nozzle carefully in and out, peformed dinamic flow calibration, bed leveling… I´m no expert, but I’m starting to guess judging by what I´ve seen, that the nozzle starts printing too high from the plate. if you watch closely you can see the filament is being laid down, like it has a gap of about 1mm to the bed. I don’t know but since yesterday I only managed to do 1 print and it was not really great. Every time I try now, it just makes a big blob in the nozzle, which I have to clean again every single time. I don’t even feel like trying anymore, nothing has worked for me. Curiously, this started happening since the last update of bambu studio.

I think we have the same issue!!!

It does look like underextrusion, but also the nozzle is hitting those bumps. Increasing extrusion ratio only makes it worse, not better.

I noticed this ~10 days ago or so and have been troubleshooting it since then, so not sure it’s connected to the firmware, I believe that came after, but maybe I’m wrong.

P.S. Anybody now when the firmware came out?

1 Like

I think it came out a couple of days back if I´m not mistaken. 2 or 3 days I believe. At least that’s when my printer told me about a firmware update.

That was, came some time before, I’m thinking my problems actually did start after that firmware update.
I’ll try downgading after my current print finishes…
Btw @19mar94 your issue is different from ours, I suggest you create a new thread for that. I would suggest scrubbing the sheet with hot water and soap until you can feel it getting rough to the touch when washing it, then drying it without depositing dust on it (so don’t scrub it with towels, just dab it) and then try again and turn on bed leveling during that print. If your filament is weird then try 3D LAC or hairspray on the sheet.


Thank you very much @zviratko , I really apreciate your assistance. I’ll try what you said and will chime back if it worked to thank you again. And if not, I will gladly start a thread in the right place. Cheers mate!

I would agree it looks like we have the same issue, sorry you have the same probmem but I’m glad it’s not just me. Could be coincidence but I really don’t think i had this problem before the last couple firmware updates. Also they released 2 firmware updates in the last week or so because the first one had a problem, I had done both.

I rolled back all the way to 01.05.02 and it didn’t fix anything, on the contrary it started complaining about X axis resonance having changed (right after I calibrated it). Recalibrating didn’t help. What helped was adding tension to the belts… I bet it has something to do with our tensioners not working correctly or the rods not being square, maybe in combination with some resonance compensation changes (maybe drivers were updated but not downgraded).

In either case, the problem persisted until I decided to try with a Cool Plate and a default profile (250mm/s infill vs 300mm/s infill which I used before). Now the problem was gone. Increasing the speed back to 300mm/s didn’t trigger the problem.
Then I changed the plate back to Textured PEI, printed the same thing and there are no bloody artifacts (not those we are talking about here anyway). There’s some underextrusion near the wall, even with PA enabled, that might also have something to do with it…

I’m lost. I hope support (I filed a ticket with all logs) comes back with some idea, hopefully they’ve seen this issue before. I have no idea if it’s the belts being loose, steppers loosing steps, Z being wobbly or uneven, PA messing up, the filament being way to inaccurate (?!) or a combination of things. I suspect it might actually be the Z axis being sticky - I changed my belts and after reassembling everything one corner was a bit higher. I did the Z alignment procedure and it looks better now, but I also noticed some belt debris under the printer now… I might change Z belt and just reset everything but I’m worried I might be compounding problems if I mess anything up.



The first layer looked much better on for some reason, in fact the whole print looks different. No idea about the underextrusion in the corners.

Just curious how many hours do you have on your machine and what brand filament are you using? I have 400 hours on my printer, I did recently clean the carbon rods and adjust belt tension. One of the tensioners did feel kind of stiff.

4500 hours :smiley: I can’t be mad at it, really.
I’m testing this with Bambu Lab Matt PLA - I noticed it with this filament, it is much more pronounced for some reason (also probably because it has higher max flowrate, thus prints faster), but the problem is there with most other materials as well, some just hide it better.

Btw I just added some tension to one of the belts (the one that subjectively felt a bit looser on both sides), recalibrated and the artefacts are gone again but there’s still some underextrusion-like-thing going on. I almost think it’s just random accross calibrations and maybe my extruder is missing steps or something…

OK so update, I downgraded firmware to 1.06.00 and recalibrated but problems were still there. I updated back to the current firmware, re-tensioned the X/Y belts, recalibrated, and ran another test print. It definitely improved and made the second layer lines closer but the problem is definitely still there. Not sure if there is something wrong with one of the tensioners and if it’s tensioning too much or too little or what to do now. I guess maybe I should open a support ticket?

Perform a cold pull on the nozzle, or swap in another. Nozzles wear out. Nozzles get partially (or totally) clogged. The quality of the extrusion is heavily dependent on the condition of the nozzle. If your extrusion sucks and you’ve tried everything else to no avail, try this.

1 Like

I did 3 cold pulls yesterday trying to diagnose this, the first one got very little the second 2 got nothing. The nozzle has maybe 250-300 hours on it with 99% of what it has had run through it being PLA, I’m pretty new to 3D Printing, is that how quickly a nozzle should wear out?

No, it isn’t. But sh!t happens. :slight_smile:

A nozzle swap is pretty easy to do provided you’re extra careful with the connectors so you don’t damage them unplugging or plugging in. So you could rule out the nozzle with a swap and just leave the replacement installed if it doesn’t change anything.

You’ve done just about everything else to no avail. As Sherlock Holmes says “When you have eliminated all which is impossible then whatever remains, however improbable, must be the truth.” It may be hard to believe the nozzle could be at fault, but there’s not a lot left to blame you haven’t already tried…

1 Like

Can you check something? Slice a cube (50x50x50 is what I used) with Rectilinear infill (10%)
Post a photo of what it looks like while printing

This is what mine looks like :scream: :scream:
(Those gaps get smaller in Silent mode, just about half the gap)
GCode looks correct.

Is there a way to do that in the slicer or do I need to make a square in Tinkercad or something? I did notice when attempting to re-tension my belts again that the bearings on the Y rails (the chrome rods) seemed loud and were causing a vibration I could feel in the head when moving it. I greased them following the procedure on the wiki which reduced the sound and vibration and seems to have reduced the weird texture substantially and at this point I feel could be chalked up to a little bit of under-extrusion at this point. I am going to try to grease the other side of the rails a little better and try to mess with the tensioners more because one was really stiff so I am wondering if moving it back and forth a little more won’t make it work as intended. I think it is one or both of those things that have caused the problem. I do wonder if maybe the bearings on the y rails on the side that was making the noise are starting to go bad already or maybe have been bad all along and I just never noticed it until it got a lot worse. I think I used to get the pattern ever so slightly on my top layers but ironing would get rid of it so I just assumed that was part of FDM printing. Here is a comparison of a test print I just did and the original coaster I shared with the really bad texture.

Do NOT grease linear rods. Clean them thoroughly (I use IPA, take care not to get it inside the bearing), then very very thinly coat them with light oil, then gently wipe it off. Those bearings are (should be :)) lubricated from the factory. If you feel like they are dry, then the only solution is to frequently apply small amounts of light oil (possibly push on them a bit to make the bearing inside them roll rather than slide), but that should only be last resort. If in doubt, just wipe them with a clean rag, and beware of any strands or dust od debris getting inside those bearings.

I think there are more factors than one to what’s happening in there. I found that making the belts tighter might improve the problem for a moment, only for it to return later. Sometimes doing nothing and just calibrating is enough. I’m pretty sure that it’s the resonance compensation mechanism trying to cope with play somewhere in the system that is not actually a resonance, and mostly failing.

I found play in my toolhead (between toolhead and the bearings), like described here Extruder has play in Y-Axis and will try fixing it tomorrow. Whether that is a complete fix or not I don’t know, but this is the only play I can see and it makes sense why I didn’t notice it when manually moving the toolhead - if you have tension on the belts, then it masks this problem, but the motor actually tensioning the belts in opposite directions will make the toolhead warp because of the play. At least I hope that’s the right explanation :slight_smile:

To create a test cube, create a new project, right click on the bed in the Prepare tab and then Add Primitive → Cube. Resize to 50x50x50 and print. But it’s enough to just print anything and use Rectilinear infill, it should show on any print.

I’m convinced I’ve had this problem for quite a while and just didn’t notice. Over time I got used to some things getting very slightly worse, and since I mostly use Gyroid infill and filaments that hide errors, this went unnoticed. Maybe something in recent firmwares made this worse…