Is there a way to rollback the P1P firmware update?

I updated the firmware and now all my prints are having issues. Stringing, extrusion gaps, you name it. I even reran a print job that I ran before the update and it is now failing. I just want to rollback the firmware. I’ve learned my lesson about being an early adopter.


I want to downgrade as well! After updating the firmware to every single print fails - already in the first layer (see picture) - before the update everything worked flawlessly. @support: please help!

1 Like

That’s exactly what I have happening. They fail on the first layer.

On the gaps it clearly drops a “blob” of filament and then stops printing for a bit. I’ve reproduced it with multiple filaments. As soon as the video from my phone uploads I’ll post it to imagur.

It does it on every STL I’ve tried to print. It’s very odd. Always consistently in the same place on each print, but I can’t figure out the commonality between each print in the spaces it does it. i.e. after a curve, etc.

1 Like

In your photo in the lower left corner, I can see the blob and then the gap, like I’m talking about.

1 Like

Here is a video showing what it is doing. It doesn’t matter what the STL file is or what filament I’m using. It does this on everyone I’ve tried to start printing. At a random space it drops a blog of filament and then there is a gap. If I let it run longer, it eventually gets really bad and the nozzle will start hitting the print.

I was talking to some people on the Discord. Try turning this off. It seems to have solved the problem for me.

1 Like

correction. It made it better, but not great.

1 Like

Coming from discord too. Per SirWill, physically unplugging the camera along with turning off Step Loss Recovery may address the issue.

Sounds to me like the CPU cannot keep up with the featureset after the firmware update, probably more code was added that increased CPU load, and now with all features enabled the CPU load is too high.


i am having the same issue yesterday with flawless printing. today after the update I’m having the same issue nothing but problems and I’m using all stock settings and bambu filament. only thing that changed was the firmware.
I will let you know if i figure out anything

1 Like

I noticed today that my phone now connects to the camera yesterday it would not so i will try that.
UPDATE: Nothing changed even printing from the SD card no wifi connected and camera unplugged
Fixed after hours of testing i found something that worked for me check it here.

1 Like


I am sorry to hear this. Please open a ticket and share the printer logs so we can check.


How do you get to the log file from the P1P? On your wiki I could only find how to access the X1 log file.

YES!!! THANK YOU!!! It worked!!! :partying_face: Finally!

After installing the soft fever version of Bambu studio, doing the pressure advance calibration and changing my filament settings accordingly, my printer prints normally again! Thank you so much! :kissing_heart:


There is a new Studio version released just now. Guess it will solve your problems

I’m glad i could help but they did just put out an update to fix the issue that i can comfirm works just lacking instruction i made a thread here

1 Like

Thanks indirectly to this thread, I discovered my P1P was suffering from these issues due to this:


That was my pre-loaded/default value in Bambu Slicer. I had no idea what that random string of numbers was under “Ext Spool” until this morning and now I know it should have said something closer to “K 0.020”.

No wonder my prints were failing so badly over the past couple of days!


THANK YOU!. I’ve done this and updated my PA to .018 and it is printing fine now. Now to do this for the rest of my filaments.

1 Like

Remember the P1P does NOT have lidar so you need to manually select the calibration of machine and the nozzle… under devise next to filament load and unload you see a button that says CALI… make sure the bed is clean and run the test this will allow you to set the nozzle for the best, once it prints the test grid, find the one that looks the best and enter the number in the box after the test…this makes a huge difference… also make sure the auto recovery is turned off… so there are always 2 calibration to do…anytime you swap out bed types always do both… i also redo it after 10 prints or if i see anything looking off…these machines are so fast, it don’t take much to make a difference on how your prints come out…

Yes, same here, K-Faktor value was really strange value…

Hi, what will be the correct falue of the K Faktor?