K Factor can't be stored

I calibrated actual my Bambu Lab PLA black. First I tried the auto mode, but I get there only K0.000
So I decided to calibrate manually. The best Line ist K 0.020. But the value isn’t been stored. If I go to “Manage Result” the value there ist stored with 0.000 if I change the value manually to 0.020 and store it after change the nozzle typ to 0,2 and back to 0,4 the value is again 0.000
Is there any problem with the software?

I am not sure if I understand your issue.

The first thing is regarding the failed test.
I am currently recalibrating my filaments. Until now, I have had no issues regarding the k-values for PLA, PETG, ABS and ASA; I had one, yet repetitive, failed auto calibration but for the flow ratio and not a zero value. I have used Cold Plate for PLA and Engineering PLA for the remaining.

I tried your issue, i.e., managing filament, editing, changing the k-value, and then changing the nozzle size again to the first nozzle size, and the k-value was equal to the one I edited.

Notes for comparison:

  • Latest firmware and software versions;
  • OS: Windows - I can test later on the Mac;
  • k-values from the automatic calibration process;

Software of Studio and printer Firmware are the newest. I tried it with Mac so it would be nice if you can test ist also. It doesn’t matter what I do, manual or automatic calibration. No Values can be stored. Everytime I have only k 0,000. maybe I will go back to a previous firmware and install then the newest one again…

Maybe try setting Bambu Studio to English … it might be a silly bug with 0,020 vs 0.020

Tried both. Nothing worked😔

I used BS in french langage, and the two first times i calibrated, i have write 0.025 and nothing has been stored. When i entered 0,025 it has become OK. Depending of langage, maybe BS is vrey strict between “.” and “,”

I tested it in the macOS, and it works as it should. I change the value, press save, and then independent of what I do; the k-value doesn’t change.

As mentioned, my values were initially generated by the automatic calibration procedure; can you retry the automatic calibration and then try to update and save your value.
Another option is the typical uninstall/install cycle with a power cycle of the printer to verify if it is not some stupid bug.
I am sure it doesn’t influence, as we use the save button, but my settings entail auto-backup at each 10s.

I tried it but issue still exists :frowning:

I run the auto calibration with one filament. Result is K 0,000. I saved the value and changed it manually. Problem still exists. I changed the firmware to an older one and changed back to the newest firmware. Restart printer and have still the problem

I have the same issue with the autocalibration of the filament. It just shows “K0.000”. I’m on the newest FW and SW (Windows10, 64Bit)

Bambu Wiki says: “Currently, it is not supported to remember the calibration result (factor K) of filaments inside Studio and the firmware. You may write it down to your notebook or somewhere else and input it the next time you use this filament, without calibrating again.”

Link? I have seen users can store the k value

False with the last versions of BS and firmware : BS 1.7.x and firmware

What you saw may have been Orca-Slicer, a fork of Bambu Studio, which can store Pressure Advance settings (aka K-factor) for each filament profile.

Mine are stored, I have to manually select them if I shut off the printer though.

@ FabriceW: “Link? I have seen users can store the k value”

Extrusion Calibration in Bambu Studio | Bambu Lab Wiki
Scroll down to " Input calibration result if you already know it"

This is wiki from p1p and not the X1😅 you can store the values on Bambu studio for the X1

It worked on the second attempt: Now it was stored and I can manually select the saved presets for the K-value (X1C).

Its under the x1 carbon section.

I don’t know if this answers some of your queries or solves your problem, but I can create a new filament entry and enter a K value without actually doing the calibration.

What I do is start a Manual Calibration but immediately cancel it. On hitting ‘Next’, it will prompt me for a new filament name and K value.