Layer high with 0.4mm Nozzle - max. 0.28mm need 0.3mm

Anybody who can explain, why I can´t set the layerhight to 0.3mm? It is automatically corrected down to a max of 0.28mm:
For my specific print I would need exactly 0.3mm because of the structure to print.
flow is set high, speed is set low, doesn´t help.

Edit the nozzle settings, extruder tab, you can increase the max layer height there.

That´s that! Thank you.
Cazy many things that can be changed in settings, presets,…

There are all the things I´ve been looking for since I came from CURA

Glad I could help. Enjoy your printer.

If you want even more settings, have a look at the Orca Slicer fork of Bambu Studio. It looks and feels and works the same, but has more settings and offers easy calibration.

1 Like

The main reason it’s not available is that is not a thickness you want to use.

Yes, you can change it as suggested by @Thrawn :wink:, but .3 is not a good value to use. The numbers are “odd” (different) because of physics.

The motors and the threads used on the three Z rods require layer heights of .28 or .32, not .30

Yes, you can use the setting but it will not give you the best print as you will be forcing the machine to print too thin or too thick layers by changing the extrusion rate, rather than printing layers that are exact multiples of the steps created by the physical system of the Z axis.

I have a CR-10S that’s heavily modified and one mod was to use different (1:1 Ratio) threaded rods for the Z axis. I can print perfectly any layer thickness I like rather than the odd multiples most machines (including the BL ones) use.

1 Like

‘Magic numbers’ become moot when your z is compensating for its bed mesh

Yep, and stepper motors can also do half steps, though they are less precise as the state is not exactly defined as the full steps.

True … maybe… It depends on how BL implemented the corrections. There’s several methods and they haven’t shared. The most common distributes the error over the first 10 or so layers.

Regardless of that you will still get the best layers by using the natural steps of the system, even if they’re distributing through the whole model.

Thank you, didn´t thinmk of that.
However, the masterpiece I downloaded from printables:
by Kagarov
is modeled in 0.3mm Layers.
With your useful Information I simply will scale in 1D (z-axis) to fit the 0.04-steps = 0.32mm
AND: disable automatic bedleveling to avoid the correction Bambu does “behind the scenes”

1 Like

You should only disable automatic bed leveling, if you have a really flat and level bed ( 2 different things). Otherwise your first layer can go havok, from the nozzle scatching the bed to no adhesion, bc the nozzle is too far.

1 Like

Wow, that’s some good “thinking outside the box”! I wouldn’t have thought of that, good one! (Takes notes to add this to my arsenal … :wink:) We all learn from each other here.

Let us know how it goes! EDIT: and such a cool print should be shown off -

EDIT 2 - I went and looked at this model. I’m going to change my suggestions here. You might indeed print this at .3 layer. IDT this model will show the layer differences that require you respect the “magic numbers”. The Author says this about the matter:

Since the size of the parts must match the height and width of the layer, changing the scale when printing can lead to an unpredictable result (but you can increase the Z height by a multiple of the layer height, in increments of 0.3 mm per layer, for example, select 0.6). I advise you to print 0.3 layer height and 0.4 layer width, with 100% airflow. The height of the first layer must be adjusted like all the others, otherwise the distribution of layers may get lost.
My print speed was 60 mm/s.

So don’t do that clever thing of scaling.

I’d go with his settings. When I checked what printer he used it didn’t say, but his profile shows Prusa and Creality printers and they have the same default stepper types and threaded rods BL used in the X1C and P1P.

One other thing - If you’d like an interesting read on this “magic number” stuff here’s an article I had bookmarked that explains it fairly well:


A big double thumbs up to this. Also, if you haven’t done the MANUAL bed tramming (‘level’) yet, do it. Technically it’s tramming, being level has nothing to do with it. A well tuned 3D printer can be mounted on the wall and work perfectly. :grin:

1 Like

Only if you have REAALY good bed adhesion :upside_down_face:

I will try your suggestions (Tramming, Scaling or not, …) and report my experiences.
Will take some days because the printers are busy doing “official work” :wink:

I had a thought (rare, but I do get 'em) in the middle of the night :upside_down_face:

You should print the first 20 layers or so each way, as test prints and examine them. This look to be a “big but doesn’t use much filament” print.

Get back to work! :innocent:

That´s what I do :slight_smile:
It´s a print that you can stop anytime, because it is kind a “infinite”

1 Like

Hello, where do i deactivate automativ bed leveling in Bambulab slicer?

The bed tramming G-code for X1C turns ABL off with: “G29.2 S0”.

G29.2 S1” should turn it on. We don’t know whether Bambu printers will also turn ABL on again when, for example, homing (with Marlin it depends on build options). Somehow Bambu does not give us any G.code documentation, while at the same time they force us to resort to G-code if we want to control the chamber fan. There’s a paradox there if you ask me :roll_eyes:

EDIT: No wait, did you mean the auto levelling before a print? There’s a checkbox for it in the print dialog.