Layer shifting after color change

Hi all

After printing some print one color, everyting worked fine. Untill is started printer more colors.
After a color change i got a layer shift. print after print…

After some tests with different colors, it’s still happening.

-I readjust the belts (
-I tried different slots
-Sliced different models and different color layers
-Adjust speeds

  • reinstalled Bambu studio
  • reset the printer to factory settings

i have watched what happens when he changed filmant, i don’t see someting unusual.

I have a little update

In bambu studio i found a button “Auto-recovery from step loss” i selected it en restart a print;
After a color change the print goes re-homing. So i’m sure now their is a step loss somewhere.

Bit now i hav te find why he does it.

Maybe the filament cutter is the problem!?

1 Like

It’s plausible… he was stuck once. But the problem was their from the beginning.

But i’m not able to when he shifts.

I’m having the same issue on my P1P

1 Like

What causes Layer Shift :wink:

  • Wrapping the of the part and the nozzles touch the wrapped side
  • wrong motor currents
  • mechanical issues

That are most of the time the problems from layer shifts .

Thanks for sharing this. I already made a ticket
They talked about clogging…

But in the last update of bambu studio the added an option step loss recovery. And when i activate this option you can see after a change the printhead goes re-homing the x and y and print further without a shift So i’m sure their is a step loss…

1 Like

Warping is not the cause

But in the last update of bambu studio the added an option step loss recovery. And when i activate this option you can see after a change the printhead goes re-homing the x and y and print further without a shift So i’m sure their is a step loss…

So assuming the other options like mechanical or power problem are more likely

1 Like

Having similar issues, enabling step recovery actually makes the error worse for me.


Offset is consistent, off by the same amount with each attempt. Here’s the increased error showing up when step recovery is enabled.

Hi, did you find the mistake?

1 Like

Something obstructed the head when homing to the front right corner which makes the home position off. That doesn’t stop it printing, but, on the first color change the head hits the left hand stops when cutting the filament and the stepper skip steps. It then carries on printing - just in a different place.

Was there a fix for this? I just figured out 1 issue and this is another one that is making multi color prints impossible.

The last post told you what the problem is. Up to you to fix it.

Did you have this problem and were you able to fix it?

From searching both of the people in this thread that had the issues haven’t reported the problem fixed and I don’t think even posted after this thread.

So are you assuming what the problem is without firsthand experience. Because I also looked at your post history and you only mention it in this thread.

But after removing the AMS and the top glass I can’t see anything hit the front right corner (front left if you are looking at the printer) causing it to skip a step.

So the answer to my question if there was a fix was NO!

And if it was as simple as you make it out to be Bambu wouldn’t be taking over a week to respond to my support ticket since there has been a few sent by others before I got this printer.


Bambu said that i have to resend te p1p.
My problem is fixed with the recover from step loss.

But last days my print are better and have to test again without the step loss.

I will come back with more info

1 Like

Thanks for the update kevyn_3D.
I tried the recover from step loss when I first found this thread and have the same results as Worldspawn00.
I’m still waiting for my support ticket to get a response.

Thanks again

Thanks for that link, unfortunately it doesn’t apply to me. I wish it was as simple as seeing a wire clip bang on the rear of the case for me.

Yeah, sorry I didn’t update here, check the PTFE tube and clips for catching on the rear of the case, and for anything that restricts the head from moving all the way to the front corner. Easiest way is to turn the power off and manually push the head into the front corner, feel for any binding or restriction that happens right around where it should stop. The motors run at reduced torque during the homing process, so it doesn’t take much to throw them off from the actual end of travel.

The head should move freely to the end of it’s travel, these machines don’t use endstops or other confirmation of end of travel, they just run the tool head until it hits the end of travel and monitors the stepper motor backfeed for when that happens. IMHO, not a great way to do it, since it can end up wrong for the X-Y axis, having an optical or mechanical stop would at least allow them to CONFIRM that it actually reached the end of travel and wasn’t interrupted while still using the same system they do now for calibration.

Alternately, since they know the number of steps along each axis, calibrating against the back left, then the front right could be used to confirm that it’s actually reaching the end of travel in both axes, though I suppose that would add another 10 seconds to the process…

1 Like

Thanks. I do have a X1 Carbon so the PTFE tube and clips are in factory spots. I have verified nothing restricts the movement. So I’m still at a lost.
I’m setting up a camera and printing a small cube with color changes on it to see if I find anything weird. but by watching it I haven’t seen anything yet.

Thanks again and glad you got it working.