Layershift with Manual Pause and filament change

Used the pause button on the front of the printer to manually pause a print job.

Used the unload option using the controls on the printer.

Loaded new filament by manually setting nozzle temp and manual extrusion. Did not use the load option.

Upon resume layer shift occurred on the x-axis by about -.5 to -1mm.

1 Like

Seems to be a bug in firmware or the slicer currently.

Have a look here for a workaround.

Thanks - wasn’t sure if issue with manual pause was also noted. I forgot to add a pause in the slicer, so I just did it manually at the console. I’ve added the custom g-code above, this time, and am trying again.

I saw the same shift when I ran out of filament, loaded a new spool and resumed.

1 Like

I have the same problem. Whenever the filament runs out during a print, there is a layer shift of a few mm.

I already do it so that I use the remains of the previous spools for unimportant prints. Then it happens that I use 3-4 spools in one print, because I do not care about the layer shift.

But it’s a mega annoying mistake that has already ruined many prints for me.

Currently there are only two solutions.

  1. Buy an AMS. The firmware bug is not present when using AMS it seems.
  2. Add a manual pause via above and switch the spool before it runs out. Might not work always if you misjudge.

I am sure there will be a fix in the next firmware update thou

If I know that I am about to run out, I watch the print and when the old spool runs out I hang a new one and just start pushing the new filament in and keep pressure on it until it is feeding. That way the printer doesn’t actually see the filament run out. Of course I have to be on the last spool layer or get lucky to do it this way.

Any Update? i am experiencing the same problem i get layer shifts when ever it is multi color jobs.

Just adding my voice - also seeing this issue but not seeing a way to resolve it. I’ve tried adjusting belt tension, printing from different slicers, and adjusting print settings. Nothing else prints poorly - quite the opposite… But aside from these busy threads, not many people are talking about it… Have raised a ticket with Bambu support.