Layer shifting after color change

Thanks for the update kevyn_3D.
I tried the recover from step loss when I first found this thread and have the same results as Worldspawn00.
I’m still waiting for my support ticket to get a response.

Thanks again

Thanks for that link, unfortunately it doesn’t apply to me. I wish it was as simple as seeing a wire clip bang on the rear of the case for me.

Yeah, sorry I didn’t update here, check the PTFE tube and clips for catching on the rear of the case, and for anything that restricts the head from moving all the way to the front corner. Easiest way is to turn the power off and manually push the head into the front corner, feel for any binding or restriction that happens right around where it should stop. The motors run at reduced torque during the homing process, so it doesn’t take much to throw them off from the actual end of travel.

The head should move freely to the end of it’s travel, these machines don’t use endstops or other confirmation of end of travel, they just run the tool head until it hits the end of travel and monitors the stepper motor backfeed for when that happens. IMHO, not a great way to do it, since it can end up wrong for the X-Y axis, having an optical or mechanical stop would at least allow them to CONFIRM that it actually reached the end of travel and wasn’t interrupted while still using the same system they do now for calibration.

Alternately, since they know the number of steps along each axis, calibrating against the back left, then the front right could be used to confirm that it’s actually reaching the end of travel in both axes, though I suppose that would add another 10 seconds to the process…

1 Like

Thanks. I do have a X1 Carbon so the PTFE tube and clips are in factory spots. I have verified nothing restricts the movement. So I’m still at a lost.
I’m setting up a camera and printing a small cube with color changes on it to see if I find anything weird. but by watching it I haven’t seen anything yet.

Thanks again and glad you got it working.

Layer shift after pausing here too, I think it might be skipping steps when cutting filament as has been suggested.
Workaround that worked for me;
Instead of using adding a pause in Bambu Studio, add this custom g-code;
M400 U1 ;pause
G28 X ;home XY

That way, the printer does a XY home after changing the filament, and continues in the right spot.
(Shouldn’t this just be the default behaviour after a pause anyway?)

1 Like

Thanks for the GCode, i did try it in different print but its still doing a random layer shift in one of the pause (i print more than 2 colors these days). I tried different technique while changing filament (via machine or studio or waiting longer or even not changing the color at the pause) but yeah, Bambu need to fix their software i guess.
Obviously, they might not care too much here with manual color change during a pause since they sell the AMS which doesnt have layer shift :stuck_out_tongue:

Turns out my loading problem was manuel AND software :slight_smile:
First, I need to hold the filament IN (pushing a little) until the machine reach 250 degrees or it won’t “grab” on it.
THEN, i need to have my APP (iOS) open on the filament tab while doing the LOAD and tap the DONE button when its loaded or it wont Resume the print (after clicking resume on the printer)… at least thats what i need to do on my side. So, yeah, a bit of time waste when printing a lot of models with 3-4 color layers like im doing right now :stuck_out_tongue:
I still do have the money for the AMS yet…

I am the proud owner of an AMS and use it in the Backup Mode (Spool failover) not for color change and guess what happend every time it changed the spool? Yes , Layer shift. I will now check the points discussed here. I had the new option “step loss recovery” not activated. I will now check the points discussed here. Very useful for a beginner like me :slight_smile:

Thanks for the info! If you can test that, it would be great!
I borrowed an AMS yesterday so I’ll test it with Color Change this weekend too :slight_smile:

6 Failovers are spot on (no layer stifts) after new option “step loss recovery” enabled. When it happend there might have been a mechanical problem as the possible source, blocking spools in the AMS. The transportsystem of the AMS must have a good grip on the rim of the spools (the rim must be FLAT and no sharp brims from the moulding of the spool, sharp edges will ruin the rubber rollers over time) and MUST NOT wobble. The spools I used when it happend woble so much that they occasionally block the AMS. When the filament is pulled tight, over time the outer sides of the spool started bending out and occasionally blocked in the AMS. Bambu mentiones to use their spools, but i did not realise its implication. Good solid Spools and the AMS is really your friend and willing helper :slight_smile: .


I’ll test the Recovery Option and make sure to check the spools for the AMS. Im kinda surprise about the “rolling system” for the AMS since it cost quite a lot imo and a lot of people are saying that its not the best and can easily block.

I’m having this problem. Turning on step recovery didn’t help. I know this is an old thread, but was a solution found?

For me it was solved with the firmware version 1.03.x. The layer shift because of the firmware error was around 1 mm. I could estimate the size of yours, but seems to be more than 1 mm. So I think it’s another problem.

Mine was solved suddenly

Hy everyone. Does the problem have been solved ? I have the same problem but an calibration does not work.

i am having the same issue no matter what i do. it has ruined so many prints.

Im having the same Issue, the Layershift only happens on the first color change, consquent ones don’t cause a shift.

I see the issue is coming back.
Don’t had it anymore when enabling “recovery from step loss” in the options

My problem is solved. Support contacted me. Please check the 4 screws on the back that are used to tension the belt.
I had 2 screws loose on the right side !!!.

Follow the steps in this guide and the problem should be solved!!

The 4 screws do NOT be loose !!!