Light Turns on when you send print doesn't turn off

This issue just recently popped up, I believe it was after the last Firmware Upgrade. I have kept my firmware up to date, I had firmware, and upgraded to (i believe the was the number it is the current newest)

as soon as the update was finished the light started doing this.

from both the handy app, or the PC, if I send a print to the printer, the light automatically turns on.

then the print works fine. everything goes as expected. it finishes, eventually the fan stops, and the screen goes to sleep.

but the light never turns off. it just says on…

SO… I downgraded my firmware back to the previous version.

the light is still doing the same thing. it turns on automatically when you send a print job, and won’t shut off.

does anyone have any suggestions?

for reference, I’m new to Bambu, but FAR from new to 3d printing. i’ve been printing for many years.

I don’t see any topics on this and yes I did search, I even searched the internet, and there are people that seem to have had this issue, but never any resolution that I can find.

1 Like

ok, reading up on other non light issues, I went ahead and did a factory reset.

so, I now have version with a fresh factory reset.

I decided to test it by printing the benchy off the SD card, like I did day one.

still the same issue, the minute you tell it to print, the light in the machine comes on.

so, I canceled the print, and I’m jumping back to firmware version

really hoping this might finally fix the issue.

nope, went all the way back in firmware, doesn’t matter, as soon as I go to the benchy on the SD card and hit print, it turns the light inside the machine on.

i’m going to contact Tech Support, maybe a wire is crossed or pinched inside of the machine, odd, It has not moved one inch since I bought it new a little over a month ago. it’s always worked fine.

you have to turn the light on manually either via the control board, or the handy app. Until the last update, then it started turning the light on as soon as you hit print or send in the handy app or in the bambu slicer… IDK… very strange.

it wouldn’t be bad if it turned it on and then at the end of the print turned it off. but it just leaves the light on. I just find it very wasteful that the light is staying on after the rest of teh system has gone into sleep mode.


well, I submitted a ticket to Bambu Support.

it’s odd. Like I said, I can find a couple other posts on other internet sources, but never a solution or a reason.

when I hit send on the bambu handy app, or the bambu slicer, before it’s even done downloading it will automatically turn the Printer LED on.

if I print the 3d benchy from the SD card, when I hit print, it will automatically turn on the LED strip.

then it prints , finishes, fan stops, screen goes into sleep mode all like it should, but the LED strip never shuts off.

at any of these points you can MANUALLY shut it off. either via the screen of the bambu handy, or the bambu slicer. and the bambu handy and slicer do show that it is on.


i’ll report back with what Bambu support says. maybe this post will help someone else that has this problem. I’m confident that Bambu will come up with a fix for the issue.

I will do a quick print and verify this. the benchy seems like the fastest… LOL

I do not recall mine ever automatically turning on when it started printing.

but, i’m trying a print now. it automatically turned on. we will see if it turns off. I know on my last print, the light was still on, and I had not turned it on manually, the screen was alseep, but the light was still on.

also, for reference, I do have a P1S. not a carbon.

I have noticed the exact same thing. I have had to turn off the light manually every time since this firmware upgrade. I didn’t notice it at first since I print fairly infrequently, and as a result the light was on for a couple of days the first time.

I have a P1S since Christmas and so far, the light never shuts off automatically.
It turns on no matter if Timelaps is activated or not and stays that way.

I assume it is more an issue with the Bambu Studio Slicer, putting the code in the files that switches the light on :man_shrugging:

I can confirm the same behavior once I upgrade to 1.04.

SO bambu support has replied, I am not complaining, but I think there may be a language barrier going on?

here was one reply

Thank you for contacting Bambu Lab support. I am sorry to see that you are experiencing problems with your printer, but rest assured we will provide support to solve them as soon as possible. In this case, the problem seems to be related to the LED light.

This behavior is normal as it generally turns on automactically when the pritn starts, The only time it may turn off by itself is if the printer has been idle and goes into sleep mode, However even then it still may remain on.

For this you are welcome to adjust the G-code for the start and end of the printing profile to turn on or off the light.

For mre infromation on this you may visit: Gcode control to disable LED lighting

Please let me know fi you ahve any questions.

Best Regards
Bambu Labs Support

as you can see no where in that post does it mention or point to a “gcode” that can be put in to turn the light off at the end of the print, or even what gcode would be making it turn on at the beginning of the print.

NOW there is this link that explains some of the Gcode. , but it is for a X1 carbon not a P1S

i’ve tweeked gcode in my startup and shutdowns on my 3d printers before, I do not see any mention of the LED light, but I also do see that my P1S has the

M960 S5 P1 Bambu Lab toolhead logo light on

gcode, I do not have a “toolhead logo light” that I am aware of on the P1S.

so maybe I need to try to put in the

M960 S5 P0 Bambu Lab toolhead logo light off gcode in the end gcode, and see if this resolves the issue?

i have a print going now, but i’ll try when it’s done.

here is a snip of the start G-code

I haven’t touched anything in the start, it is exactly as it has always been

and below it is the End code.

I added M960 S5 P0 Bambu Lab toolhead logo light off

as you can see, even on the P1S which does not have a tool light, it does have the “M960 S5 P1” code to turn on the tool light.

so, I figure, it’s worth a try to see if adding this to the end code will turn the light off.

I don’t expect it to work. as the light comes on when you SEND the file to the printer, or hit print.

before the printer is even done downloading the light turns on. so I don’t expect this test to work.

however, it does mean that the printer is fully capable of turning the light on and off without manually doing it. the real question is “what” is making the light turn on by itself.

again, this happens in bambu handy, Bambu Slicer or from the SD card itself.

so I have to expect it is something in the firmware, because of WHEN the light it turning on.

BUT… i’ll test this theory at least, as the Bambu Support said it was “gcode” related.

ok, ran a 9 min print.

the light comes on before it’s even done downloading the print. the print goes fine, the light never shuts off, even after the fans are all off and the printer is back to sleep mode.

To me that tells me that the control of the light isn’t in the Gcode. how can the Gcode affect the light if it isn’t even done downloading yet?

i’m going to remove the Gcode I added, does make me wonder why “turn on the tool light” gcode is even in the start up script on a P1S?

I’ll see what Tech Support has to say.

so far it’s a question that has been asked, and issue that has been noticed my multiple people on the internet, but no answer or fix has ever been posted.

general thing to think about though. it is clear that SOMETHING turns the light on as soon as you “send” the print from the Handy App, or Bambu Slicer. so you would think there would be a way for Bambu to turn the light back off when it’s done printing. OR… just stop the light from comming on automatically like my printer did for weeks. prior to this my light did not come on automatically, so something changed…

Hello, did anybody manage to fix the problem? P1S, firmware up to date. The light turns on when I start to print, but it never turns off. It will stay on for days (when I was on vacation and came back after a week, i was surprised the light didnt turn off). Is there a way to fix this? Normally i would not notice this, since i print all day all night, but when the printer was in sleep mode for couple of days, how did it not turn off the light as well? BTW, what is that “sleep mode” option in the settings for? I thought thats for the light

It’s for the screen

25 limit

Ok so there is a timer for that little screen but not for that bright light? Hope thy fix that soon with the next update

No, tech support never resolved the issue. I don’t mean to talk bad but they genuinely seemed to not understand much about the printer to be honest.

they told me repeatedly that it was a “start code” in the gcode. but it is not.

one of the reasons I can confirm this is because if you print from either the bambu handy, or the bambu studio app, the light turns on even inside LED turns on even before the print is done downloading.

this was NEVER the case prior to the update. I had to Manually turn on the light if I wanted it on, and turn it off when I didn’t. Now it turns on by itself, and never turns off.

I genuinely believe that something in the programming on the two APPS themselves was changed. I’m starting to suspect it was not firmware on the printer, but the coding in the Apps that is turning the light on.

It’s NOT gcode. again, the print is not even downloaded when the light comes on. Gcode does not run until it is completley downloaded to the printer.

long story short. No tech support never resolved the issue.