Need Help with Bambulab P1P top Layer printing Issues (Pillow.)

Hello Community,

I’ve been using my Bambulab P1P 3D printer with the standard 0.4mm nozzle for quite some time now. Lately, I’ve been encountering an issue during printing where cushion-like formations appear on the top layer, as you can see in the attached picture. (pillow)

I’ve set my flow rate ratio to 0.9, which I adjusted through calibration. Additionally, I’ve configured the K value to 0.020. I’ve also installed the anti-vibration feets and an AMS.

Filament: Bambulab PLA Matte
Slicer: Bambu Studio

Strangely, I’ve been getting good prints with these settings until now. I’m perplexed as to what might have caused this sudden change. Could the introduction of the anti-vibration feet or the AMS be related to this issue?

If anyone has experienced something similar or has suggestions on how to troubleshoot and resolve this problem, I would greatly appreciate your insights.

Thank you for your time and assistance!

Best regards,


Are you using grid infill just under that top surface? I ask because this is exactly what my printer has started to do when printing just one or two top layers over grid. And solid layers look no better - after a couple of months of flawless performance, all of a sudden I get this horrible top surface. Which I think is down to underextrusion. My bottom surface is also looking a tiny bit underextruded too :frowning: I have cleaned everything to within an inch of its life, swapped filaments, used gcode that has worked flawlessly in the past - but the problem is still there. I’m currently running a print at 50% speed to see if that is less bad.

It all started to go wrong when I updated to the 0.6 firmware; it just fails to get any better when I roll that back to earlier FW :frowning:

Are you using grid infill just under that top surface?

Yes, im using the default infill settings.


I also tried to install the older firmware (1.03.) to possibly solve the problem - unfortunately without success.

I could not solve the problem, but it improved when I changed the floren ratio of the filing (Bambulab PLA).
from 0.9(Value of the bambulab calibration) to 1.01. with these settings:


I also tried to reset everything (printer, cutter), unfortunately I could not solve the problem.

Maybe the nozzle is worn out!?

I will try the days to order a new nozzle and install, maybe that also solves the problem.

For me, the problems only occur when the surface is relatively large and is driven in the same direction for a very long time.

I have tried the same test with smaller plates. there I had no problems.

Were you able to solve your problem? Did you try what I wrote? I hope it works for you as well, at least as an improvement. :wink:

Just wondering after adding both did you happen to do the vibration calibration?

Also I got to thinking, I will try my k value again let’s say if it is 5 I will set the first.

Then I may adjust it to say 4 or 6 if there are issues. Just Incase 5 wasn’t quite it. It might truly be like 5.5 or even 4.5

So I kind change the number around that first value until it works.