New Filament Type "Generic PCTG"

Is there a possibility to extend the list of material types for the AMS? I’ve several spools of PLA, PETG and PCTG, and right now I’m abusing the “Generic PC” when I load PCTG into the AMS.


Same issue for me. I can’t get the AMS to accept PP as a filament type. I can’t get the job to print with 3 colors of PP in the AMS. Allowing user editted filament names, or allowing the AMS to synch with the slicer filaments list would solve the problem.

You can change the filament type in the Prepare section after synching with the AMS, where more choices are available including user presets.

1 Like

To add to holmes4 comment: Currently, there are no additional ‘filament types’ available for the AMS other than those defined by BambuLab. I think what he mend was that in the slicer you can choose other presets(incl. user presets) and you can print with them using the AMS as long as the ‘filament type’ of the preset and the AMS is matching. And yes, this currently may also mean that you have to use a ‘fake’ filament type in the preset as well as in the AMS. Not ideal, I hope they will add the option for user input in a later stage.

Addendum: In Bambu-Prepare I’ve named my filament as “Fiberlogy PCTG PC” (user preset), and for the actual spool loaded in the AMS I’ve selected “Generic PC”. This hack works well, because both names ends with “PC”, the temperature range is roughly compatible, and I don’t yet use any real PC-filament.

Part of my experience - the loaded filament type in the AMS and the type in the preset have to match. E.g. I could say it has loaded Bambu PLA Matte (even it is not Bambu PLA Matte). If you look into the stock-preset of Bambu PLA Matte, you can see that there is the type ‘PLA’ defined. I can then change everything (incl. even different temp settings outside the standard settings) and save it as a new name.

When I slice afterwards and send it to the printer - it only looks if he selected slot filament type is the same as the filament type used for slicing. If it matches → start printing. It doesn’t take care of the settings of the ‘brand’ defined in the AMS.

I learned it that way, cause organized I tried to be I created a preset as ‘PLA+’ → AMS didn’t accept this type of material. Therefore, on the not user-friendly version I save specific filaments as e.g. ‘PLA+ as PLA’ in the name. If someone deals with several units and/or filaments I don’t think this is a long-term solution - but it is the ‘best’ we have currently.

1 Like