New firmware 01.03. the printer stops printing after a few hours


After upgrading to fw, the printer stops printing after a few minutes to hours.

The nozzle stops in place and heats up. The menu works, pause and resume also work. (the head moves to the edge and then returns to the print position).

But it stands in place. Does nothing.

I’ve tried downgrade and upgrade several times and the problem only appears with the new firmware. I have already contacted support, no response yet.

Does anyone have a similar experience or have any ideas?

1 Like

Hi, I ‘upgraded’ yesterday morning and the printer starting behaving strangely. Firstly buttons on the control panel either didn’t get a response or strange responses such as going off to see unexpected part of the menu! Took many attempts to connect to the Bambu handy app. and get on the wi-fi. I couldn’t get the filament to feed for ages and thought the mechanism had broken. Eventually filament did feed through but once I did get it to print, settings seem to be wrong with terrible stringing. Reset to factory setting several times, but no way I could find to roll back to previous version (which had been working very well since I bought the printer a month ago). No response from customer support since reporting yesterday morning. No particularly impressed with the company at the moment for making my printer unusable!

Did you turn off the printer and then back on after the upgrade?
Did you run the calibration for the firmware from the machine control panel?
Has this happened more than once?

One thing you can try, which I did once in a similar situation, is to turn of the machine. Then turn it back on and resume the print. Resume after power failure has worked when I tested it.

1 Like

Yes, many times.

I tested it all weekend. Upgrade, restart, print, downgrade, etc.

I want information on what the problem is. Encrypted logs make it impossible for me. Each question or response always takes 3 days at BambuLab.

What are you ashamed of, Bambu Lab? Why do you encrypt log files?

BambuLab Answer:

Bambu Lab
2023-06-14 09:41:05
Hello Rostislav,

R&D has been checking the log and has found the issue.
This will be solved in the next release of the firmware, but at this moment I do not have a date for this.
In the meantime I hope it is okay for you to use the old firmware that did not have the issue.

Sorry for the inconvenience, but thank you for pointint out the issue!
You helped us making the firmware even better :slight_smile:

Best regards,


But how do we revert to the previous firmware? On my Bambu Handy there is no previous version listed.

Yes, reset to factory which performs a calibration. I haven’t tried the resume print but with faulty software that probably won’t fix it.


The problem reported here is related to a very specific scenario where the printer is not used with the regular Bambu Studio setup and network connection on the X1.

We do not expect other customers to have issues like this one if the printer is used as expected, with Bambu Studio and the regular Cloud connection.

If there are suspicions that the new firmware generates problems, a new ticket can be opened with the log attached or the firmware can be reverted to a previous version.



I had the same thing happen the other day, then I put the same print on an sd card thinking maybe it was a cloud error and had stopped downloading at that point, 2 hours into that print it did the same thing, stopped dead and melted a hole. Pressed pause and it went back to its corner as usual, pressed play and back to the same spot. Everything looked fine, no error, no nothing. That was 2 of the 3 ruined prints since this update. They’re fucking around and I’m saving all of the PLA this printer wastes because if their messed up system and shipping it right to them. China Post.

At last, the Handy app. let me downgrade. I can now get printing again! First indication of the software downgrade is that the control panel now works. BTW, still no response from customer support. I’ll be wary of 'upgrading 'again!

We do not expect other customers to have issues like this one if the printer is used as expected, with Bambu Studio and the regular Cloud connection.

Does this mean that when I am using the X1 in LAN-Only mode I use the printer in an unexpected way? :astonished:

A spontaneous restart of the printer due to something trying to query it on the network is simply a bug. (Home Assistant in my case). But thanks to Bambulab support for the correct diagnosis. If the printer had normal log files, I wouldn’t have to contact support at all.

1 Like

The head of Bambu, in a recent Q&A session, stated that the reason the logs are encrypted is to protect their proprietary IP. There is apparently enough detail there to allow competitors to reverse engineer some of the “secret sauce” that allows the Bambu to work as well as it does.

Hi, I have been having similar issues with wifi – the printer just disconnects every single time when I am printing something. Did you encounter this same issue with wifi? The printer is visible in router, but cant ping to it, neither connect to handy/studio, as it is showing “offline”. Thx for answer

No, my WiFi connection works as expected. I had have no problem with connection, but with interrupted print process.

Ok, seems weird. I have excellent print quality, But bad Wi-Fi

Again, stopped dead in its tracks 4 hours in.
Im so sick of this garbage printer and these updates that keep turning this waste of money into a bigger waste of money. That’s like 5 out of the last 7 prints that have failed with no error, just the hotend stopping. Press pause it goes back to it’s corner, play and it goes back to the same spot and stays there.


Hey same here man this morning discovered an incomplete print. Press paused and the screen was really glitchy and slow. Went to turn it on and off via power switch. It seems to be working fine but printed with a different file. Did you ever solve this problem by any chance? What did you do to fix the issue. I’m running a p1s with polymaker pla+

No, it was by wrong access code in my Home Assistant integration a restarting by firmware due to many wrong connection from that.