Newest Bambu Studio => Setting new brand filament will delete itself

Installed newest version from git.

Created new filament brand as per instruction. Now I’ve tried to set new brand for AMS in a Bambu Studio, it worked once for one brand, but now I cannot recreate same action. Before it was set and I was able to see brand on AMS. Now it will just delete itself and set to unknown… Is this working for anyone else ?

bambu_lab

It would be fine if we could overwrite existing brands, as changing anything break the AMS functionality instantly (you cannot save what is loaded, and setting every time 8x filaments is too annoying to hassle with Bambu)

3 Likes

Same problem here. I tried it the first day after the update, added one custom filament to try it out, and whenever I sync the AMS on Bambu Studio, the customized filament disappears :frowning:

I have the exact same problem. After setting a new custom filament profile for an AMS channel in BambuStudio, it erases itself after a few seconds.

Using Bambu Studio 1.8.2.56 on MacOS 14.1. Device is an X1 Carbon with firmware 01.07.00.00 and AMS firmware 00.00.06.40.

Same exact problem here

I’m having the same issue. Anyone stumble along a solution?

A few issues also reported on GitHub, there is a solution if you force selection through the Printer LCD vs just through the Device Tab in Studio

Last one is the best one \ lots of info

Unfortunately it doesn’t solve anything for me.

I am using cloud but yet the printer doesn’t show any filaments.

Tried resetting everything, but without any luck. Custom filament is not present on a printer and will disappear when trying to set it via Bambu Studio.

Ok.

This worked for me following last comment on Github. I have created new brand and then checked on printer to see if filament is there. It was and now it works!

Here is instruction:

DanBao-Bambu commented 2 days ago

Please try entering the material tab of the printer screen after creating the Filament and entering a slot to set material information. After returning to the Device interface of Studio, setting Filament should not cause the above problem. If there are any issues, please continue to contact me and I will continue to track the issue until it is resolved.

1 Like

It’s almost March 2024 and I’m having the exact problem shown in the screen recording here. I would love to see this fixed! Very frustrating!

I notice this is marked as “solved”. That is not true. This is definitely a bug that is still open. The behavior I’m seeing is exactly the same as the screen recording at the beginning of this thread, which is definitely a bug. There’s a workaround, but that’s not a solution, it’s just a way of kicking the can down the road on actually fixing the bug… I hope that if anyone else is seeing this problem they will comment here, and conversely, if anyone can definitively confirm that this NEVER happens for you, that would be super helpful if you could try to help us figure out what’s different about your setup! @carmamir