Nozzle Temp Stays high After Load

When loading filament from the AMS to the hotend through the screen using the “Load” button, the process will complete and leave the nozzle temp at 220+ depending on the filament.


I find it as a feature finally get the Prusa behavior. When loading a filament from the screen , you want to keep the heat on( or it can be reduced with the 20C) usually external spool, ether for timeout period of inactivity ( safety timer) , or be left warm to use it as usually you need it straight away.
Have not tried the new FW, but great on Bambu

Except that really high temp doesn’t actually help you start a print quickly. It’s just oozing filament.

But if its sitting there oozing filament wouldn’t click in your mind maybe my temperature settings for this filament might be wrong? It’s not supposed to do that even moving

After a PLA load it sits at 220 which is the printing temp for the filament. That will just lead to oozing while it hangs out.

Andrew , there are 4 Procedures which extrude before the actual print starts, which remove any oozing, unless you removed them from the start-up gcode. If there is oozing on the print it is something else !
And yes there might be something on the back or bottom left over so vacuuming/cleaning from time to time is a good idea , that is happening even in the normal startup procedures

oozing it self with retracted filament usually does not happen a tiny oozing is acceptable in this specific situation if not retracted as the head sit on top of the poop shoot usually

The Prints start a little faster, as the nozzle is heated, but that is not the main point. When manually loading the filament from the screen - usually there are only two reasons to do that on the X1C

  • Using external spool
  • Trouble shooting filament or nozzle or AMS on a filament already loaded in the MS or external spool

It depends on the personal workflow but

For using external spool i want to load and start print sometimes to extrude extra filament especially after using PETG , and start the print straight away - so immediate turn off does not help

For trouble shooting turning off the nozzle , and then going through the menus and turning it back on is a hassle if you print often and changing filament often you may find that is benefitable not to turn it off

What would be a worry and a bug if you load the filament and after timeout period does not turn off( when you forget / or delay the print start-up) Which works just fine. Just leave it for a few minutes and will see that will turn off the heater.

Any way it is a personal choice but i do not want this to be changed the way you suggested
But don’t mind if Bambu add a configuration option for that behavior, and for the timeout, with default current ones

Maybe this is just a miscommunication here. I wasn’t saying that the nozzle is oozing onto a print. I’m pointing out that when you click load on the screen, it will do the load process and then just sit at the back with the temperature set at basically printing temp or near it. As you specifically mention start up gcode, there’s no reason you’d want to start with the nozzle at printing temp. The startup sequence actually keeps the nozzle well below that point until the bed is up to temp. In reality it takes like 30 sec to heat the nozzle back up to operating temp so that’s hardly a time savings. It is a problem in that if you want to load something up like ASA before you heat soak the chamber to make sure you don’t have PLA in the hotend (which could lead to a clog if not expelled). During that heat soak, I don’t want the nozzle sitting at 220-240. It seems completely unnecessary to leave the set temperature of the nozzle that high.

After doing more testing it looks like it holds the nearly printing temp of the filament (set to 220 after loading PLA) for 5 minutes. Then instead of turning it off (set to 0) it instead set the temp to 38C. This doesn’t seem like intended behavior.

Again, you are wrong. If the head is moving and the nozzle is oozing filament and the print head is not actively extruding material your temp settings are 1000% wrong for the filament you are using

The PAIN again :frowning:
I installed the latest firmware and yes not turning the nozzle heater off the after the Safety timeout , leaves it at 38C this is a bug( load from AMS) or some one from the Bambu was not thinking. Please report it . It was ok in the older versions not sure when was broken or changed

Also i confirm that after loading the filament 240C print they use +10C (250C) and then they reduced to 220 from the requested filament 240C( ASA ) or -20C to reduce the leaking, but makes one of my arguments and requirements not fully applicable, they actually use the -20C for cleaning to reduce internal volume and pressure, but not implemented properly for this specific case, other wise very clever idea . Some times is difficult to cover all cases

REAL BUG : After 5 minutes of loading the filament and the X1C is inactive for 5 minutes does not turn off the heater completely instead sets it 38C. This is a safety requirement Broken in

This same bug, does the same after unloading filament, hot end stays at 220 degree.

This error seems to originate from Bambu Studio and not firmware.

It did work ok for me but after the next print finishes will try it again .