P1s is not detecting filament

I already replaced the extruder/filament sensor. The printer does not detect the filament when fed by the ams. I can print via an ex t ernal spool as the filament is not detected automatically

I am having the same issue.

I’m also having the same issue, but I’ve tried feeding the filament from the external spool and the toolhead is still unable to detect that there’s a filament being pushed into the extruder

i reverted my firmware to and that solved the issue

I reverted back to firmware but still having the same issue. Any other suggestions would be helpful

Did you install Something like that?

Really helps.

for me the issue was not getting the filament to the detector. the issue was the detector detecting it.i did print something similar out of pla. it broke a while ago and i never replaced it.
i previously had issues with a y splitter so i could use an external spool without taking anything apart and it was a problem. if you have one of those id get rid of it.