P1S Self Test New Printer

I just got a new P1S and the self test would fail with [0x0]. I tried an auto calibration, but it would not run and the printer would restart. I was finally able to get the firmware updated to the latest using the Bambu Handy app, and then did a factory reset and the self test worked. Just putting this here if anyone else sees this issue. I am excited for the new P1s


Update: I printed one print turned off the printer and came back 2 days later and now I am getting a “HMS_0500_0300_0001_0002: The toolhead is malfunctioning. Please restart the device.” error. I just swapped out to the new Nozzle (some comments suggested this) to see if that could help but no luck. I have contacted the support I will try to update with the fix.

Does anyone have ideas of how to fix the “HMS_0500_0300_0001_0002: The toolhead is malfunctioning. Please restart the device.”? I have all ready checked everything on HMS_0500_0300_0001_0002: The toolhead is malfunctioning. Please restart the device. | Bambu Lab Wiki.
I am still waiting for support to contact me back.

1 Like

Sorry this doesn’t address you issue but I got a P1S a week ago and I don’t see a reason to power it down. Just like all the other home vampire devices that stays on. Unless I find that it’s drawing a lot of current….

I understand why you would like to turn the printer off; it’s not the most power-saving device. (12W at sleep)
Did you try to reseat all connectors in the print head? Sometimes, these connectors need to be seated more than once.

Thank you both for the advice. I have tried to reset all the connections a few times know. It is just strange that it worked fine (Once I got it working out of the box) for one print. And now I get a tool head error and I cannot do anything. It did not move between power cycle or anything. Just turned it off one night and on a few days later and the tool head error popped up. I have also reset to factory default, ran a “Self-test” and that came back fine. I went to the device on Bambu-hub and it had the error still.

@dean448 Did you have any strange issues with yours out of the box I got mine last week as well. As I stated with the first post it would not run the self-test until I got the firmware updated. I am wondering if I got a bad one or if something happened in transport. All of the packing material was there, and it was very secure.

No pulled it out of the box turned it on and it automatically did an update and test. Loaded studio on both a pc and my phone. Connected the AMS then tried to print a model off the front display and rear coil.
Realized that you can’t plug the AMS in and load from a coil, unplugged AMS and it printed.
AMS gave me some issues at first but in the end all four coils are working. I think the AMS will be the one weakness, if one come up.

For what ever it’s worth I picked this unit up. It wasn’t shipped to me.

Another for what ever it worth… I put the printer on the most stable platform I have.

Thank you for the feedback. I was able to get to printer to turn on without the error. There was a cable on the MC board in the back that was loose. I plugged that back in and the Toolhead error was GONE!! I just printed a 2-color print with the AMS. The only issue is the PLA was not sticking to the textured sheet. I had to use some glue stick and it worked perfectly.

1 Like

Fantastic. You would think they would have fought that or it came loose during shipping

I can’t get anything to stick to that textured plate without glue. I was thinking about trying alcohol but when I just rinse it with water, if it does stick to print, I find that it’s barely adhered to the plate. Still trying to figure that out and I won’t be surprised if glue wins long term.