Possible Bug - AMS Filament Descriptions

I believe I found a possible bug with the AMS:

  • I added non-Bambu filament to the AMS
  • Using the Handy App, I selected what filaments and colors were in each slot
  • I made a successful (sort of) print
  • The next day, I reloaded the AMS with filament in different locations/and colors
  • I changed the filament locations on the AMS through the Bambu Studio Application
  • I Sliced the print using AMS A4
  • Sliced preview showed AMS A4
  • I sent to printer
  • Send shows AMS A2
  • I synced the AMS
  • AMS shows A4
  • Slicer shows A4
  • Send to print, shows A2

To remedy the issue, I had to manually change the filaments one more time through the Handy App.

Anyone else? I plan on using Bambu filament in the future wherever possible; but, I can see this being a slight issue.

1 Like

I have the same problem. I hope they have a solution to make it seamless.

Hi @christianglong,

Concerning your solution, I cannot foresee a better one. AMS was designed for Bambu Lab filament, so you will get the best performance and reliability. It is only a question of if you can and want.

Nonetheless, it is not mandatory. I successfully use both BL and third-party filaments in the AMS. Many third-party filaments demand tweaking, such as changing the spool, but many solutions work well.
I had some minor issues with AMS, but nothing similar. However, it seems that you are not the only one. I tried to replicate the steps that led to the problem occurrence, but it is not easy to do it, as it entails many actions carried out in different apps; additionally, your procedure can outcome in distinct behaviours depending on the AMS settings, specifically the “Insertion update” and “Update on startup” options and the use of sync and resync.

I may try to check if mine fails to if it is a simpler or at least more straightforward
procedure.
Is it a one-time occurrence or a systematic error?

So far only once but that is likely. Eva use I am watching for it.

I did have an error today when the AMS decided to use a different slot altogether.

I’m having a similar annoying bug wrt the AMS. I have 4 rolls of ABS, red, blue, grey, white. I slice a part using red ‘A1’ when I click print the filament show red, but below it is A3 which is grey. Out of pure frustration I yanked the grey out, then it selects A4 ‘white’. I’ve been using the latest FW and BBS for about a week and this only appeared yesterday.

@christianglong, that’s good. I tend to ignore a one-time issue and not a severe one. It is hard to debug without further instances or error codes. Recently I started to take note of the occurrence day, as it may be relevant in future (e.g. trouble ticket). Hopefully not the case.

@duane777, are you carrying flow dynamics and rate calibration?

Mmm something to think about, I did calibrations on 3 spools but after a power cycle they are not applied to slots anymore. So I don’t bother assigning those each time. I did select one of the previously saved calibrations for the new spool and left the others blank as I was only printing in one colour. I’m considering going back to 1.05FW and 1.6.x BBS as I had a much better experience using those versions. Give them a few months to iron out all the new bugs 'cos it seems like they’ve added a bit too much at once in this latest update, all “nice to have’s” but I didn’t really need any of that before. I also had far less print failures with those.

@ZayZay After thinking about it some more. I thought maybe it’s because I used the flow dynamics I had for grey, since I haven’t cal’d the red spool yet, it may have matched the slot that way. So I tried a few permutations of unassigned calibrations in 2 slots and 2 slots with the correctly assigned calibs.
Sadly this produced the same results, where unassigned red still wants to be slot3 grey. But unassigned white stays on it’s correct slot 4.

It is always a solution; how are your AMS settings regarding updating filament? If you go physically to the AMS or through the slicer, can you find your previous calibration settings?

The same question regarding the AMS update settings.
Mine are below.
Both your descriptions seem that you have the update on startup.
Look, I also had some issues with config; for example, pressing resync instead of sync disconnects the link between AMS and slicer filament. I am still learning how to use it, but it seems to work after getting used to it, with the potential for improvements.

Same as yours but I had AMS filament backup checked.

Sorry for not being able to help, but at the moment don’t recall anything else.
What OS are you using? I use both Windows and macOS, and the calibration parameters are editable and updated symbiotic.
However, a macOS user posted an issue because of not being able to change the calibration settings on macOS.

I’m on Ubuntu 22 and Mac OS but I mostly use linux

I only use Linux for my other printer to run Klipper.
Since it can be an issue of the slicer, you will get faster and proper support in the GitHub repository. My experience there has been great, as most of the problems are already being discussed, and official help in a matter of hours.
However, it is exclusive to the Studio software.

I think I figured it out. The red filament profile was based on the grey one I’d previously created. If I sync the AMS so they all show Generic ABS then make the changes to the generic abs profile one and save as my brand red it all works correctly. There may be some other settings in the filament profile that we can’t edit in BBS.

Good to read… yeah the process logic is discussable. I got confused regarding saving preset names; even now, I wonder if it makes sense. But after understanding it is practical.
So have yourself a good marathon of filament calibration …