Potential bug: bad layers when priting multicolor objects with AMS

Hello there, I’m facing a strange bug that seems reproducible:

I’m trying to print a very simple 3 color object with my P1S and AMS unit.

First layer goes well, but then starting from the 2nd layer, it seems that the infill is not touching the walls leading to very poor quality and a LOT of under-extrusion.

I’ve tried countless fixes and tests to try to isolate the problem as it seems it is flow or speed related (filament calibration, drying filament, reducing speed, etc…). Nothing helped. Then finally found how to isolate the problem:

Here comes the funny part: the problem arises ONLY if I’m using the AMS to do multicolor. If I start the print with the 3 colors mapped to a single AMS slot color (lets say White), print seems fine and infill looks WAY better.

I’ve tried multiple times to perform a full color print → fails all the time.

Then, tried the same print (same profile, same everything) with colors mapped to a single slot → looks beautiful. I’ve always stopped the print after 2nd layer to show you, there was no point continuing the print to the end as under-extrusion led to very bad layers.

I’m convinced at this point this is a slicer bug, but I would like to have your opinions on whether I’m failing something and if this can be solved.

I’m using a P1S with AMS loaded with official Bambu Matte PLA.0.4 nozzle, PEI gold plate. Standard 0.2mm profile, no overridden settings.

I’ve sent a technical support message to Bambu, still waiting for their answers.

Am I really stupid and missing something here or what?

Many thanks to your help.

1 Like

Salut, je pencherais pour le facteur K qui ne serais pas bien régler, moi ca fonctionne bien le matte pla avec .030

I’ve also tried to calibrate and 0.03 is also the best for me. I think I wouldn’t manage to print correctly with one color if my K factor was wrong. But it is working perfectly if I print everything using white.
It’s seems to be a big that only happens when printing multicolor, almost as if the K factors were messed up.

Figure this out? I am having similar issues… But even odder it’s only happening if slot 2 is adding into the multi color. Same thing with you though, if I print all say 3 colors from slot 1, perfect print. If I do 3 colors from slots 1-3 when slot 2’s color comes around it under extrudes horribly.

I have confirmed the bug with Bambu Support after 10s of back and forth and still waiting for a fix.
No news from their side, aven though this was reported 2 months ago :sob:

hei, i got the same problem. have you fixed it?

Yea, I am here looking for the same info. My AMS is frustrating me a lot the last few days.

I am having the exact samedi issue when turning on the slot 1 and 2 in AMS for multicolor printing. No issue when printing with slot 2 only. I’ll see if printing with slot 3 and 4 works.

I’m sorry guys. I haven’t had any news from Bambu despite many many many emails. They just don’t care. I gave up and moved on :man_shrugging:t2:

I’m not sure if my issue would be related to the potential bug or not, but I tried printing a model with four components in two colors. It’s about a 3 1/2 hour print and after four attempts they all fail around the three hour mark. The models are small cone shaped objects with a relatively small contact surface. The layers begin to get ugly and then ultimately one of the the cones breaks free from the bed. As I’m typing this it dawned on me that my issue may be because I didn’t use brims. I did add some manual tree supports but they didn’t help.

I’m sorry if I’m hijacking the topic, but would using brims potentially solve the issue or does this sound like the bug that the rest of you are experiencing?