Print by object clash

I think this problem is unique to x1 and x1c

The current head clearance is not adequate for the X1 lidar.

Video Added

Seems like your picture didn’t upload properly. Also, if you upload your video on google drive or dropbox you can link it here.

Howdy mates! :space_invader:

Epic level Noob here, stumbled over this right now.
I’m fiddling with 2 full build plates, with millimeters apart, would my plate be excempt from this problem?
(I mean I have not activated or even know where the Print by object Clash is, it’s not auto on from start I hope?)

Anyhows, great joining a lively forum!

May the force b with you mates!

/Silverbullit a.k.a. Tobbe :+1: :partying_face: :+1:

Until they correct this bug or make clearance editable, you can adjust extruder clearance in Bambula/Softvever fork :

1 Like

Or you can try to edit :

The clearance is stored there.

Why would you want to risk a crash by printing a single object then moving on to the next instead of doing the whole plate at once?

less color swaps with objects in different colors.

Second this, had this problem, too. Unfortunately I couldn’t reproduce it with small test cylinders. Are you using the actual slicer version?

1 Like

There are many reasons to do that, e.g:

  • you only use 1 item, not the whole plate, if something goes wrong /filament runs out/ etc.
  • no stringing between objects / better seams /less travel moves /less retractions
  • less color swaps (already mentioned)

And some reasons against it:

  • more cooling issues when objects are small
  • you can’t wait if the first layer finishes well when overnight printing
  • less objects on the plate because of needed clearances

So it really depends on the job to be done, but I use this mode regularly.

@Silverbullit : No, doesn’t hurt you unless you turn it on. But this shouldn’t be your top priority when learning 3d-printing :wink:

it’s not a risk if you have any idea what you’re doing. If I’m printing multiple parts I almost exclusively print by object.

10x faster if you print two objects with differents colors not to mention the quality is always better if you print sequentially

EDIT: and as other already said, if one fail, often you dont loose the others.

Image still disapear sometime, like the first post of this thread

NB: It can be see when clicked

Thanks for this! On my X1C the clearances are set way higher than physically necessary, but not quite as big as the LiDAR.

Or rather, they’re set to about the physical dimensions, but the slicer won’t let me overlap the clearance zones so that parts end up being nearly twice as far apart as needed. And it won’t let me slice if there’s any theoretical overlap of clearance zones.

This way I can adjust them so that they’re not doubled and I’ll just have to pay attention to things a bit more.

I have been trying to change these settings to sequentially print a very thin and narrow part that only need a few mm of clearance for the hotend to not clash with the previous part. However, I am struggling to get the software to actually reduce the default settings.

I have tried the bambustudio fork without results. (changing values doenst change the behaivoir in the slicer.
I have tried changing the textfile for the standard bamabulab as suggested in the thread and while the numbers then change they are still greyed out in the bambu studio. BUT the behavior of the slicer still doesnt change. THose large radiuses still exist that prevent me from printing more tahn 4 parts on a plate.

Any ideas?

I think customised keepout area are a bad idea. I just want them to be right.

Maybe with a cool way to do taller parts individually by positioning them front to back. So the x axis rods don’t pass over previously printed parts.

In my case it makes all the sense to print them with small clearances in sequence. Ninjaflex being best rpinted sequentially due to stringing otherwise. I understand the risks and the default vlaues are good to have, but it would be nice to be able to change them for nische cases like mine.