Question about Start G Code

Some of my PETG filament ooze more than others. And sometimes it ruins the first layer.

With the start g-code, it prints two purge lines. After purge line 1, the nozzle moves to the middle of purge line 1 and make a pause - it ooze. Then he moves to purge line 2 and leaves strings over the whole print bed.

How and where can I change the start g code, that this “pause” is not on purge line 1? he should do that at the start of line 2 and I would like to do a second nozzle wipe before line 2 starts printing.

There might be what you are looking for in this link. Throughtheframe has done a lot and keeps it up to date.

I saw that already and its not that what i’m looking for. I dont know why the printer moves to the middle of purge line 1 and make that pause…

I dont find the location in the Gcode :confused:

I found this one also

I removed the whole gcode for lidar (which I done use) and it works now :slight_smile:

But there is on thing. Does anyone know which “M106 PX” the chamber fan is?

M106 P3 = Chamber fan
M106 P2 = Aux fan
M106 P1 = Nozzle fan

You can also edit the chamber fan speed in the filament setting start g code but most likely you know this already.

M106 P3 S127 @ 50%

What you are calling the purge line is called the noozle load line in the P1P start code.


Most typos I can gloss over but that one is funny.

That is why I copied it from the actual P1P gcode.

Hahahahah this is a very good idea :stuck_out_tongue_closed_eyes:

I have been have the same issue with the start purge line. What did you change in the G code to turn off the Lidar?

Here is my gcode

If you search for " mch " in the code, you will find my changes

Thanks. I’m still new to editing gcode. Which one do I change to stop the Lidar scan on the start purge line?

Dont check “Flow Calibration” when you send the print job :wink:

I did a flow calibration on Orca and set my flow to 1.01 on mine so I don’t check the flow calibration anymore.

You know how on the start purge line it pause to does a lidar scan and oozes. I was wondering what did you change to turn off the lidar on the start purge line to stop the oozing?

Check out my modified start code here: Request: Faster print start - #21 by rshea0

I got rid of that delay. I still have some more tweaking to do but it’s good enough for now.