Some filaments resetting after AMS sync

When I start a new file in Bambu Studio, my filaments load as shown in the image below. The problem is, some of the filament types are incorrect (I have only one ABS spool loaded).

If I sync from AMS, the list corrects itself, but I can’t find a way to save this change. When I start a new tray, I have the incorrect list once again, and if I don’t notice then I may accidentally begin a PLA or PETG print with ABS settings.

Does anyone know how to commit the information after a sync?

image

It is supposed to start up with whatever filaments it had last time you ran it:

  • Loading a 3mf with an “incorrect” set of filaments and then quitting, will save the “incorrect” set for next time you start Studio.
  • If you start Studio, do a sync, quit and then restart Studio, the synced list should be there. If it’s not, I have no idea why.

On the other hand, there’s no need for your list to reflect your AMS. That was never the intention, instead it should be a list of what materials and colors you need for the model at hand. The only matching between them happens when you send a print - and that will work just fine regardless of order, as long as the materials and/or colors are loaded in some slot, in some AMS unit.

I tend to click the “-” sign until I only have the number of filaments actually needed for my model (most often that’s just one). This helps my brain to stop wanting the list to resemble every filament in every AMS unit I own, in the same order - for no real reason.

1 Like

something is wrong for me also… doubled checked the sliced model and everything is fine… when i started the print we looked and the colors where all good on the printer… unfortunatly it swapped the red and blue colors on my pepsi logo ? 14hours print to come back and see that the colors where swapped and then we started the print again same slice and same gcode… printed in the right order … whats going on with the ams on our a1 ? thanks

Im having the same issue and its very frustrating.

Once synchronized in AMS, to capture the thread information, you can try the following: Open Bambu Studio settings and go to Materials or Thread Settings. There you should find the option “Save settings” or “Lock thread list”. Click this option to save your changes and prevent the thread list from accidentally changing each time you run the file.

I’m not following, could you please show a picture of what settings you mean?

I don’t see the settings you indicate. I don’t see “Bambu Studio settings” anywhere; I have the preference window as shown below, but it does not have the features you’re talking about.

image