Strange problem just developed!

I’ve had my X1C for nearly 1-1/2 years and printed over 3000 hours and haven’t had any issues that I couldn’t fix. But this one has me stumped. The printer has started printing terribly went printing in the direction of -Y to +y while it prints perfectly from +Y to -Y. It also cannot properly print arcs. See the attached pictures.

I have re-calibrated, adjusted the belts, replaced the extruder and hotend, dried my filament, and anything else I can think of. I even tried downgrading the firmware just to see if anything would change, but to no avail.

See the pictures below: the left side of the straight sections are fine, but the other side (when the travel is in the opposite direction) is a mess.

I have submitted a ticket but I have know idea how long it will take for a response.

Please, if anyone can help, please let me know…

Something in the belt path is loose. A pulley/idler maybe that can move in one direction, like it’s sitting in an elongated hole. So when the belt pulls on it one way it stays where it’s supposed to but when the belt tension reverses, it moves and the belt loosens up.

Yank on the belts while keeping the printhead from moving and see if you feel more slack when you pull in one direction vs. the other… or just tug on the belts and listen for something rattling and then track whatever it is down and make sure it’s not supposed to rattle. :slight_smile:

1 Like

My first guess would be extruder motor. as the head goes in one direction, it compresses the filament inside the ptfe tube. When going in the exact opposite direction, its straightening the filament back out. In the 2nd direction, the extruder has to work harder than when moving in the first direction. Could also be extruder gears. Otherwise, i think you would have seen a slow progression.

I’ve tried RocketSled’s idea and can’t find anything wrong. Nothing loose, no noises. All mechanical bits seem normal.

I’ve also tried StreetSports idea by changing the extruder motor, but no difference.

Still waiting for a response to my support ticket, but I suspect it will take many more days…

I have production to run and I’m nearly at wits end. Anyone else have suggestions?

I think your belt tensioner bracket is loose, did you tighten them after doing the belt adjusting procedure?
Just my 2 cents worth.

Considering the information shared, and the number of hours the printer was used, it would be recommended to start by cleaning the carbon rods.

Please follow this guide for cleaning the rods.

Two very important items to do:

  1. Ensure the belt tensioners move as shown in the video
  2. Soak the carbon rods in IPA, then move the print head a few times before wiping the rods (to ensure IPA reaches inside the bearings and cleans them)

After you repeat the wiping procedure 2-3 times, perform a full calibration from the printer menu and try to print one of the pre-sliced files to validate if the problem can be replicated.

Of course, it is recommended ensuring the hotend is cleaned and a few cold pulls are done. If the extruder was not cleaned in a while, it is recommend opening it and confirming everything is clean and greased for best result.
Finally, try a different filament to see if this changes in any way

In case this solution doesn’t solve the problem, please leave a comment to your open ticket with your findings, and our team will assist you further.

Good luck!

1 Like

Speaking as someone with a lot of experience troubleshooting such issues, while previously working escalated cases of such problems at Markforged…

Have you printed filled filaments (glass or carbon fiber in particular) through the extrusion system?

It’s quite possible that the developed pressure at the print head could be wrong if the tubing is worn out, and therefore the friction of pulling the filament through the tubing is too much when it’s going through certain portions of the motion path.

In short, the inside of the tubing could be pinching the filament, reducing the ability of the extruder to drive the filament at the right pressure.

What filaments have you tried? Any filament-to-filament differences?

Also, it could be an improperly set compensation on the hot-end/bad thermistor settings, that could have the wrong “gain” on the sensor leading to bad hot end temperature readings.

This is less likely since it doesn’t address the difference in performance by extrusion direction, but it’s possible that the temps are off. A temp tower print might help you isolate the issue by seeing how extrusion performance varies with temp.