The nozzle temperature is abnormal,the sensor may be open circuit

I just got this P1S printer and it worked beautifully for 2 days. Then some filament got stuck in the extruder. No big deal, I removed the stuck filament after removing the hotend assembly and put everything back together.

After turning the P1S back on, I get this error:

HMS_0300_0200_0001_0007 The nozzle temperature is abnormal,the sensor may be open circuit.

There is a link to resolving this issue and it takes me here.

https://wiki.bambulab.com/en/x1/troubleshooting/hmscode/0300_0200_0001_0007

So I went through those steps I don’t know how many times - still the same issue.

I’m wondering if I have a wiring issue. I took a picture of my hotend - see the oddly sticking out wire(s):

Could this hotend wiring even cause the issue? I have no idea which wire does what, but I’m tempted to try to re-wire that harness - or is that a waste of time?

I filed a ticket with support - haven’t heard anything and it sounds like I won’t for some time. This printer isn’t working at all in the meanwhile.

I’ve had this printer for all of 4 days and it’s already non-functional. I’m worried I bought a $1000 paperweight.

The printer came with a spare nozzle. Use it and see if the error goes away.

1 Like

Yes, I did try that, thank you. I’m still getting the same error.

You turned the printer off when plugging/unplugging this connector?

When changing out hotends I have had instances where the connector wasn’t seated firmly. It’s usually pretty obvious when you turn the printer back on as the display shows a hotend temp of “0” instead of the ambient ~28 degrees it usually is. I will then turn the printer off and reseat it.

It also helps to actually push the 4 wires under the wire clip on the extruder housing before you plug it in. I have noticed that if I leave those wires out of the clip (as I did the first few changes) it often will result in a bad connection (and error). I now always push those 4 wires behind the clip first. Then connect the 4 wire connector and plug in the fan connector (I don’t bother putting the fan wires behind the clip) on top of it. Then I push the hotend up into the tool head body and secure with the screws last.

One more thing of note here, the way that connector is designed on the P1 series, it is possible to plug in the connecter incorrectly. Since both the top and bottom pin arrays are the same, I have accidentally connected the top pin array in to the bottom part of the connector. I noticed it before turning the printer back on so I don’t know if damage can occur.

I would be willing to bet it’s just a poorly seated connector causing your issue.

Yes, I make sure to turn off and unplug the printer before changing any connections.

The behavior I’m seeing is exactly as you described. I did what you suggested and made sure the wires were inside the wire retention clip before plugging the hotend sensor back into the board and double checked that the connector was seated correctly - I’m still getting the same error.

I’ve plugged/unplugged that connector at least a dozen times as well trying to get it to read the nozzle temp.

I also hold the tool head and push hard on all the connectors with my thumb to make sure they are seated well. I assume you’ve tried this since you’ve repeated the steps several times, but it’s worth mentioning.
Did you unplug any of the other connectors on the tool head (they have metal backing plates) in your effort to clear the extruder clog? If so perhaps they need to be reseated as well.
I’m not sure if the thermistor data is handled on the toolhead board or it just passes the signal through the cable chain bundle.

You may just have a bad thermistor or damaged wire.

You can order replacements from Bambu Lab:

Or if you’re in a hurray Amazon sells them too:
(https://www.amazon.com/Thermistor-Ceramic-Cartridge-Bambulabs-Hotend¡­/dp/B0CSZCYKBK?th=1)
There is an option to buy the thermistor/heater combo only.

If you have a mutli-meter you could test the resistance of the thermistor to know for sure.
I don’t know the pinout or the resistance, but I have some spares so I’ll go look.

The pins for the thermistor on the 20 pin connector for the P1 series:

Outside leg of the thermistor: Pins 6,7,16,17
Inside leg of the thermistor: Pins 4,5,14,15
Thermistor resistance > 90K ohms at room temperature

Thank you for the suggestions Lexi. I’m beginning to think it’s the thermistor as well. I have ordered new parts and still have that open support ticket with Bambu.

I’m going to try and dig up my multi-meter and test the thermistor I have - not 100% sure on how to do that though.

If you look at what I circled in my uploaded picture, you can see the exposed wires on the head of the wiring harness - maybe they are not actually wired in??

I looked at your picture but I didn’t quite see what you are referring to.
Here is the connector from one I purchased from BL:

Does your connector look drastically different?

To test the one you have, select the 200K resistance range on your multi-meter.
Touch one lead to the any one of the 6,7,16 or17 pins and touch the other lead to anyone of the 4,5,14, or 15 pins. There are numbers on the inside of the connector near the 10,11 and 20 pins.
It should show something around 90 (which would be 90k ohms on the 200K range) or higher. If it doesn’t seem to change, it’s probably an (open) broken circuit

OK - tried testing with my multimeter - an older version of this one specifically: https://www.homedepot.com/p/Commercial-Electric-Analogue-Multimeter-M1015B/202353292

It doesn’t have 200k resistance, so I tried pins 14 and 17 set at 2k resistance. The voltage red more like 25k ohms, which would be quite a bit lower than what you indicated. I suppose it’s probably that and worth trying to replace at least.

Here’s a better closeup of the wires on my connector:

IMG_1997 - Copy - Copy

As you can see, the wires on the far left and far right appear to be poorly connected. This is at least what I am suspecting for now.

Thanks again for all your help, Lexi. Let me know if any other ideas pop up.

Yeah, that particular multi-meter doesn’t have a high enough impedance range to get a good reading.
I hope the replacement fixes your issue.
It really is a great printer. It’s a shame you’re having an issue with it and so early on.

For anyone looking at this question, I did end up figuring it out: I ordered a few replacement parts and replacing the TH Board FPC cable fixed this error. It had ripped ever so slightly that I hadn’t noticed it.

I am back to printing with no issues.

Thank you again Lexi for your helpful suggestions!

1 Like