Top layers issues

I shouldn’t need to, as I’m printing files from the same era as the FW I have tried :frowning:

Meanwhile, it just gets worse. This was printed on SLOW. A couple of weeks ago, this top surface would have been perfect :frowning:


And to add to my woes, the machine continually asks me to adjust the X axis belts. Which I have done. Four times in a row.

Recalibrate! If your using the newest firmware do not use an old sliced file. Slce it with the newest version of bambu labs. That should take care of belt issues.

I have the exact same issue.
I have 5 other bambu printers setup the exact same way, and they print the files fine, but that 1 machine does not. I swapped print heads, cleaned it up, re sliced files, everything. The way it does supports is not correct, and the top layer seems thing and you can see the grid lines below it.
ANY IDEAS ANYONE?

By any chance are you using ironing?

no
the other p1s machines i have print the file fine, all have latest FW, clean new nozzles
the ps1s with AMS prints it fine

its that one p1s just started doing what the guys talking about, the print looks great other then the uneven top layer, like you can see whats below it, almost like the z offset is wrong
i have cleaned the machine and recalibrated many times

Silver - the problem with recalibrating and not using an old sliced file is this; firstly, I have recalibrated and recalibrated and recalibrated. Secondly, the print pictured was from a newly-sliced file! It does this on EVERY print - old, new, old FW, new FW, every filament I feed it etc etc. I mention old files because a few weeks ago it absolutely did not do this, and now it does.

Not using ironing either; for some files I do, but not these. But then, for most files I have never had the slightest need.

It does look like it is ONLY the uppermost layer(s) that I am having major problems with; no Z wobble or banding during the print. Other things might be happening in the layers beneath, but they’re not showing up.

After the current job (yes, this is a work machine) I’ll print a Benchy; I bet that it’s perfect EXCEPT for the top layer.

EDIT - Before trying a Benchy, I ran some specific cleaning filament through the machine (at 240 then 230). So now it’s printing AOK again.

Lesson learned - don’t blame anything until you have adjusted, calibrated and cleaned the machine properly. And “properly” means with things like cleaning filament, apparently - not just cold pulls.

1 Like

Mine do the same thing, I can print the same code on the same roll of PLA, with a new print head, and the it turns out like the black example, all my other P1P’s are like the red example of supports and top isnt as thin. Ive recalibrated, ive swapped PLA rolls, Ive re sliced, changed heads everything. ANYONE?

I don’t know if any of this will help, but I’ve always gotten pretty good top layers. I have 4 P1S’s and they all perform about the same. Here’s a few of the things I do for top layers (using Esun PLA+ and Voxel PLA:

  1. Top Layer Line Width: 0.3
  2. Top Surface Pattern: Monotonic Lines
  3. Top Surface Speed: 50
  4. Top Surface Acceleration: 500
    Layer Height is 0.1 (except for the first layer which is 0.2)
    Classic Walls
    Only 1 Wall on top layers
    If I need a smooth surface, I also iron the top most layer with a flow of 8%.

Like I said, this might not be of any help since it sounds like top layers were printing good then just suddenly started messing up.

EDIT: Probably not relevant, but thought I’d mention it. Even with the newest software and firmware, once or twice I’ve gotten some horrible prints (‘missing layer’, layer shift, etc.). Re-downloaded the file and all worked fine. I think I remember a notice about BL fixing some issues with unpacking the files, but apparently it’s still a problem on rare occasions, at least for me.

1 Like

What do you mean by “cleaning filament”?

Something like this: https://www.amazon.com/eSUN-CLEANING-Filament-Printers-Cleaning/dp/B00MVIYNFW

When switching between high and low temp filaments, sometimes they contaminate the hotend/nozzle. Running this “cleaning filament” through at 300 C just sort of sucks it up and pushes through as much as it can. Then, cold pulling the rest which will probably have more gunk on the edges pulled from the inner walls of the hotend. I don’t think it can get any cleaner than that. :man_shrugging:

If I’m still having problems at that point, I replace the nozzle.

Hello guys,

I’ve performed all tips given in this thread, and even swapped full hotend assembly with a brand new one.
Printer and firmware are up to date.

And here’s below the results of flow calibration:



As you can see, no one is fine!
I’m a little bit lost of what I can do more to solve this issue …

Did you recalibrate the K-Factor for your filaments?
After the software update you have to calibrate your filaments. Without that step your K-Factor is set to 0,000 which will result in under-, and overextruded sections, depending on the speed of your print-head at that position.

Check your device Tab in the slicer and then look at the Text in the spools in your AMS picture to the right. If it says " PLA K 0,000" you did not calibrate your filament.

Open the new tab in the latest slicer and calibrate your K Factor and also your flow afterwards.

I felt so stupid when i realized this because i also suddenly had underextruded prints

Can t upload a picture for some reason so i hope it helped

1 Like

Im the same boat
same model, sent to multple p1p’s, same filiment, same settings
but ONE of them always does that all others are fine.

Anyone found the solution? I have the same problem for more than 10 days and it sucks :frowning: I replaced nozzle, cleaned extruder, cleaning whole machine, calibration for many times.

I’m not saying you have to restore the factory settings if you’ve done a firmware update, but that has solved a lot of sudden and unexplained problems.

I made couple good prints after the last update and then everything was bad.

Settings->General->Restore factory settings fixed my issues.

Bambu filament calibrations stored on the printer will be lost.

That’s what sorted my issue. As can be seen in my pics upstream, the top surface was awful; once the machine was reset, it was back to normal.

Mind you, I didn’t remember to restore the factory settings after the most recent FW update, so it might have only been an issue with the FW releases earlier this year.

1 Like

Chcecking it now, will let you know, thanks.

Unfortunatelly it does not help, even get it worse i think. I also disassembly AMS and saw used PTFE tube, replaced all of them in hope that it will help, but it does not too :frowning:

This may not fix your problem but if you have tried everything else try this. Revert to the old firmware and then update again. The only reason I am saying this, at work some times when we do an update or download machine settings they do not take and weird things happen until we do it again. If there was a way of just dumping the update in again I would suggest that. Good luck and I hope that helps.