Top layers issues

Hello all,

Since few days I noticed the top flat layers are deteriorated. As you can see in attached.

I use to print this part many times perfectly before this issue occurs.
I have 2 bambulab X1C, and the other one prints it correctly. (Slice parameters are the same for both printers)
All calibrations are marked before each prints.
Hotend has been replaced around 100h ago.

Material is ABS polymaker and I guess my parameters are fine since it has already print it correctly.

Do you have a clue of what is wrong with this printer specifically?

Are you using the AMS when you experience this problem?

It’s under-extruded for sure, especially in the higher-speed areas. If you are positive that you have exactly the same setup (settings, filament, hot end, etc.) on each printer, then I would look first at any issues in the filament path. The AMS, as @Venom mentioned), or perhaps the extruder gears/motor or the hot end. I would think that it’s not the extruder skipping because it is consistently under-extruded where the speeds are the same, but if you are not putting out enough filament, then this should be checked.

Is it only the top layer that seems to be printed incorrectly?

Have you ever disassembled the extruder?

On a whim, you might try the new version of Bambu Studio (or the 1.6.3 OrcaSlicer) if you are not already on those releases. I recall some bugs being fixed in top layers, but I don’t remember what release that happened in.

Puzzling problem, to be sure. Good luck!


Thanks for your replies.

@Venom :
Yes I use AMS. Tried on different slot and the issue still occurs (Even PLA or ABS)

@Venom :
Indeed all top flat layers (Not only top most layer).

I didn’t disassembled the extruder yet, only changed the complete hotend assembly few weeks ago.
Should I disassemble it?

Concerning version i’m running and it seems there’s no upper version. BS said I’m up to date.

I’m actually running the same part on Orcaslicer to see how it goes?

Just one question: Is it normal to have 25% more time printing with Orca than BS?
I transferred all the printing profile so it should be the same? Or there’s something I miss out?

I had a similar problem and found that my boden tube was to long from my two AMS units with to many bends. This can also happen if your boden tubes become worn due to use with abrasive materials. Instead of stripping the print head, you can also use the thin nozzle cleaning pin to clean the nozzle out when the print nozzle is on temperature. Or you can do a hot pull to see if any burnt filament comes out of the nozzle.

Hello all,

Here’s what I did but still have this issue :confused:

  • Several prints with Orcaslicer (1.6.3).
  • Tried to print without AMS, directly from spool holder.
  • Cleaned nozzle and performed hot and cold pull of filament.

If you guys have another tips to suggest, don’t hesitate :slight_smile:

Thanks in advance.

I am in the same boat with two P1Ps.
A new one from July and one from March.
The older one with the same settings only works at 50% Speed equally good as the new one.

But i missed to do the maintenance in the first months and the hotend is not the problem. After doing the maintenance I saw at the Extruder Motor many black dirt thingies I could not clean anymore. I ordered a new Extruder unit and I will test it again next week.
Do the maintenance guys!

Mine’s just started doing exactly the same thing! After weeks and weeks of producing the same parts perfectly, last week it started to do as the OP has pictured - which leaves the top surface uneven.

I’m away at the moment, so don’t have access to the machine - and in the last few days when it started doing this I didn’t have time to investigate it properly.

But FWLIW, it started around the time that I updated the machine to the latest FW. Probably unrelated, of course …

I’d given the rods a good clean last week, but haven’t done a hot/cold pull for a while - that might also be part of the issue, as I’ve been using some silk PLA that was causing some clogs.

I’m left with 3 possibilities:

  1. Print settings. Can you post screenshots of your process and filament settings?
  2. Partial nozzle clog or a mechanical issue in the filament path. You’ve already done a cold pull, but try swapping the hot end and extruder modules out. I know you said they were replaced recently but that does not guarantee they are good.
  3. Extruder stepper motor issue. Not sure how to diagnose that one.

I’ve noticed the same issue with my top layers this past week. And I’m definitely thinking it is caused by the latest firmware. Not sure where I would report that, however. :man_shrugging:

It’s hacking me off, whatever the cause. Is there a quick (even temporary) fix that doesn’t involve me recalibrating my usual filament and then reslicing all of my files?

On second thoughts, I’ve rolled back the FW (which was easier than I thought it would be). Will try a few prints and see if that has solved the problem (in which case the FW is to blame) or whether the problem does in fact lie elsewhere.

1 Like

Thanks for trying this. I’m interested in hearing your results after rolling back the FW!

1 Like

What was the result of rolling back the FW?

Just this moment pulled it off my printer. The results were imperceptible between 1.0.6 and the older 1.0.5 FW.

Which leads me to think that the FW update and the onset of underextrusion was a coincidence, and my problem is either a partial clog, the extruder gears needing cleaning, or drag in the PTFE pathway from the AMS to the print head.

I’d been printing some silk PLA which can cause clogs, so that’s the most likely culprit. Despite my having done a few cold pulls.

1 Like

I’m a P1P guy, but I would be curious to hear if any of you having the issue have cleaned the Lidar lens yet? ABS and ASA will leave more residue on the lens than most filaments, and its possible the lidar is screwing up the results instead of helping.

I just gave my X1C a thorough cleaning last week. But today it popped up a message that the Z axis screws need cleaning. So I suppose I should try again and do a better job this time! :smile:

FWLIW, having eliminated the FW update as the issue (by rolling back to an earlier release), I ruled out the AMS (and pathway) from being the issue by printing direct from the spool. It still underextruded.

I cleaned the nozzle (with 6 or 7 cold pulls), disassembled the extruder and cleaned that with a dental pick. Put everything back together and I think its okay now.

I was wrong. It’s still doing it :frowning:

I’m still none the wiser, but I am seeing it CONSISTENTLY doing this. And the top layers are coming out pretty rough - like sandpaper (if sandpaper has very regular lines and grids!)

That - and a comment in the P1P Troubleshooting section - makes me wonder if the plastic isn’t melting enough (or is cooling too fast to melt into the layers below). I’ll whack the temp up 5-10 degrees and print some stuff - although why this is now necessary is lost on me; I’m printing from files I sliced a few months ago that were absolutely spot-on then, using the same filaments. The only things that have changed are the FW was updated (and downgraded, just in case), the hours on the machine have increased, and the passage of time. A couple of weeks ago everything was perfect.

1 Like

Did you downgrade the Bambu Studio, also?