Unable to bind P1P to account

Because I had a faulty AP board I had to wait a couple weeks to get a replacement, which arrived today. Thankfully the new board worked and the printer turns on and appears to be good to go.

Except I can’t get the darn printer to bind with my account. In either the Handy app or Bambu studio I get the following error:

IOT_ERROR_NO_VALID_DEVICE

The printer is connected to my local wifi and has an IP address. I should also note that I also have an X1C and another P1P that are connected properly.

Is this yet another quirk of the cloud based system? Any idea what is happening or how to resolve it?

Contact Support and tell them the new Serial Number of the AP board. They have to put your printers SN and the new AP boards SN together in their database. In my opinion this is a big f**k up, to bind AP board and printer.

Sorry forgot to update this thread. That’s exactly what I needed to do. These sorts of things are just maddening from a user perspective.

Hello all,
i would like to use this chat and not open a new one, because the description fits perfect.
I can’t manage to connect my printer, I have followed the instructions exactly, but the error message is always the same. I have also tried the help guide in Bambu’s wiki, binding P1 series printer with Bambu Handy and Bambu Studio, without success. Does anyone have any ideas?
I use a FritzBox with 5ghz and 2,4ghz Wlan, distance to the printer 2m.
Should I shut down on of the wlans?
To add: error is always SNxxxx not found

Have you tried contacting Bambu support about this, as described above by AndiS? That’s what I needed to do and it worked fine after that.

Finale it was so easy that I’m ashamed to tell it here in public. But maybe it helps somebody struggling as I did.
The only thing I had to do, is to allow the app, to have access to my location and to my contacts.
After switching these two on, applause applause, it connected finally in seconds.

This is because the pairing process uses the bluetooth on your phone.

3 Likes