Where am I doing wrong?

Hello I am modeling an AMS riser for the BLB X1C Combo. However, I could not print the color I chose for the icons on the buttons. I think you can better understand what I mean in the pictures. Please help me before I finish my filaments. :rofl:

This is odd. It’s hard to follow but I’m assuming the bigger cylindrical part is supposed to be black and if so, it does know which spool is black.

What I don’t understand is why the preview looks right but the print swaps black and orange for the thin logo layers. What if you reverse that assignment? I assume the preview would then look like the actual part you printed with the colors reversed but then it might print properly?

Just for background, I’m guessing you have printed multicolor parts properly before using AMS and are fluent with all the steps?

There’s also a popup before printing that tells you the color mappings it will use for the print. All looks ok there with black mapping to black and orange to orange?

1 Like

Thank you very much for your reply. I’ve been dealing with this for 2 days and couldn’t find a solution. Yes, in the AMS window that opened while going to the printing step, I selected black for black and orange for orange. I also tried yellow and gray colors, the result is always the same. At the end of the print, I get an error like my model is either completely black or orange.

If you swap orange and black assignments just in the logo layers where the preview looks like the part you printed, does the print then come out correct?

I don’t really have anything useful now beyond that. Hopefully someone else has insight.

Other than that, might do a bug report and escalate it?

1 Like

There was a thread a while back with a very similar problem. I’m just trying to find it…


I can’t for the life of me find the thread I am thinking of.

It’s a very odd problem as the base is printing in the correct colour but the top is swapped.

Are you able to provide either the 3mf file you are using or the STL parts so we can see if we can duplicate the issue?

Ofcourse dude I am sending now.

I’m trying to submit bug reports, but I keep getting an unexpected error message.

Very strange.
You would probably have checked this already but just to be on the safe side: What is your purge multiplier and purge volumes? Also, do you have purge into onject or purge into infill checked?
The reason for me asking is the 4th picture. It appears like layer top-3 is fully orange but layer top-2 is an orangeish black. And the parts on pic 5 do seem to have a bit of a mixed coloring.

Can I send the bug report via Google Drive link?

I’m getting a 400 error trying to download the file.

The server cannot process the request because it is malformed. It should not be retired. That is all we know.

Can anyone else confirm?

Thank you very much for your interest. I have done all the calibrations. As you mentioned, it seems like the nozzle is not being cleaned completely. For example, when yellow filament is loaded in AMS, the black color is not completely cleared from the nozzle and it continues to print black color for a while when it should be printing yellow color. I tried many settings and unfortunately I could not solve the problem.

I can download the 3mf okay and open it. It contains a lot of things, but not this button.


Sorry dude I am looking now

Downloaded the new 3mf and it’s there now. :+1:

1 Like

Buttons Parts .stl files

Then you may be able to fix this easily at the expense of more poop:
Click here:

Then, check that this is somewhere between 0.75 and 1 (the higher the more purge):


Slice and print.

You may want to be double safe though. So you can uncheck the purge defaults in the Others tab. More waste, but better chance of getting clean prints.


PS: A while ago I my purge multiplier in the slicer had a habit of resetting itself to 0. Sometimes the slicer does odd things.


Thank you very much, I’m glad to have you, my friend. My purge volumes value was 0.00. I said set this value to 0.90 and calculate again, and now I will slice it and try it.